aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-27 23:05:26 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-20 10:49:26 +0200
commit9dc60fe10fe812eb4d722d81351c74ec598cb114 (patch)
treeaa2544f28a1e8af088ab92e8cbb9cbb490e9436e /recipes-qt/qt5/qtwebkit_git.bb
parentd6fe20e6083d421cc6091892e1d302c46e2d075d (diff)
recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF
* this fixes builds for DISTROs which include no-static-libraries.inc * this change depends on oe-core change: http://patchwork.openembedded.org/patch/116719/ which was merged in this form: http://patchwork.openembedded.org/patch/120513/ to Yocto 2.1, if you want to use latest meta-qt5 with older oe-core you need to append EXTRA_OECONF to PACKAGECONFIG_CONFARGS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 04cefada..4e61cca7 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -35,7 +35,7 @@ PACKAGECONFIG[qtwebchannel] = "OE_QTWEBCHANNEL_ENABLED,,qtwebchannel"
PACKAGECONFIG[libwebp] = "OE_LIBWEBP_ENABLED,,libwebp"
do_configure_prepend() {
- export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}"
+ export QMAKE_CACHE_EVAL="CONFIG+=${PACKAGECONFIG_CONFARGS}"
# disable gstreamer-1.0 test if it isn't enabled by PACKAGECONFIG
sed -e 's/\s\(packagesExist(".*\<gstreamer-1.0\>.*")\)/ OE_GSTREAMER_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
# disable gstreamer-0.10 test if it isn't enabled by PACKAGECONFIG