aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-24 03:28:57 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 09:22:19 +0000
commitd498eb607514eefaf0548c4377d5c8cdbdcb46c3 (patch)
tree4d30465d6a6048273348c921ad4d6656fa10af5c /recipes-qt/qt5/qtwebkit_git.bb
parentb716195f609de6547cfdfadfd4fd25292a6bbf09 (diff)
qtwebkit: Use relative paths for pri files when cross compile
This helps in compiling examples etc. without hardcoded headers Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 0a978357..a137b2f9 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -14,8 +14,8 @@ DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-
SRC_URI += "\
file://0001-Do-not-skip-build-for-cross-compile.patch \
file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
- file://0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
file://0004-Fix-build-bug-for-armv32-BE.patch \
+ file://0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
"
inherit cmake_qt5 perlnative pythonnative
@@ -40,8 +40,9 @@ ARM_INSTRUCTION_SET_armv7ve = "thumb"
# https://bugzilla.redhat.com/show_bug.cgi?id=1582954
CXXFLAGS += "-fpermissive"
-EXTRA_OECMAKE = " \
+EXTRA_OECMAKE += " \
-DPORT=Qt \
+ -DCROSS_COMPILE=ON \
-DECM_MKSPECS_INSTALL_DIR=${libdir}${QT_DIR_NAME}/mkspecs/modules \
-DQML_INSTALL_DIR=${OE_QMAKE_PATH_QML} \
"