aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-02-22 14:51:05 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-04-20 10:06:37 +0000
commitf33be06035faaa59cee17e5a97e82d079b4ab444 (patch)
tree79d1a995808932b7e9fae144e2b13ddb0b4908a2 /recipes-qt/qt5/qtwebkit_git.bb
parentc7549747b6e83e9630ae37c7e2595e41e4f1ebac (diff)
qt5: upgrade to 5.11 Alpha
* use qtwebkit and qtwebkit-examples from dev branch, because there is no 5.11 branch (there isn't 5.10 as well, but because nobranch=1 in qt5-git.inc nobody noticed). * qtbase: drop qml-debug options removed from qtbase in: commit 525f8516c2580018f910cfb99ab5e0e36bd55ab1 Author: Ulf Hermann <ulf.hermann@qt.io> Date: Fri Oct 6 16:27:09 2017 +0200 Subject: Remove qml-debug configure flag and feature * qtgraphicaleffects, qtquickcontrols2, qtquickcontrols, qtvirtualkeyboard: add qtdeclarative-native dependency needed for qmlcachegen binary * qtwebkit: update LIC_FILES_CHKSUM and remove PACKAGECONFIGs referenced files disappered in: commit 6882a04fb36642862b11efe514251d32070c3d65 Author: Konstantin Tokarev <annulen@yandex.ru> Date: Thu Aug 25 19:20:41 2016 +0300 Subject: Imported QtWebKit TP3 (git b57bc6801f1876c3220d5a4bfea33d620d477443) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb42
1 files changed, 3 insertions, 39 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index c8e83281..36c967f4 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -3,9 +3,7 @@ require qt5-git.inc
LICENSE = "BSD & LGPLv2+ | GPL-2.0"
LIC_FILES_CHKSUM = " \
- file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
- file://Source/WebCore/rendering/RenderApplet.h;endline=22;md5=fb9694013ad71b78f8913af7a5959680 \
- file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
+ file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
file://Source/JavaScriptCore/parser/Parser.h;endline=21;md5=bd69f72183a7af673863f057576e21ee \
"
@@ -26,13 +24,6 @@ ARM_INSTRUCTION_SET_armv7a = "thumb"
ARM_INSTRUCTION_SET_armv7r = "thumb"
ARM_INSTRUCTION_SET_armv7ve = "thumb"
-# Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.10
-# 5.10.meta-qt5.1
-SRC_URI += "\
- file://0001-qtwebkit-fix-QA-issue-bad-RPATH.patch \
- file://0002-Exclude-backtrace-API-for-non-glibc-libraries.patch \
-"
-
PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxrender', '', d)} \
fontconfig \
@@ -50,27 +41,6 @@ PACKAGECONFIG[fontconfig] = "OE_FONTCONFIG_ENABLED,,fontconfig"
do_configure_prepend() {
export QMAKE_CACHE_EVAL="CONFIG+=${PACKAGECONFIG_CONFARGS}"
- # disable gstreamer-1.0 test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(packagesExist(".*\<gstreamer-1.0\>.*")\)/ OE_GSTREAMER_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable gstreamer-0.10 test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(packagesExist(".*\<gstreamer-0.10\>.*")\)/ OE_GSTREAMER010_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable qtlocation test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(qtHaveModule(positioning)\)/ OE_QTLOCATION_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable qtmultimedia test if it isn't enabled by PACKAGECONFIG
- sed -e 's/(video):\(qtHaveModule(multimediawidgets)\)/(video):OE_QTMULTIMEDIA_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable qtsensors test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(qtHaveModule(sensors)\)/ OE_QTSENSORS_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable qtwebchannel test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(qtHaveModule(webchannel)\)/ OE_QTWEBCHANNEL_ENABLED:\1/' -i ${S}/Source/WebKit2/Target.pri
- sed -e 's/\s\(qtHaveModule(webchannel)\)/ OE_QTWEBCHANNEL_ENABLED:\1/' -i ${S}/Source/WebKit2/WebKit2.pri
- # disable libwebp test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(config_libwebp: \)/ OE_LIBWEBP_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable libxcomposite test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(config_libXcomposite: \)/ OE_LIBXCOMPOSITE_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable libxrender test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(config_libXrender: \)/ OE_LIBXRENDER_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
- # disable fontconfig test if it isn't enabled by PACKAGECONFIG
- sed -e 's/\s\(config_fontconfig: \)/ OE_FONTCONFIG_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
}
# Forcibly enable ICU, so qtbase doesn't need it.
@@ -80,12 +50,6 @@ EXTRA_QMAKEVARS_PRE += "QT_CONFIG+=icu"
QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0"
EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}"
-do_install_append() {
- # Remove paths to workdir, qtwebkit is dead now, so I won't spend extra time trying to prevent this
- # from some .prl or .prf file like for other modules
- sed -i 's@-Wl,-no-whole-archive -L${B}[^ ]* @ @g' ${D}${libdir}/pkgconfig/Qt5WebKit.pc
-}
-
# remove default ${PN}-examples* set in qt5.inc, because they conflicts with ${PN} from separate webkit-examples recipe
PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples"
@@ -95,6 +59,6 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-QT_MODULE_BRANCH = "5.9"
+QT_MODULE_BRANCH = "dev"
-SRCREV = "bd0657f98aff85b9f06d85a8cf4da6a27f61a56e"
+SRCREV = "beaeeb99881184fd368c121fcbb1a31c78b794a3"