aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-06-24 10:49:59 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-06-28 09:56:04 +0000
commite33d86095392f20a6301ab33472736b34a869339 (patch)
tree25a12df2b973f10c285772962dc82cc7c1a1d867 /recipes-qt/qt5
parent364eb068de13c57b6f8ffdac90a88ec14ca71912 (diff)
qt3d-runtime: update to ogl-runtime v2.4
Qt 3D Studio Runtime 2.x switches/upgrades to OpenGL Runtime with version update 2.3 -> 2.4. Contains new 3rdparty submodule EASTL (Electronic Arts Standard Template Library), recipe adjusted accordingly. Change-Id: Iebb2399f5f837e556cf9d59629d663c66d2f622d Reviewed-by: Kari Hormi <kari.hormi@qt.io>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb25
-rw-r--r--recipes-qt/qt5/qt3d-runtime_git.bb16
2 files changed, 25 insertions, 16 deletions
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
new file mode 100644
index 00000000..c2009418
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -0,0 +1,25 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+"
+
+DEPENDS += "qtbase qtdeclarative"
+
+QT_MODULE_BRANCH = "2.4"
+QT_MODULE_BRANCH_EASTL = "master"
+QT_GIT_PROJECT = "qt3dstudio"
+PV = "2.4+git${SRCPV}"
+
+SRC_URI += " \
+ ${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
+"
+
+SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f"
+SRCREV_EASTL = "31697c758f2ed19bd7c6bbe61f1b91f9e12035b5"
+SRCREV = "${SRCREV_ogl-runtime}"
+
+SRCREV_FORMAT = "ogl-runtime_EASTL"
diff --git a/recipes-qt/qt5/qt3d-runtime_git.bb b/recipes-qt/qt5/qt3d-runtime_git.bb
deleted file mode 100644
index fb018e58..00000000
--- a/recipes-qt/qt5/qt3d-runtime_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require qt5.inc
-require qt5-git.inc
-
-LICENSE = "GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = " \
- file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
-"
-
-DEPENDS += "qtbase qtdeclarative qt3d"
-
-QT_MODULE_BRANCH = "2.3"
-QT_GIT_PROJECT = "qt3dstudio"
-PV = "2.3+git${SRCPV}"
-
-SRCREV = "5e0bfe934b9930b7e41d457b4f88fce91342a0ea"