aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMingde (Matthew) Zeng <matthew.zeng@windriver.com>2020-05-20 01:48:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2020-07-07 12:04:32 +0200
commit098b9aca232b07b53bc4db0c7f5274a627670a75 (patch)
tree5e5433951e0c4f82ae5b8121086c93798b467955 /recipes-qt/qt5
parentfbbd24d91b8b6ff5a055aafa30e0f4b2940b7426 (diff)
qt5-creator_git: add x11 and opengl to REQUIRED_DISTRO_FEATURES
Signed-off-by: Mingde (Matthew) Zeng <matthew.zeng@windriver.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 000e135e..d046110b 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -83,3 +83,6 @@ RRECOMMENDS_${PN} += " \
# ERROR: qt5-creator-4.5.1-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qt5-creator/4.5.1-r0/packages-split/qt5-creator/usr/lib/qt5/qtcreator/libqbscore.so.1.10.1'
INSANE_SKIP_${PN} += "ldflags"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES ?= "x11 opengl"