aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-01-10 20:44:52 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2018-01-15 17:56:40 +0000
commit229f819b97e653399455e7b1d491de5ea49d5ba5 (patch)
treece4c530794a9f149baf05ef8af487184908c2d78 /recipes-qt/qt5
parent0e209bade346ee73171df196df9244d3a2eecef9 (diff)
qtwebengine: explicitly depend on bison-native
QtWebEngine uses bison during the build. While normally bison-native gets staged into sysroot indirectly by the toolchain via binutils-cross, it's better to have the dependency listed explicitly for deterministic builds. Otherwise, when using an external toolchain, it fails like this: | FAILED: gen/blink/core/XPathGrammar.cpp gen/blink/core/XPathGrammar.h | .../qtwebengine/5.9.3+...-r0/recipe-sysroot-native/usr/bin/python-native/python2 | ../../../../git/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py | ../../../../git/src/3rdparty/chromium/third_party/WebKit/Source/core/xml/XPathGrammar.y gen/blink/core bison | Traceback (most recent call last): | File "../../../../git/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py", line 83, in <module> | returnCode = subprocess.call([bisonExe, '-d', '-p', prefix, inputFile, '-o', outputCpp]) | File ".../qtwebengine/5.9.3+...-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 168, in call | return Popen(*popenargs, **kwargs).wait() | File ".../qtwebengine/5.9.3+...-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 390, in __init__ | errread, errwrite) | File ".../qtwebengine/5.9.3+...-r0/recipe-sysroot-native/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child | raise child_exception | OSError: [Errno 2] No such file or directory Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f88e5e7d..3a6a37e2 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -18,6 +18,7 @@ DEPENDS += " \
nspr-native \
ninja-native \
yasm-native \
+ bison-native \
qtwebchannel \
qtbase qtdeclarative qtxmlpatterns qtquickcontrols qtquickcontrols2 \
qtlocation \