aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-20 16:20:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-25 12:14:12 +0200
commit567a4d462fa0129751600d32d07ee67a9c0c3f23 (patch)
tree08d765fcc06b16564c05066655ecbcf5808f1137 /recipes-qt/qt5
parent3da4d425d06f74dbb0b5334f1f62efa20bd02176 (diff)
qt5: drop INC_PR and update PR only in 5.0.2 recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtbase-native.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtbase.inc2
-rw-r--r--recipes-qt/qt5/qtbase_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative.inc2
-rw-r--r--recipes-qt/qt5/qtdeclarative_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects.inc2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats.inc2
-rw-r--r--recipes-qt/qt5/qtimageformats_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtjsbackend-native.inc2
-rw-r--r--recipes-qt/qt5/qtjsbackend-native_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtjsbackend.inc2
-rw-r--r--recipes-qt/qt5/qtjsbackend_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia.inc2
-rw-r--r--recipes-qt/qt5/qtmultimedia_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtquick1.inc2
-rw-r--r--recipes-qt/qt5/qtquick1_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtscript.inc2
-rw-r--r--recipes-qt/qt5/qtscript_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtsensors.inc2
-rw-r--r--recipes-qt/qt5/qtsvg.inc2
-rw-r--r--recipes-qt/qt5/qtsvg_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit.inc2
-rw-r--r--recipes-qt/qt5/qtwebkit_5.0.2.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns.inc2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_5.0.2.bb2
27 files changed, 13 insertions, 41 deletions
diff --git a/recipes-qt/qt5/qtbase-native.inc b/recipes-qt/qt5/qtbase-native.inc
index 70a30724..1adf422e 100644
--- a/recipes-qt/qt5/qtbase-native.inc
+++ b/recipes-qt/qt5/qtbase-native.inc
@@ -3,8 +3,6 @@ DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://qt-project.org"
-INC_PR = "r1"
-
QT_MODULE = "qtbase"
require qt5-native.inc
diff --git a/recipes-qt/qt5/qtbase-native_5.0.2.bb b/recipes-qt/qt5/qtbase-native_5.0.2.bb
index 623b17ad..b2bdcab0 100644
--- a/recipes-qt/qt5/qtbase-native_5.0.2.bb
+++ b/recipes-qt/qt5/qtbase-native_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r3"
SRC_URI += " \
file://0017-Rename-qAbs-Function-for-timeval.patch \
diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc
index 0e091235..c6cb2cce 100644
--- a/recipes-qt/qt5/qtbase.inc
+++ b/recipes-qt/qt5/qtbase.inc
@@ -120,8 +120,6 @@ QT_CONFIG_FLAGS += " \
${EXTRA_OECONF} \
"
-INC_PR = "r2"
-
# Qt uses atomic instructions not supported in thumb mode
ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-qt/qt5/qtbase_5.0.2.bb b/recipes-qt/qt5/qtbase_5.0.2.bb
index 15ac3718..be7bcf53 100644
--- a/recipes-qt/qt5/qtbase_5.0.2.bb
+++ b/recipes-qt/qt5/qtbase_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r3"
SRC_URI += " \
file://0016-Allow-tslib-to-be-specified-at-configure-time.patch \
diff --git a/recipes-qt/qt5/qtdeclarative.inc b/recipes-qt/qt5/qtdeclarative.inc
index 495e9a98..6569c69e 100644
--- a/recipes-qt/qt5/qtdeclarative.inc
+++ b/recipes-qt/qt5/qtdeclarative.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtjsbackend qtsvg qtxmlpatterns"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtdeclarative_5.0.2.bb b/recipes-qt/qt5/qtdeclarative_5.0.2.bb
index 439de99e..71f8ff55 100644
--- a/recipes-qt/qt5/qtdeclarative_5.0.2.bb
+++ b/recipes-qt/qt5/qtdeclarative_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI += " \
file://0001-qmltestexample-fix-link.patch \
diff --git a/recipes-qt/qt5/qtgraphicaleffects.inc b/recipes-qt/qt5/qtgraphicaleffects.inc
index 1845faf1..63e884ea 100644
--- a/recipes-qt/qt5/qtgraphicaleffects.inc
+++ b/recipes-qt/qt5/qtgraphicaleffects.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtdeclarative"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_5.0.2.bb b/recipes-qt/qt5/qtgraphicaleffects_5.0.2.bb
index 99db424f..ee5f3abe 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_5.0.2.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_5.0.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffe
file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \
"
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "3d4475a4702f7bbe8064f69e17f1e8dd"
SRC_URI[sha256sum] = "944399c5795b83b8f6b5e4ccec763ce5192f0e99b5e6d256f2b43a3165ee3016"
diff --git a/recipes-qt/qt5/qtimageformats.inc b/recipes-qt/qt5/qtimageformats.inc
index 26e06d4d..bbb05a65 100644
--- a/recipes-qt/qt5/qtimageformats.inc
+++ b/recipes-qt/qt5/qtimageformats.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtbase"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtimageformats_5.0.2.bb b/recipes-qt/qt5/qtimageformats_5.0.2.bb
index 1b881650..e53c8633 100644
--- a/recipes-qt/qt5/qtimageformats_5.0.2.bb
+++ b/recipes-qt/qt5/qtimageformats_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "e397a4237f51cfef7a3b38ad29b831d7"
SRC_URI[sha256sum] = "93bd13a47002f188a8a83a5c742d396a2008a545fc22d58df442c4c070a463b7"
diff --git a/recipes-qt/qt5/qtjsbackend-native.inc b/recipes-qt/qt5/qtjsbackend-native.inc
index 4369af03..30663b87 100644
--- a/recipes-qt/qt5/qtjsbackend-native.inc
+++ b/recipes-qt/qt5/qtjsbackend-native.inc
@@ -11,8 +11,6 @@ QT_MODULE = "qtjsbackend"
require qt5-native.inc
-INC_PR = "r0"
-
SRC_URI += "\
file://0001-Install-the-mkv8snapshot-tool-to-the-native-side.patch \
"
diff --git a/recipes-qt/qt5/qtjsbackend-native_5.0.2.bb b/recipes-qt/qt5/qtjsbackend-native_5.0.2.bb
index 9dcbcc01..83832d86 100644
--- a/recipes-qt/qt5/qtjsbackend-native_5.0.2.bb
+++ b/recipes-qt/qt5/qtjsbackend-native_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "610f011757755888153cb2004c04446f"
SRC_URI[sha256sum] = "65071ab9ab7d9024b7ba6d128a1c97ac09cf1b37818affb4238e4ba7d6665cc0"
diff --git a/recipes-qt/qt5/qtjsbackend.inc b/recipes-qt/qt5/qtjsbackend.inc
index 4479654e..66afc948 100644
--- a/recipes-qt/qt5/qtjsbackend.inc
+++ b/recipes-qt/qt5/qtjsbackend.inc
@@ -9,8 +9,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
DEPENDS += "qtbase qtjsbackend-native"
-INC_PR = "r0"
-
SRC_URI += " \
file://0002-v8.pro-respect-external-host-bindir-when-set.patch \
"
diff --git a/recipes-qt/qt5/qtjsbackend_5.0.2.bb b/recipes-qt/qt5/qtjsbackend_5.0.2.bb
index b536da32..b59a3ebb 100644
--- a/recipes-qt/qt5/qtjsbackend_5.0.2.bb
+++ b/recipes-qt/qt5/qtjsbackend_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI += " \
file://0003-V8-Cleanup-hardfp-ABI-detection.-This-work-was-trigg.patch \
diff --git a/recipes-qt/qt5/qtmultimedia.inc b/recipes-qt/qt5/qtmultimedia.inc
index d9fdf793..6a1a7375 100644
--- a/recipes-qt/qt5/qtmultimedia.inc
+++ b/recipes-qt/qt5/qtmultimedia.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtdeclarative gstreamer alsa-lib "
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtmultimedia_5.0.2.bb b/recipes-qt/qt5/qtmultimedia_5.0.2.bb
index 7b97cbd3..17d9de0a 100644
--- a/recipes-qt/qt5/qtmultimedia_5.0.2.bb
+++ b/recipes-qt/qt5/qtmultimedia_5.0.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffe
file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \
"
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "f0902250974440c9c63569112a67440c"
SRC_URI[sha256sum] = "fffc7bd71e6cb2853da3c90d7f9794583e7a83e4eeb6fea039a2efac53688834"
diff --git a/recipes-qt/qt5/qtquick1.inc b/recipes-qt/qt5/qtquick1.inc
index d39c0e63..a9ec211c 100644
--- a/recipes-qt/qt5/qtquick1.inc
+++ b/recipes-qt/qt5/qtquick1.inc
@@ -2,5 +2,3 @@ require qt5.inc
DEPENDS += "qtscript qtsvg qtxmlpatterns qtwebkit"
# qttools
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtquick1_5.0.2.bb b/recipes-qt/qt5/qtquick1_5.0.2.bb
index c20732e1..ddef81af 100644
--- a/recipes-qt/qt5/qtquick1_5.0.2.bb
+++ b/recipes-qt/qt5/qtquick1_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "22cd03e2e2aadbc5e2ce324a3526fa8b"
SRC_URI[sha256sum] = "2a2235f4f4afd5bf8c6960efafbe89f8c443f174fb22931d48f566660cfcea9a"
diff --git a/recipes-qt/qt5/qtscript.inc b/recipes-qt/qt5/qtscript.inc
index 26e06d4d..bbb05a65 100644
--- a/recipes-qt/qt5/qtscript.inc
+++ b/recipes-qt/qt5/qtscript.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtbase"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtscript_5.0.2.bb b/recipes-qt/qt5/qtscript_5.0.2.bb
index 0bac91ad..9d334ce2 100644
--- a/recipes-qt/qt5/qtscript_5.0.2.bb
+++ b/recipes-qt/qt5/qtscript_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "929db18c2f4f66cb2ba204076f9f0c22"
SRC_URI[sha256sum] = "def1b60e5ff5513cbda27200554fb568ef822e0ee790476facfe3bcf3438598f"
diff --git a/recipes-qt/qt5/qtsensors.inc b/recipes-qt/qt5/qtsensors.inc
index 786f603b..b2147f16 100644
--- a/recipes-qt/qt5/qtsensors.inc
+++ b/recipes-qt/qt5/qtsensors.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtbase qtdeclarative"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtsvg.inc b/recipes-qt/qt5/qtsvg.inc
index 26e06d4d..bbb05a65 100644
--- a/recipes-qt/qt5/qtsvg.inc
+++ b/recipes-qt/qt5/qtsvg.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtbase"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtsvg_5.0.2.bb b/recipes-qt/qt5/qtsvg_5.0.2.bb
index 4ce9b811..6f6706f7 100644
--- a/recipes-qt/qt5/qtsvg_5.0.2.bb
+++ b/recipes-qt/qt5/qtsvg_5.0.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffe
file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \
"
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "a000016afd3672540b2488c2f8e8d8b3"
SRC_URI[sha256sum] = "5983485ade365a9e809d4614cc76fb106c35d5c514e0312a9013bb25227a6521"
diff --git a/recipes-qt/qt5/qtwebkit.inc b/recipes-qt/qt5/qtwebkit.inc
index 9c467dce..4c9cc7fe 100644
--- a/recipes-qt/qt5/qtwebkit.inc
+++ b/recipes-qt/qt5/qtwebkit.inc
@@ -11,8 +11,6 @@ DEPENDS += "qtdeclarative qtlocation qtsensors ${ICU} ruby-native sqlite3"
QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0"
EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}"
-INC_PR = "r0"
-
do_configure_append() {
# Fix rpaths for QtWebProcess
find -name "Makefile*" | xargs sed -i "s|-Wl,-rpath,${B}/lib||g"
diff --git a/recipes-qt/qt5/qtwebkit_5.0.2.bb b/recipes-qt/qt5/qtwebkit_5.0.2.bb
index 4d2f34d9..ab1cacd5 100644
--- a/recipes-qt/qt5/qtwebkit_5.0.2.bb
+++ b/recipes-qt/qt5/qtwebkit_5.0.2.bb
@@ -1,7 +1,7 @@
require qt5-${PV}.inc
require ${PN}.inc
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "85aad9f287910c21c8464d7d1ea010a9"
SRC_URI[sha256sum] = "6ff4038f8db68be51661d1a6646f510b26f6ebbecbdeefb76cd8361f808768f6"
diff --git a/recipes-qt/qt5/qtxmlpatterns.inc b/recipes-qt/qt5/qtxmlpatterns.inc
index 26e06d4d..bbb05a65 100644
--- a/recipes-qt/qt5/qtxmlpatterns.inc
+++ b/recipes-qt/qt5/qtxmlpatterns.inc
@@ -1,5 +1,3 @@
require qt5.inc
DEPENDS += "qtbase"
-
-INC_PR = "r0"
diff --git a/recipes-qt/qt5/qtxmlpatterns_5.0.2.bb b/recipes-qt/qt5/qtxmlpatterns_5.0.2.bb
index a10c8350..47cdb320 100644
--- a/recipes-qt/qt5/qtxmlpatterns_5.0.2.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_5.0.2.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
"
-PR = "${INC_PR}.0"
+PR = "r1"
SRC_URI[md5sum] = "29e6776165e43e9f3a865338121b4e1d"
SRC_URI[sha256sum] = "c05ae43fffc911ffda808deecebddd1b31916714cefc9cfd840689fc52ae20a6"