aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-03-08 12:33:01 +0100
committerMartin Jansa <martin.jansa@lge.com>2021-10-03 15:43:25 -0700
commit7d8cd33108de753f44a4c3031009a420c6292e01 (patch)
tree5492eca42f8966d2b0f9abf5b9264f5ee93a8768 /recipes-qt/qt5
parenta72b27efd3fa8439608f427b81424f129b60dafd (diff)
qtwebengine: Fix build with ninja >= 1.10.0
* For now just skip version check. Looked into: ninja came from meta-oe to oe-core with: commit fc3aef67a95a90e9a485c6b0e93db8cdeab5d3ab Author: Khem Raj <raj.khem@gmail.com> Date: Thu Jul 27 21:52:12 2017 -0700 ninja: Add recipe llvm is using it, therefore move it from meta-oe Signed-off-by: Khem Raj <raj.khem@gmail.com> That was in rocko release cycle. So the assumption we have a ninja decent enough should be acceptable. * and since the upgrade to ninja-1.10.0 in: commit d1cd957cea29f3ab111ae752bc9ad75a1324c255 Author: Upgrade Helper <auh@auh.yoctoproject.org> Date: Fri Feb 21 14:45:35 2020 -0800 ninja: upgrade 1.9.0 -> 1.10.0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> the do_configure task fails with: | ERROR: Feature 'webengine-system-ninja' was enabled, but the pre-condition 'tests.webengine-ninja' failed. * Looked into qtwebengine current dev branch: There is no solution yet. So as soon as upstream offers a better solution most likely this patch will not apply any more and has to be removed then. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch39
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
new file mode 100644
index 00000000..89014da3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
@@ -0,0 +1,39 @@
+From 5f5afe275757efe77ff48debb040e08001ea5907 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sun, 8 Mar 2020 10:51:48 +0100
+Subject: [PATCH] Remove ninja version test for now - it fails for ninja >=
+ 1.10.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+As long as upstream has no better solution, assume we have a ninja version
+recent enough
+
+Fixes:
+| Found ninja from path: /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja
+| + /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja --version
+| > 1.10.0
+| Ninja version too old
+
+Upstream-Status: Inappropriate [temporary-hack]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ configure.pri | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.pri b/configure.pri
+index 3a144e3f..6c3f29fd 100644
+--- a/configure.pri
++++ b/configure.pri
+@@ -163,8 +163,7 @@ defineTest(qtConfTest_detectNinja) {
+ !isEmpty(ninja) {
+ qtLog("Found ninja from path: $$ninja")
+ qtRunLoggedCommand("$$ninja --version", version)|return(false)
+- contains(version, "1.[7-9].*"): return(true)
+- qtLog("Ninja version too old")
++ return(true)
+ }
+ qtLog("Building own ninja")
+ return(false)
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1a3fcae5..9ee81562 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -141,6 +141,7 @@ QT_MODULE_BRANCH_CHROMIUM = "69-based"
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
+ file://0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch \
"
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \