aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-03 16:42:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-03 16:44:54 +0200
commit886509518d5662e42b1177c88403ebb31454c605 (patch)
tree55b98f8f480da2dfe1d17ee628e83313355a100e /recipes-qt/qt5
parent28753fa6aacd27ea3d7f429a44ff88fe26168249 (diff)
qtwayland: Add xproto dependency together with libxkbcommon
* xproto provides X11/keysym.h which is used when testing libxkbcommon support: executing config test xkbcommon + cd /OE/work/i586-oe-linux/qtwayland/5.1.0+git/build/config.tests/xkbcommon && /OE/sysroots/x86_64-linux/usr/bin/qt5/qmake "CONFIG -= qt debug_and_release app_bundle lib_bundle" /OE/work/i586-oe-linux/qtwayland/5.1.0+git/git/config.tests/xkbcommon + cd /OE/work/i586-oe-linux/qtwayland/5.1.0+git/build/config.tests/xkbcommon && make MAKEFLAGS='-j 9' OE_QMAKE_COMPILER='i586-oe-linux-gcc -m32 -march=i586 --sysroot=/OE/sysroots/qemux86' OE_QMAKE_CC='i586-oe-linux-gcc -m32 -march=i586 --sysroot=/OE/sysroots/qemux86' OE_QMAKE_CXX='i586-oe-linux-g++ -m32 -march=i586 --sysroot=/OE/sysroots/qemux86' OE_QMAKE_CFLAGS=' -O2 -pipe -g -feliminate-unused-debug-types' OE_QMAKE_CXXFLAGS=' -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden' OE_QMAKE_LINK='i586-oe-linux-g++ -m32 -march=i586 --sysroot=/OE/sysroots/qemux86' OE_QMAKE_LDFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' OE_QMAKE_AR='i586-oe-linux-ar' OE_QMAKE_STRIP='echo' OE_QMAKE_WAYLAND_SCANNER='/OE/sysroots/x86_64-linux/usr/bin/wayland-scanner' compiling /OE/work/i586-oe-linux/qtwayland/5.1.0+git/git/config.tests/xkbcommon/main.cpp /OE/work/i586-oe-linux/qtwayland/5.1.0+git/git/config.tests/xkbcommon/main.cpp:42:24: fatal error: X11/keysym.h: No such file or directory compilation terminated. make: *** [.obj/release-shared/main.o] Error 1 test xkbcommon FAILED Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtwayland.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland.inc b/recipes-qt/qt5/qtwayland.inc
index 0c76b993..7cf39351 100644
--- a/recipes-qt/qt5/qtwayland.inc
+++ b/recipes-qt/qt5/qtwayland.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenod
# libxkbcommon isn't mandatory with 0001-xcbcommon-should-not-be-a-mandatory-dependency.patch
# make it easier to remove by .bbappend (e.g. for building qtwayland with danny which doesn't
# have libxkbcommon in oe-core).
-XKB_DEPENDS = "libxkbcommon"
+XKB_DEPENDS = "libxkbcommon xproto"
DEPENDS += "qtbase qtdeclarative wayland wayland-native ${XKB_DEPENDS}"
INC_PR = "r1"