aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-06 11:54:32 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 00:55:36 +0000
commitb8fade938e684a5dda8c978689e914c5d11baf2e (patch)
tree5dad741faa436fe9317a59eaab4b9388a2ec4966 /recipes-qt/qt5
parent0cdf7276685ff03a769dc8201f60e8f16e04d879 (diff)
qtbase: Fix build with clang/musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0020-corelib-Include-sys-types.h-for-uint32_t.patch30
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 57309495..77594b0b 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -42,6 +42,7 @@ SRC_URI += "\
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
file://0016-Disable-ltcg-for-host_build.patch \
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
+ file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 246f183a..4c26d0f3 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -37,6 +37,7 @@ SRC_URI += "\
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
file://0016-Disable-ltcg-for-host_build.patch \
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
+ file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0020-corelib-Include-sys-types.h-for-uint32_t.patch b/recipes-qt/qt5/qtbase/0020-corelib-Include-sys-types.h-for-uint32_t.patch
new file mode 100644
index 00000000..81ae28b3
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0020-corelib-Include-sys-types.h-for-uint32_t.patch
@@ -0,0 +1,30 @@
+From d48cd5f4c46ec4ba129ae8abdfb8707285485933 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 6 Dec 2018 11:47:52 -0800
+Subject: [PATCH] corelib: Include sys/types.h for uint32_t
+
+This has been includes indirectly on glibc/linux systems
+via inttypes.h -> stdint.h -> sys/types.h but it breaks on
+musl where this indirect include chain does not exist.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/corelib/global/qnumeric_p.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/corelib/global/qnumeric_p.h b/src/corelib/global/qnumeric_p.h
+index 5f8a124bcc..fe1711cf1b 100644
+--- a/src/corelib/global/qnumeric_p.h
++++ b/src/corelib/global/qnumeric_p.h
+@@ -55,6 +55,7 @@
+ #include "QtCore/private/qglobal_p.h"
+ #include <cmath>
+ #include <limits>
++#include <sys/types.h>
+
+ #if defined(Q_CC_MSVC)
+ # include <intrin.h>
+--
+2.19.2
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 18137ce2..57fa1783 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -33,6 +33,7 @@ SRC_URI += "\
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
file://0016-Disable-ltcg-for-host_build.patch \
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
+ file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
"