aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-01 20:13:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-05-01 23:29:26 +0200
commitdcf2ece48ea45336f44e01fd3f93e0efa0a163b6 (patch)
tree9c93b0ba940917d1ab61975bed82339af19a0dcd /recipes-qt/qt5
parentc7ec5568d86396de9571e1de111b92c9e6f86f20 (diff)
qtbase: fix build with gcc-11
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb9
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb11
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch8
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0017-Fix-Wdeprecated-copy-warnings.patch8
-rw-r--r--recipes-qt/qt5/qtbase/0018-qfloat16-Include-limits-header.patch58
-rw-r--r--recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch (renamed from recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
24 files changed, 106 insertions, 45 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index f043198a..8041d80c 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.9
+# 5.12.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -42,14 +42,15 @@ SRC_URI += "\
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
+ file://0018-qfloat16-Include-limits-header.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.9
+# 5.12.meta-qt5-native.12
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
- file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 5ef19724..878a20c2 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.9
+# 5.12.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -37,19 +37,20 @@ SRC_URI += "\
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
+ file://0018-qfloat16-Include-limits-header.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.9
+# 5.12.meta-qt5-native.12
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
- file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0020-Bootstrap-without-linkat-feature.patch \
+ file://0021-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 85b6b63d..62607509 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From f474b08de99d505eb2f2b7d69fed40c4aa09ac70 Mon Sep 17 00:00:00 2001
+From 1ce378d41c2d26e9f24763f8eadda393e7765e4e Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -31,10 +31,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index ef7bad1bfc..dcca0f9135 100755
+index f9407ef587..467f57f960 100755
--- a/configure
+++ b/configure
-@@ -712,7 +712,7 @@ fi
+@@ -709,7 +709,7 @@ fi
# is where the resulting variable is written to
setBootstrapVariable()
{
diff --git a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index 999ec4c9..1b9e0794 100644
--- a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,4 +1,4 @@
-From c1d85b492d8e40fe37dd11f69e24a04b3f086025 Mon Sep 17 00:00:00 2001
+From 0598d5f7a41993303557ff19920e5823c58b5f19 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index 9c11e6de..f8116772 100644
--- a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 73e2aad711fe5d94f0aec72c353e5acf957d66d2 Mon Sep 17 00:00:00 2001
+From d0d2b716621b6e1dd874f3575e099f8f98241ffb Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
@@ -20,7 +20,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
-index c0a5369cdd..df620d6ebe 100644
+index f2ada4ab30..62c6feae17 100644
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
@@ -174,7 +174,10 @@ void QLibrarySettings::load()
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index 60ae7314..f63edc8c 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From bf9825b206959b29be15e0b76db3ef59187e84cd Mon Sep 17 00:00:00 2001
+From 150679264704533a44f885ba4ae36c504914cec3 Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
@@ -15,10 +15,10 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.pri b/configure.pri
-index b109192..cccbf1c 100644
+index 33c90a8c2f..74da4682de 100644
--- a/configure.pri
+++ b/configure.pri
-@@ -836,10 +836,10 @@ defineTest(qtConfOutput_preparePaths) {
+@@ -838,10 +838,10 @@ defineTest(qtConfOutput_preparePaths) {
$${currentConfig}.output.qconfigSource = \
"/* Installation Info */" \
diff --git a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index 8a236470..803f8776 100644
--- a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From b6e5080c41557a20c85326af39323ff1ed42d944 Mon Sep 17 00:00:00 2001
+From 038242ebbaa2153a0ac7e81dffcac2b0b6eedc6c Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
@@ -10,7 +10,7 @@ Change-Id: Ib884fe33cac74439f9592b145937f6b75ced8447
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf
-index 242544d41b..68a7758a9c 100644
+index 850ee98057..7b591dc8bb 100644
--- a/mkspecs/features/qt_configure.prf
+++ b/mkspecs/features/qt_configure.prf
@@ -1598,7 +1598,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
diff --git a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index 7531b19a..f887b9bb 100644
--- a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From ec636d121ae1dd6a0995cb9b9ac0321a1fab57e6 Mon Sep 17 00:00:00 2001
+From a86287d457e4eb7386d60f48fb5d0a1037b2ef25 Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index 98526ee4..95535a2f 100644
--- a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From 2f4dcaf341e7b23cd23693f3675d70f5e1b18a24 Mon Sep 17 00:00:00 2001
+From e2dea00b1c713fd881d83c4b25d9e8e4e7d7d870 Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 955a772b..1f4df52a 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From 054ca0a5394596156abbadc01cae46d0fb16e8ed Mon Sep 17 00:00:00 2001
+From 9fee68b32cdd86e4354a42aaa93c804bc7d30158 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -36,10 +36,10 @@ index e6fac74ccc..28c7e9cfb3 100644
QMetaType info(tp);
if (!info.isValid()) {
diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-index 10b09629bc..858fc5fc99 100644
+index d477c2f112..c48cf04d8e 100644
--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-@@ -78,6 +78,7 @@
+@@ -80,6 +80,7 @@
#include <stdlib.h>
#include <sys/stat.h>
#include <unistd.h>
@@ -47,7 +47,7 @@ index 10b09629bc..858fc5fc99 100644
#endif
#include "private/qhostinfo_p.h"
-@@ -2151,8 +2152,8 @@ public slots:
+@@ -2153,8 +2154,8 @@ public slots:
#if defined(Q_OS_MAC)
pthread_yield_np();
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index a92ff91f..b7f8c280 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From 64f3d24f53d5c0fc0af4cf36eaefb85d0c29f8c6 Mon Sep 17 00:00:00 2001
+From 2e135b2b154f6293da42685db266bfdd9b1e4a35 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
index 9aeb4b51..efe1c6eb 100644
--- a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -1,4 +1,4 @@
-From a426a2623ef9566827093f0424944ef93318db64 Mon Sep 17 00:00:00 2001
+From 1ad62e76697d8dde8b31caf84ce0c5983278587d Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:44:48 -0700
Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
diff --git a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
index bf399e10..ae3dfaf5 100644
--- a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
+++ b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -1,4 +1,4 @@
-From cda33b76c273faa7d46667d8ebbdbecf12f55b30 Mon Sep 17 00:00:00 2001
+From 1d9f21489b64d3cd98d9304695a8bba3cd9d71d3 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 10:11:50 -0700
Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
index 9fb49d73..3b010068 100644
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
@@ -1,4 +1,4 @@
-From 6047aa7010fb960fcc9dcc6714014e720e5179d1 Mon Sep 17 00:00:00 2001
+From b04f65cddd3fff0f2ca1223d28f508d382327673 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 14 Feb 2018 17:08:43 -0800
Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
diff --git a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
index dbe939ae..d47b13bc 100644
--- a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
-From cee285b681dfeb25692ea6c756f8e0d8c5017a25 Mon Sep 17 00:00:00 2001
+From bc28dc25e719c182b0275dace8e13d3926e890e5 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 23 Oct 2018 09:54:57 +0300
Subject: [PATCH] Disable ltcg for host_build
diff --git a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
index d33f06e3..3f239dec 100644
--- a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
+++ b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -1,4 +1,4 @@
-From ba7c32a7209edbe2f628e72308fd5cb5aa18238a Mon Sep 17 00:00:00 2001
+From 23c53b8cd1ccbdb382911c7a8e194ad06e333584 Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 27 Oct 2018 12:29:31 +0000
Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
diff --git a/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch b/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
index c5a3c24b..4cae71fb 100644
--- a/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
+++ b/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
@@ -1,4 +1,4 @@
-From 1969e55b5e1b58b39c6712f8a2399ad1738b1673 Mon Sep 17 00:00:00 2001
+From f647a46e9572406a6d611cf6b6cb772e6723c08a Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 11:47:52 -0800
Subject: [PATCH] corelib: Include sys/types.h for uint32_t
diff --git a/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch b/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
index 3e173856..bd6a6719 100644
--- a/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
+++ b/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
@@ -1,4 +1,4 @@
-From c91442deb25e2d5d0d49898c308e2b71fe899a2a Mon Sep 17 00:00:00 2001
+From a0159813d1422e5f64c6b8ade4f4155ed886b406 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 15:06:20 -0800
Subject: [PATCH] Define QMAKE_CXX.COMPILER_MACROS for clang on linux
@@ -13,7 +13,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 9 insertions(+)
diff --git a/mkspecs/features/toolchain.prf b/mkspecs/features/toolchain.prf
-index 03612e5689..f227e0772e 100644
+index 5003679bd0..2ab31b1603 100644
--- a/mkspecs/features/toolchain.prf
+++ b/mkspecs/features/toolchain.prf
@@ -41,6 +41,13 @@ defineReplace(qtVariablesFromGCC) {
diff --git a/recipes-qt/qt5/qtbase/0017-Fix-Wdeprecated-copy-warnings.patch b/recipes-qt/qt5/qtbase/0017-Fix-Wdeprecated-copy-warnings.patch
index 6d8a1629..29bbe89a 100644
--- a/recipes-qt/qt5/qtbase/0017-Fix-Wdeprecated-copy-warnings.patch
+++ b/recipes-qt/qt5/qtbase/0017-Fix-Wdeprecated-copy-warnings.patch
@@ -1,4 +1,4 @@
-From f434ca2641a9cb93b86ad0b74fbd9b16612a2c24 Mon Sep 17 00:00:00 2001
+From e042e3feaadcd37abcb449adaaee41e16e1dfae4 Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@qt.io>
Date: Tue, 13 Nov 2018 17:14:43 +0100
Subject: [PATCH] Fix -Wdeprecated-copy warnings
@@ -27,10 +27,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
9 files changed, 44 insertions(+), 19 deletions(-)
diff --git a/mkspecs/features/qt_common.prf b/mkspecs/features/qt_common.prf
-index caecb68a84..3ef28dcb71 100644
+index 57edc8370a..689172adba 100644
--- a/mkspecs/features/qt_common.prf
+++ b/mkspecs/features/qt_common.prf
-@@ -99,14 +99,8 @@ clang {
+@@ -100,14 +100,8 @@ clang {
greaterThan(QT_GCC_MAJOR_VERSION, 5): QMAKE_CXXFLAGS_WARN_ON += -Wshift-overflow=2 -Wduplicated-cond
# GCC 7 has a lot of false positives relating to this, so disable completely
greaterThan(QT_GCC_MAJOR_VERSION, 6): QMAKE_CXXFLAGS_WARN_ON += -Wno-stringop-overflow
@@ -46,7 +46,7 @@ index caecb68a84..3ef28dcb71 100644
}
warnings_are_errors:warning_clean {
-@@ -146,14 +140,13 @@ warnings_are_errors:warning_clean {
+@@ -147,14 +141,13 @@ warnings_are_errors:warning_clean {
# GCC 7 includes -Wimplicit-fallthrough in -Wextra, but Qt is not yet free of implicit fallthroughs.
greaterThan(QT_GCC_MAJOR_VERSION, 6): QMAKE_CXXFLAGS_WARN_ON += -Wno-error=implicit-fallthrough
diff --git a/recipes-qt/qt5/qtbase/0018-qfloat16-Include-limits-header.patch b/recipes-qt/qt5/qtbase/0018-qfloat16-Include-limits-header.patch
new file mode 100644
index 00000000..5884fafd
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0018-qfloat16-Include-limits-header.patch
@@ -0,0 +1,58 @@
+From 0d72160c2956cc18246b198b8a752f2af146a062 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 2 Mar 2021 13:18:47 -0800
+Subject: [PATCH] qfloat16: Include <limits> header
+
+gcc11 complains
+ error: 'numeric_limits' is not a class template
+ | 344 | template<> class numeric_limits<const QT_PREPEND_NAMESPACE(qfloat16)>
+
+This is because its missing right header which perhaps is included
+implicitly in older compilers
+
+Change-Id: I29fa715399e4aa4686d01a2385fcde4ac6860cc0
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/corelib/global/qfloat16.h | 1 +
+ src/corelib/tools/qbytearraymatcher.h | 1 +
+ src/tools/moc/generator.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/src/corelib/global/qfloat16.h b/src/corelib/global/qfloat16.h
+index b76d2b9616..66383722e6 100644
+--- a/src/corelib/global/qfloat16.h
++++ b/src/corelib/global/qfloat16.h
+@@ -43,6 +43,7 @@
+ #include <QtCore/qglobal.h>
+ #include <QtCore/qmetatype.h>
+ #include <string.h>
++#include <limits>
+
+ #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
+ // All processors that support AVX2 do support F16C too. That doesn't mean
+diff --git a/src/corelib/tools/qbytearraymatcher.h b/src/corelib/tools/qbytearraymatcher.h
+index dafaea9c12..fd9038dcc6 100644
+--- a/src/corelib/tools/qbytearraymatcher.h
++++ b/src/corelib/tools/qbytearraymatcher.h
+@@ -40,6 +40,7 @@
+ #ifndef QBYTEARRAYMATCHER_H
+ #define QBYTEARRAYMATCHER_H
+
++#include <limits>
+ #include <QtCore/qbytearray.h>
+
+ QT_BEGIN_NAMESPACE
+diff --git a/src/tools/moc/generator.cpp b/src/tools/moc/generator.cpp
+index 12ffd6ae95..a6683d303c 100644
+--- a/src/tools/moc/generator.cpp
++++ b/src/tools/moc/generator.cpp
+@@ -40,6 +40,7 @@
+ #include <QtCore/qplugin.h>
+ #include <QtCore/qstringview.h>
+
++#include <limits>
+ #include <math.h>
+ #include <stdio.h>
+
diff --git a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
index 668f5764..48466883 100644
--- a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 65964cf34bb703359ad42fee3b56aa768582bbdc Mon Sep 17 00:00:00 2001
+From 0eb870c467ecb1f756f665e65798deb21dd360f0 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
@@ -14,10 +14,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/src.pro b/src/src.pro
-index b704ccd7ab..422865874f 100644
+index 1c76a2e46f..fbd4014fb3 100644
--- a/src/src.pro
+++ b/src/src.pro
-@@ -236,7 +236,7 @@ qtConfig(gui) {
+@@ -232,7 +232,7 @@ qtConfig(gui) {
}
}
}
diff --git a/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch b/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch
index 32311591..4daa3bee 100644
--- a/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch
+++ b/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch
@@ -1,4 +1,4 @@
-From e98e9c57e8c614ae14e1f3a423c508a59025fd49 Mon Sep 17 00:00:00 2001
+From e45d6335b5030195cffb54a49632e0123477cf42 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 14 Apr 2019 13:27:58 +0200
Subject: [PATCH] Avoid renameeat2 for native(sdk) builds
diff --git a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
index bef94fc1..493d867f 100644
--- a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 620ce7709bfdc46fb7a5b256c6b14d01563e8314 Mon Sep 17 00:00:00 2001
+From 51756824d0aad6965aeec06581b0181e28a6b402 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index fb6449f3..200cb430 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.9
+# 5.12.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -33,6 +33,7 @@ SRC_URI += "\
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
+ file://0018-qfloat16-Include-limits-header.patch \
"
# for syncqt