aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-01 15:15:10 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-07 23:54:18 +0000
commite117b58d16ead9debac214bfce9a44817975c427 (patch)
tree825ed00a57d48e2a98a84555c8b5bc8b9e0b74f4 /recipes-qt/qt5
parent6280befe6c4dbbc5ac8f384cda4480a1b896b1dd (diff)
qtbase: Fix test builds with clang/x86_64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch48
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1a0e38eb..987d156f 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -45,6 +45,7 @@ SRC_URI += "\
file://0018-Fix-compile-issue-with-gcc-9.patch \
file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
+ file://0023-build-failure-with-clang.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index e636167e..51cc6c4a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -40,6 +40,7 @@ SRC_URI += "\
file://0018-Fix-compile-issue-with-gcc-9.patch \
file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
+ file://0023-build-failure-with-clang.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch b/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch
new file mode 100644
index 00000000..0576a22c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch
@@ -0,0 +1,48 @@
+From f958dccc8c7c777aaca1f110ed48c71b28fdea92 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 1 Mar 2019 15:11:19 -0800
+Subject: [PATCH] Fix build failure with clang
+
+Complement below commit
+
+commit 1555894dec537cbc422f43fe959b0d0ee0000881
+Author: Thiago Macieira <thiago.macieira@intel.com>
+Date: Wed Jul 25 19:04:20 2018 -0700
+
+ QCborValue: Disable support for spaceship operator
+
+ __has_include(<compare>) is not the correct way to detect this feature,
+ since that's a library header and may be provided by an implementation
+ (libc++) before the compiler supports the syntax.
+
+ Change-Id: I80aae0d068974d83b6c0fffd1544c8e558e2446b
+ Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
+
+Fixes
+tst_qcborvalue.cpp:336:17: error: invalid operands to binary expression ('QCborValue' and 'QCborValue')
+ QVERIFY(!(v > other));
+ ~ ^ ~~~~~
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp b/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
+index 38b26e7de4..4b753eab6b 100644
+--- a/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
++++ b/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
+@@ -330,7 +330,7 @@ void tst_QCborValue::copyCompare()
+ QCOMPARE(v, other);
+ QVERIFY(!(v != other));
+ QVERIFY(!(v < other));
+-#if QT_HAS_INCLUDE(<compare>)
++#if 0 && QT_HAS_INCLUDE(<compare>)
+ QVERIFY(v <= other);
+ QVERIFY(v >= other);
+ QVERIFY(!(v > other));
+--
+2.21.0
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index ca31626b..a9c17559 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -36,6 +36,7 @@ SRC_URI += "\
file://0018-Fix-compile-issue-with-gcc-9.patch \
file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
+ file://0023-build-failure-with-clang.patch \
"