aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-08-15 11:18:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-09-02 15:16:33 +0200
commitf30c4ba364030ad1c92d24c6f5ee3bc7e479dc65 (patch)
tree2e636f0dbb5ea67f168a540594e9156163123501 /recipes-qt/qt5
parent3ed820535438a47cf65d5f2015512d4ee99b27b4 (diff)
qttools: Force build of native help-tools when clang is set in PACKAGECONFIG
Am working on recipes for kdevelop and musescore. These require native help tools - at least because cmake configs reference them. * Have tried other - patch-less - ways to achieve this without success * Tested multiple combinations with and without clang in PACKAGECONFIG * gcc/clang toolchain with expected result: For clang set, native tools are build for clang misssing tools are not build. * Target build remained unchanged because it was buildung help tools with clang in PACKAGECONFIG * Tried also to add the patch to nativesdk but help tools were not build. Stopped further investigation - that is not a use case for me - sorry Note for clang-toolchain users (confused me a bit - now it's obvious): For qttools-native clang has to be set explicitly in PACKAGECONFIG, otherwise native help tools are not build (same as behaviour as before). Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch32
-rw-r--r--recipes-qt/qt5/qttools_git.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch b/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch
new file mode 100644
index 00000000..4bc53c79
--- /dev/null
+++ b/recipes-qt/qt5/qttools/0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch
@@ -0,0 +1,32 @@
+From 88c20560720693b6b30d48af748ab232238f9ac8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Fri, 14 Aug 2020 21:25:27 +0200
+Subject: [PATCH] Force native build of qt-help tools as qhelpgenerato
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstrem-Statu: Inappropriate [embedded specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ src/assistant/assistant.pro | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/src/assistant/assistant.pro b/src/assistant/assistant.pro
+index d34b5590..7d87ac48 100644
+--- a/src/assistant/assistant.pro
++++ b/src/assistant/assistant.pro
+@@ -14,9 +14,3 @@ SUBDIRS += \
+
+ assistant.depends = help
+ qhelpgenerator.depends = help
+-
+-qtNomakeTools( \
+- assistant \
+- qhelpgenerator \
+- qcollectiongenerator \
+-)
+--
+2.26.2
+
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 2943db97..117b9143 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -19,6 +19,7 @@ SRC_URI += " \
file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
file://0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch \
"
+SRC_URI_append_class-native = " ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'file://0004-Force-native-build-of-qt-help-tools-as-qhelpgenerato.patch', '', d)}"
FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks"
FILES_${PN}-examples = "${datadir}${QT_DIR_NAME}/examples"
@@ -36,7 +37,7 @@ export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config"
EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
- ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath', 'CONFIG+=noqdoc', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath CONFIG+=assistant', 'CONFIG+=noqdoc', d)} \
"
SRCREV = "6a85b6150554111f7d473d56addfe5a8b5da4400"