aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-16 12:44:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2019-07-17 10:32:59 +0000
commit8f0e74102237fc3d2eeb5012e8fd4ed28ff33503 (patch)
tree8b0ac31c08a2248811ba5e77ada93ca933e1e686 /recipes-qt
parentc8b3085aa4b0030d6ef07b4703763692c2c58ec0 (diff)
qtwebengine: Fix build on aarch64
adapt a patch from meta-browser to get aarch64 going Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0006-chromium-aarch64-skia-build-fix.patch62
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-include-fcntl.h-for-loff_t.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-include-fcntl.h-for-loff_t.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-use-off64_t-instead-of-the-internal-__.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-use-off64_t-instead-of-the-internal-__.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-linux-glibc-make-the-distinction.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-linux-glibc-make-the-distinction.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Use-correct-member-name-__si_fields-fr.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Use-correct-member-name-__si_fields-fr.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Do-not-define-__sbrk-on-musl.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Do-not-define-__sbrk-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Adjust-default-pthread-stack-size.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Adjust-default-pthread-stack-size.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0019-chromium-musl-pread-pwrite.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb29
15 files changed, 90 insertions, 27 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-aarch64-skia-build-fix.patch b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-aarch64-skia-build-fix.patch
new file mode 100644
index 00000000..b97b2dca
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-aarch64-skia-build-fix.patch
@@ -0,0 +1,62 @@
+From 564eb25c70160f6b3f20a6eb5727427efc78b695 Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <raphael.kubo.da.costa@intel.com>
+Date: Thu, 8 Mar 2018 15:39:55 +0100
+Subject: [PATCH] chromium: aarch64 skia build fix
+
+Upstream-Status: Inappropriate
+
+GCC (tested rocko's 7.3.0) cannot find these intrinsics and the build fails:
+
+../../third_party/skia/src/opts/SkRasterPipeline_opts.h: In function 'neon::F neon::from_half(neon::U16)':
+../../third_party/skia/src/opts/SkRasterPipeline_opts.h:657:26: error: cannot convert 'neon::U16 {aka short unsigned int}' to 'float16x4_ t {aka __vector(4) __ fp16}' for argument '1' to '
+float32x4_t vcvt_f32_f16(float16x4_t)'
+ return vcvt_f32_f16(h);
+ ^
+../../third_party/skia/src/opts/SkRasterPipeline_opts.h: In function 'neon::U16 neon::to_half(neon::F)':
+../../third_party/skia/src/opts/SkRasterPipeline_opts.h:677:26: error: cannot convert 'neon::F {aka float}' to 'float32x4_t {aka __vector (4) float}' for argum ent '1' to 'float16x4_t vcvt
+_f16_f32(float32x4_t)'
+ return vcvt_f16_f32(f);
+ ^
+
+Upstream seems to have had similar issues according to
+https://skia-review.googlesource.com/c/skia/+/84222, but there is no fix at the
+moment.
+
+Signed-off-by: Raphael Kubo da Costa <raphael.kubo.da.costa@intel.com>
+---
+ .../skia/src/opts/SkRasterPipeline_opts.h | 15 ++-------------
+ 1 file changed, 2 insertions(+), 13 deletions(-)
+
+diff --git a/chromium/third_party/skia/src/opts/SkRasterPipeline_opts.h b/chromium/third_party/skia/src/opts/SkRasterPipeline_opts.h
+index de14e65b94e..b8be7852086 100644
+--- a/chromium/third_party/skia/src/opts/SkRasterPipeline_opts.h
++++ b/chromium/third_party/skia/src/opts/SkRasterPipeline_opts.h
+@@ -729,12 +729,7 @@ SI F approx_powf(F x, F y) {
+ }
+
+ SI F from_half(U16 h) {
+-#if defined(SK_CPU_ARM64) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+- __fp16 fp16;
+- memcpy(&fp16, &h, sizeof(U16));
+- return float(fp16);
+-
+-#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
++#if defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
+ return _mm256_cvtph_ps(h);
+
+ #else
+@@ -751,13 +746,7 @@ SI F from_half(U16 h) {
+ }
+
+ SI U16 to_half(F f) {
+-#if defined(SK_CPU_ARM64) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+- __fp16 fp16 = __fp16(f);
+- U16 u16;
+- memcpy(&u16, &fp16, sizeof(U16));
+- return u16;
+-
+-#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
++#if defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
+ return _mm256_cvtps_ph(f, _MM_FROUND_CUR_DIRECTION);
+
+ #else
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
index 2972dc6b..c040504a 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
@@ -1,4 +1,4 @@
-From c665cc484556b07aec52fcb1d6851881b646450d Mon Sep 17 00:00:00 2001
+From 34ab4deee6cffc8e6876e991ceabe6baf7308b6f Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:01:12 -0700
Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
index d3e168f2..14b469e1 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
@@ -1,4 +1,4 @@
-From 136539399b9c3c9d2b52a0f789c045ca215682e2 Mon Sep 17 00:00:00 2001
+From 6eec3f3105b0f6b37fdb52efbb4b3820e1d25846 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:09:06 -0700
Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-include-fcntl.h-for-loff_t.patch b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-include-fcntl.h-for-loff_t.patch
index 6c2a4bf7..f6c23b0e 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-include-fcntl.h-for-loff_t.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-include-fcntl.h-for-loff_t.patch
@@ -1,4 +1,4 @@
-From 16488c99dd7d8f05cde58ca39df13c4a54c13d4a Mon Sep 17 00:00:00 2001
+From 87a8cb561129701c8ba94dc927c45cbbb9f5c75b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:37:49 -0700
Subject: [PATCH] chromium: musl: include fcntl.h for loff_t
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-use-off64_t-instead-of-the-internal-__.patch b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
index 7c86f5d3..ca31a456 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
@@ -1,4 +1,4 @@
-From 1f00a9e4b43c742768da46b7580c1d134f5beb37 Mon Sep 17 00:00:00 2001
+From bf780e32b4de82b55368967642bc8f975a93d619 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:38:37 -0700
Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-linux-glibc-make-the-distinction.patch b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-linux-glibc-make-the-distinction.patch
index 34d5456c..8ca842eb 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-linux-glibc-make-the-distinction.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-linux-glibc-make-the-distinction.patch
@@ -1,4 +1,4 @@
-From 1e3a7fcca67a13bc79761d27c8abb5cd3bdb52a7 Mon Sep 17 00:00:00 2001
+From 0dbb65a8a1633a8fe1704ddc0f299799998cc9b0 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:54:38 -0700
Subject: [PATCH] chromium: musl: linux != glibc, make the distinction
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
index 0ea63ea3..f995676a 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
@@ -1,4 +1,4 @@
-From c67e75a89f9e5216eeb9e351b9a6b864f1d992ab Mon Sep 17 00:00:00 2001
+From a74e3dd8323dedb012bce6cf5995ae2a78efd5de Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:09:02 -0700
Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Use-correct-member-name-__si_fields-fr.patch b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
index 1d25ed8c..c4e6ce02 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
@@ -1,4 +1,4 @@
-From 705bb6693c207516b9b96d217f9d417b8360c952 Mon Sep 17 00:00:00 2001
+From 1a11d644434ace1eaf72d2cc8bb3dec350655db5 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:12:39 -0700
Subject: [PATCH] chromium: musl: Use correct member name __si_fields from
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
index 2a162fec..9f1f2b10 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
@@ -1,4 +1,4 @@
-From f236c935f90cc338c8c8db68c08aa8fc2ca13406 Mon Sep 17 00:00:00 2001
+From 319b50c1cb9ab3beaf52d5119feb9ba2283aaa13 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:27:50 -0700
Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Do-not-define-__sbrk-on-musl.patch b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Do-not-define-__sbrk-on-musl.patch
index 9cbb933c..2bb6d115 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Do-not-define-__sbrk-on-musl.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Do-not-define-__sbrk-on-musl.patch
@@ -1,4 +1,4 @@
-From b297eebffe2350a76945191e374f6012d1f0fc16 Mon Sep 17 00:00:00 2001
+From da261d4402fac21694aeca82247974f4043934bc Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:39:57 -0700
Subject: [PATCH] chromium: musl: Do not define __sbrk on musl
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Adjust-default-pthread-stack-size.patch b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Adjust-default-pthread-stack-size.patch
index b92235f8..e1754c1a 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Adjust-default-pthread-stack-size.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Adjust-default-pthread-stack-size.patch
@@ -1,4 +1,4 @@
-From b40a99156402f483f6defb234542f71234ab8ab4 Mon Sep 17 00:00:00 2001
+From 9f526ef03263867d7fb305d5fc91f95e2c9564ea Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 16:41:23 -0700
Subject: [PATCH] chromium: musl: Adjust default pthread stack size
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
index c03fddc2..16c958c9 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
@@ -1,4 +1,4 @@
-From 7def3e9107a6ba742936e038a4dd747613bcf1b6 Mon Sep 17 00:00:00 2001
+From 295afaa918bafc70df23c2c6740e0ef3cc3a7ba5 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 25 Sep 2018 12:35:07 -0700
Subject: [PATCH] chromium: musl: Use _fpstate instead of _libc_fpstate on
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch b/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
index f2d39138..287ef7e6 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
@@ -1,4 +1,4 @@
-From e5c0314a43a30f2cef8bb72560e2cec0ed603e01 Mon Sep 17 00:00:00 2001
+From 73406a38f36c4d5a408b575efdf30f52bf38f75e Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 25 Sep 2018 12:59:05 -0700
Subject: [PATCH] chromium: musl: elf_reader.cc: include <sys/reg.h> to get
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch b/recipes-qt/qt5/qtwebengine/chromium/0019-chromium-musl-pread-pwrite.patch
index 3d041d8a..71d76413 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0019-chromium-musl-pread-pwrite.patch
@@ -1,4 +1,4 @@
-From f446867c2a65d20a62caf69248b48465b58d4046 Mon Sep 17 00:00:00 2001
+From 43c53d6afde5183bc2da3b5b698314d050b2ff5d Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 23 Dec 2018 16:58:04 -0800
Subject: [PATCH] chromium: musl: pread pwrite
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a0179059..1444d41d 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -146,29 +146,30 @@ SRC_URI_append_libc-musl = "\
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/73-based
-# 73-based.meta-qt5.1
+# 73-based.meta-qt5.2
SRC_URI += " \
file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
file://chromium/0003-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
+ file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\
- file://chromium/0006-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
- file://chromium/0007-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
- file://chromium/0008-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
- file://chromium/0009-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
- file://chromium/0010-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
- file://chromium/0011-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
- file://chromium/0012-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
- file://chromium/0013-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
- file://chromium/0014-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
- file://chromium/0015-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
- file://chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
- file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
- file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
+ file://chromium/0007-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
+ file://chromium/0008-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
+ file://chromium/0009-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
+ file://chromium/0010-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
+ file://chromium/0011-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
+ file://chromium/0012-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
+ file://chromium/0013-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
+ file://chromium/0014-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
+ file://chromium/0015-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
+ file://chromium/0016-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
+ file://chromium/0017-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
+ file://chromium/0018-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
+ file://chromium/0019-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
SRCREV_qtwebengine = "5d4bac57a0191287a2fc345f6b398fb1f5d08517"