aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMikko Levonmaa <mikko.levonmaa@palm.com>2013-01-09 14:44:21 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-06 12:21:30 +0200
commit188ff8fb52527ac338c0223350067948d14eca60 (patch)
tree3021c7e617b12381b3bc7f6cf155ff8261f5e701 /recipes-qt
parent37d0412e343cac16c06eb51bf47b5e72d14f852e (diff)
qtbase: Disable mkv8snapshot
* Disabling this for the time being as it generates invalid instructions when the target is arm. Signed-off-by: Mikko Levonmaa <mikko.levonmaa@palm.com> Signed-off-by: Martin Jansa <martin.jansa@lge.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase/0004-Disable-mkv8snapshot.patch46
-rw-r--r--recipes-qt/qt5/qtbase_5.0.0.bb2
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0004-Disable-mkv8snapshot.patch b/recipes-qt/qt5/qtbase/0004-Disable-mkv8snapshot.patch
new file mode 100644
index 00000000..ae483732
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0004-Disable-mkv8snapshot.patch
@@ -0,0 +1,46 @@
+From 2719aaabbf29a0f28638e5d67f4d68d548b593a7 Mon Sep 17 00:00:00 2001
+From: Mikko Levonmaa <mikko.levonmaa@palm.com>
+Date: Tue, 8 Jan 2013 15:58:29 -0800
+Subject: [PATCH] Disable mkv8snapshot
+
+It seems to generate code that throws SIGILL, so disabling it
+
+Program received signal SIGILL, Illegal instruction.
+0x26312c60 in ?? ()
+(gdb) bt
+ function=..., receiver=..., argc=1978934572, args=0x7efff254,
+ has_pending_exception=0x7efff277, qml=...)
+ at ../3rdparty/v8/src/execution.cc:125
+ argc=1, argv=0x7efff254, pending_exception=0x7efff277,
+ convert_receiver=false, qml=...) at ../3rdparty/v8/src/execution.cc:194
+ receiver=<optimized out>, argc=<optimized out>, argv=<optimized out>,
+ pending_exception=0x7efff277, convert_receiver=false)
+ at ../3rdparty/v8/src/execution.cc:161
+ data=<optimized out>, exc=0x7efff277)
+ at ../3rdparty/v8/src/execution.cc:734
+ at ../3rdparty/v8/src/api.cc:4742
+ at qml/v8/qv8contextwrapper.cpp:155
+ ownership=<optimized out>) at qml/v8/qv8engine.cpp:155
+ parent=<optimized out>) at qml/v8/qjsengine.cpp:192
+
+Signed-off-by: Mikko Levonmaa <mikko.levonmaa@palm.com>
+---
+ configure | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure b/configure
+index 89246c8..b7d1cb5 100755
+--- a/configure
++++ b/configure
+@@ -779,7 +779,7 @@ CFG_BUILD_PARTS=""
+ CFG_NOBUILD_PARTS=""
+ CFG_RELEASE_QMAKE=no
+ CFG_AUDIO_BACKEND=auto
+-CFG_V8SNAPSHOT=auto
++CFG_V8SNAPSHOT=no
+ CFG_QML_DEBUG=yes
+ CFG_JAVASCRIPTCORE_JIT=auto
+ CFG_PKGCONFIG=auto
+--
+1.7.4.1
+
diff --git a/recipes-qt/qt5/qtbase_5.0.0.bb b/recipes-qt/qt5/qtbase_5.0.0.bb
index d9c922d6..9a0d68bc 100644
--- a/recipes-qt/qt5/qtbase_5.0.0.bb
+++ b/recipes-qt/qt5/qtbase_5.0.0.bb
@@ -3,5 +3,7 @@ require qt5-${PV}.inc
PR = "${INC_PR}.0"
+SRC_URI += "file://0004-Disable-mkv8snapshot.patch"
+
SRC_URI[md5sum] = "c29073bfc3cf6b39492a2481d982386e"
SRC_URI[sha256sum] = "89bcde09b24e8139f9d1d957dcb07c5aada83d578c84279f66813f348243d500"