aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-25 14:43:45 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-26 17:21:13 +0200
commit22c28fee3cbd394ae1b261854637696b1f5deeb5 (patch)
tree6dff0059317ea4715e57d935fb30d10ea967d208 /recipes-qt
parentf969c48953359c75199634867ab8e1d775b7e747 (diff)
qt5: improve support for native and nativesdk modules
Change qmake.bbclass to support building native and nativesdk packages, so that qmake or qt5-module can be inherited and BBCLASSEXTEND used to create native and nativesdk packages. qtxmlpatterns and qtdeclarative native and nativesdk modules are required for Qt Quick Compiler. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qt5.inc2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
3 files changed, 5 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index ef849bf6..4c58ad69 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -50,7 +50,7 @@ PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmlplu
ALLOW_EMPTY_${PN} = "1"
ALLOW_EMPTY_${PN}-dbg = "1"
-RRECOMMENDS_${PN} = " \
+RRECOMMENDS_${PN}_class-target = " \
${PN}-plugins \
${PN}-qmlplugins \
"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 421c4820..f9689e61 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,3 +33,5 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
SRCREV = "cc0df64bb0e1dea2fe37950816095802f527a241"
+
+BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index cb6bf9df..3c273db5 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -13,3 +13,5 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
SRCREV = "ae6504efc85adf754d60a02f81413e5949282d78"
+
+BBCLASSEXTEND =+ "native nativesdk"