aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-08-13 23:11:36 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 14:38:10 +0200
commit380ecfd7fb3c26f69bc78df287ce5cf5fc91f34f (patch)
tree03d4aa4388395267ce8dd24971e432e9d2f64958 /recipes-qt
parentbaa732006620c132b8a068de495c9a6468042c15 (diff)
qtbase_git: ensure fonts go into own subdir by creating it first
Sometimes, when ${OE_QMAKE_PATH_LIBS} is empty, "cp -a" ends up copying font files there w/o preserving "fonts" directory, failing the following chown command. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 44e2e048..f472c988 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -222,7 +222,8 @@ do_install_append() {
### TODO: FIX
# install fonts manually if they are missing
if [ ! -d ${D}/${OE_QMAKE_PATH_LIBS}/fonts ]; then
- cp -a ${S}/lib/fonts ${D}/${OE_QMAKE_PATH_LIBS}
+ mkdir -p ${D}/${OE_QMAKE_PATH_LIBS}/fonts
+ cp -a ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_LIBS}/fonts
chown -R root:root ${D}/${OE_QMAKE_PATH_LIBS}/fonts
fi