aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-24 14:57:39 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-26 17:20:45 +0200
commitc44912563c4eadc288050f0b5e25981bc432d3f7 (patch)
treebe630e6fc5b07e98d63157372ba39ebe238773d8 /recipes-qt
parent813103e622b721467f64f8a3c4e6a4eab4e346cc (diff)
qtbase: Package the 3rd party libs if built
Third-party libs e.g. libqtfreetype when built is not packaged and hence goes missing in sysroot, then rest of qt components like qtwayland gets its configuration from qtbase to enable it but then does not find the internal version of libqtfreetype.a which is what qtbase directs it to use and as a result it starts throwing linking errors e.g. x86_64-angstrom-linux-ld.gold: error: cannot find -lqtfreetype This patch installs the needed libs into dev packages Remove a trailing whitespace as well while at it. Signed-off-by: Khem Raj <raj.khem@gmail.com> Tested-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 0d3f685d..006968b0 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -229,9 +229,9 @@ do_install_append() {
cp -a ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_LIBS}/fonts
chown -R root:root ${D}/${OE_QMAKE_PATH_LIBS}/fonts
fi
-
+ cp -a ${B}/lib/libqt* ${D}${libdir}
# Remove example.pro file as it is useless
- rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro
+ rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro
# Remove macx-ios-clang directory because /usr/lib/qt5/mkspecs/macx-ios-clang/rename_main.sh:#!/bin/bash
# triggers QA Issue: qtbase-mkspecs requires /bin/bash, but no providers in its RDEPENDS [file-rdeps]