aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2018-01-08 06:52:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2018-01-15 17:54:58 +0000
commitf5cb85e6293e1f742d77959cd1d7e42d536b259f (patch)
tree5f03b9326b03488e285cfbc8ea6e017b221a2d2f /recipes-qt
parent0fd9104da4939ab65652d324ce7008dfb5e7b938 (diff)
qtbase: introduce QT_EDITION
QT_EDITION defaults to 'opensource', but the end users could override it with 'commercial' if they want. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 33be99e7..3aeb2ab1 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -103,7 +103,7 @@ deltask generate_qt_config_file
do_configure() {
${S}/configure -v \
- -opensource -confirm-license \
+ -${QT_EDITION} -confirm-license \
-sysroot ${STAGING_DIR_TARGET} \
-no-gcc-sysroot \
-system-zlib \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 4c6b7015..597b45ed 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -103,7 +103,7 @@ do_configure_prepend() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
touch ${S}/mkspecs/oe-device-extra.pri
- MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
+ MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -${QT_EDITION} -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
}
do_install() {
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 4e8dc4cd..e2784d82 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -171,7 +171,7 @@ do_configure() {
touch ${S}/mkspecs/oe-device-extra.pri
${S}/configure -v \
- -opensource -confirm-license \
+ -${QT_EDITION} -confirm-license \
-sysroot ${STAGING_DIR_TARGET} \
-prefix ${OE_QMAKE_PATH_PREFIX} \
-bindir ${OE_QMAKE_PATH_BINS} \