aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2022-12-25 14:33:23 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2022-12-25 15:35:34 +0100
commitba52d87706b24f1edda966cbafa1bfffea12e050 (patch)
treecd5df3f113253788758519c2c47d8d20145183d9 /recipes-qt
parent7068a3bf0911dc9d7fd5531b126d052c6e89a918 (diff)
recipes: use 5.12 branch instead of delete 5.12.12, except qtbase's nobranch
qtbase v5.12.12 tag isn't included in any branch after 5.12.12 branch was deleted by stupid script from: https://bugreports.qt.io/browse/QTQAINFRA-3091 Released branches should be deleted Branches are cheap, breaking existing projects like meta-qt5 without good reason is not. It's possible to apply work around QT_MODULE_BRANCH_PARAM="nobranch=1" in meta-qt5, but some projects are using some older revision from meta-qt5 and will need to apply such work around locally as well. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb4
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
4 files changed, 13 insertions, 1 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 9c18525d..be37f552 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -198,3 +198,7 @@ do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
SRCREV = "01272c0948be9f1c6b8a3eff328b931f47d38649"
+
+# v5.12.12 tag isn't included in any branch after 5.12.12 branch was deleted by stupid script from:
+# https://bugreports.qt.io/browse/QTQAINFRA-3091 Released branches should be deleted
+QT_MODULE_BRANCH_PARAM = "nobranch=1"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 8b87011c..5141caf4 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2019 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.12.12"
+QT_MODULE_BRANCH ?= "5.12"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
# each module needs to define valid SRCREV
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 9d5359c5..7cf33dc7 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -145,3 +145,7 @@ do_install() {
}
SRCREV = "01272c0948be9f1c6b8a3eff328b931f47d38649"
+
+# v5.12.12 tag isn't included in any branch after 5.12.12 branch was deleted by stupid script from:
+# https://bugreports.qt.io/browse/QTQAINFRA-3091 Released branches should be deleted
+QT_MODULE_BRANCH_PARAM = "nobranch=1"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 888f8a0f..a021e7c9 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -299,3 +299,7 @@ sed -i \
}
SRCREV = "01272c0948be9f1c6b8a3eff328b931f47d38649"
+
+# v5.12.12 tag isn't included in any branch after 5.12.12 branch was deleted by stupid script from:
+# https://bugreports.qt.io/browse/QTQAINFRA-3091 Released branches should be deleted
+QT_MODULE_BRANCH_PARAM = "nobranch=1"