aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-01 21:35:06 -0800
committerMartin Jansa <martin2.jansa@lgepartner.com>2023-01-13 21:46:46 +0000
commitc89865dee104514f33b1579bddc47ff44a438b93 (patch)
treec79821a8a0478dad546c6bfcf214693b98907a2b /recipes-qt
parentba52d87706b24f1edda966cbafa1bfffea12e050 (diff)
qtbase: Fix build with 64bit time_t on glibc
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch37
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..17a34761
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,37 @@
+From 4e00087b393183493a0f7115fd41efc867bd3421 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 1 Jan 2023 21:30:23 -0800
+Subject: [PATCH] zlib: Do not undefine _FILE_OFFSET_BITS
+
+This is required for 64bit time_t to work with glibc as it needs
+_FILE_OFFSET_BITS to be defined as 64 as well.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/3rdparty/zlib/src/gzguts.h | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/src/3rdparty/zlib/src/gzguts.h b/src/3rdparty/zlib/src/gzguts.h
+index 20de7cb4ce..f6ab9357c7 100644
+--- a/src/3rdparty/zlib/src/gzguts.h
++++ b/src/3rdparty/zlib/src/gzguts.h
+@@ -12,15 +12,6 @@
+ # endif
+ #endif
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifndef QT_BOOTSTRAPPED
+ # include <qconfig.h>
+ #endif
+--
+2.39.0
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index a021e7c9..a13eb25a 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -36,6 +36,8 @@ SRC_URI += "\
file://0018-qfloat16-Include-limits-header.patch \
"
+SRC_URI += "file://0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch"
+
# for syncqt
RDEPENDS:${PN}-tools += "perl"