aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-23 19:42:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-24 11:57:45 +0100
commita35403dcf6b75ee7355108cab3e466009003b1a7 (patch)
treef1f691fd361b6305f6fc780114458c04bc88cb7e /recipes-qt
parenta797f85c6fa0b89cb20ac0346cf0406cc85569ce (diff)
qtwebkit: remove
* it wasn't updated for very long time and I assume that all users already migrated to qtwebengine if not let me know that you'll start maintaining this recipe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rwxr-xr-xrecipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb6
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch28
-rw-r--r--recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch69
-rw-r--r--recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch25
-rw-r--r--recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch37
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb89
7 files changed, 1 insertions, 255 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
index 0fca38e6..2d006242 100755
--- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
@@ -8,11 +8,6 @@ inherit packagegroup
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
-# Requires Ruby to work
-USE_RUBY = " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qtwebkit-dev', '', d)} \
-"
-
# Requires Wayland to work
USE_WAYLAND = " \
qtwayland-dev \
@@ -90,7 +85,6 @@ RDEPENDS_${PN} += " \
qttools-staticdev \
qttools-tools \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '${USE_WAYLAND}', '', d)} \
- ${USE_RUBY} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${USE_X11}', '', d)} \
qtwebsockets-dev \
qtwebsockets-mkspecs \
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 5b723ab4..5c11e4e8 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
inherit qmake5
-DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib"
+DEPENDS = "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib"
DEPENDS_append_toolchain-clang = " clang llvm-common"
DEPENDS_append_libc-musl = " libexecinfo"
diff --git a/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch b/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch
deleted file mode 100644
index a237d03d..00000000
--- a/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 34018c2a61045c58f88e09a12ecd62533aa2c2f1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Mon, 4 Jun 2018 10:35:46 +0200
-Subject: [PATCH] Do not skip build for cross-compile
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Inappropriate [OE specific]
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- Tools/qmake/mkspecs/features/functions.prf | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/Tools/qmake/mkspecs/features/functions.prf b/Tools/qmake/mkspecs/features/functions.prf
-index e3f42cec4..797b7085f 100644
---- a/Tools/qmake/mkspecs/features/functions.prf
-+++ b/Tools/qmake/mkspecs/features/functions.prf
-@@ -53,8 +53,6 @@ defineReplace(appleSdkVersion) {
- defineTest(isPlatformSupported) {
- !qtHaveModule(widgets): skipBuild("QtWidgets module is required to build QtWebKit.")
-
-- cross_compile: skipBuild("cross-compilation of QtWebKit with qmake is not supported yet")
--
- requiredPrograms = cmake gperf python perl bison ruby flex
- for(program, requiredPrograms): \
- !programExistsInPath($$program): \
diff --git a/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch b/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch
deleted file mode 100644
index bf79b363..00000000
--- a/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From c4ceb318aa1064bfa677cdd800c52155eb1bed3a Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 23 Aug 2018 04:06:17 +0000
-Subject: [PATCH] Fix build with non-glibc libc on musl
-
-Need to ensure glibc features are not assumed to be linux-wide
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++----
- .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++
- 2 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-index 883914fd3..ce4e8d331 100644
---- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-+++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-@@ -566,7 +566,7 @@ void* MachineThreads::Thread::Registers::stackPointer() const
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__) && ENABLE(JIT)
-+#elif defined(__linux__) && ENABLE(JIT)
-
- #if CPU(X86)
- return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESP]);
-@@ -665,7 +665,7 @@ void* MachineThreads::Thread::Registers::framePointer() const
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -747,7 +747,7 @@ void* MachineThreads::Thread::Registers::instructionPointer() const
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-@@ -838,7 +838,7 @@ void* MachineThreads::Thread::Registers::llintPC() const
- #error Unknown Architecture
- #endif
-
--#elif defined(__GLIBC__)
-+#elif defined(__linux__)
-
- // The following sequence depends on glibc's sys/ucontext.h.
- #if CPU(X86)
-diff --git a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
-index fd7f869d4..e95391b32 100644
---- a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
-+++ b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
-@@ -51,8 +51,10 @@
- #include <cxxabi.h>
- #if OS(DARWIN) || (OS(LINUX) && !PLATFORM(GTK))
- #include <dlfcn.h>
-+#if defined(__GLIBC__)
- #include <execinfo.h>
- #endif
-+#endif
-
- #if ENABLE(REMOTE_INSPECTOR)
- #include "JSGlobalObjectDebuggable.h"
diff --git a/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch b/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch
deleted file mode 100644
index ffd8da0f..00000000
--- a/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f6576377f8bf2c854d8079b7f309f570b3d2bde4 Mon Sep 17 00:00:00 2001
-From: Lei Maohui <leimaohui@cn.fujitsu.com>
-Date: Fri, 31 Aug 2018 15:42:48 +0900
-Subject: [PATCH] Fix build bug for armv32 BE.
-
-Upstream-Status: Pending
-
-Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
----
- Source/WTF/wtf/dtoa/utils.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Source/WTF/wtf/dtoa/utils.h b/Source/WTF/wtf/dtoa/utils.h
-index 889642cee..05302e6e6 100644
---- a/Source/WTF/wtf/dtoa/utils.h
-+++ b/Source/WTF/wtf/dtoa/utils.h
-@@ -49,7 +49,7 @@
- defined(__ARMEL__) || \
- defined(_MIPS_ARCH_MIPS32R2)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
--#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA)
-+#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA) || CPU(ARM)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
- #elif defined(_M_IX86) || defined(__i386__)
- #if defined(_WIN32)
diff --git a/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch b/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch
deleted file mode 100644
index 14cb8aa4..00000000
--- a/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 83aa5b3265d7c9f64e754cb890988cf8a5669ce7 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 24 Sep 2018 02:11:10 -0700
-Subject: [PATCH] PlatformQt.cmake: Do not generate hardcoded include paths
-
-If we do not use this define,then it falls into else case which
-generated .pri files with /usr/include and so on for includes and
-compiler does not like specifying absolute include paths pointing to
-build host includes
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Source/WebKit/PlatformQt.cmake | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
-index 9aed9906e..48638aef4 100644
---- a/Source/WebKit/PlatformQt.cmake
-+++ b/Source/WebKit/PlatformQt.cmake
-@@ -512,7 +512,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
- install(FILES ${WebKit_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
- endif ()
-
--if (KDE_INSTALL_USE_QT_SYS_PATHS)
-+if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE)
- set(WebKit_PRI_ARGUMENTS
- BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE"
- LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE"
-@@ -737,7 +737,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
- install(FILES ${WebKitWidgets_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
- endif ()
-
--if (KDE_INSTALL_USE_QT_SYS_PATHS)
-+if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE)
- set(WebKitWidgets_PRI_ARGUMENTS
- BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE"
- LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
deleted file mode 100644
index 942e733a..00000000
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ /dev/null
@@ -1,89 +0,0 @@
-require qt5.inc
-require qt5-git.inc
-
-LICENSE = "BSD & LGPLv2+ | GPL-2.0"
-LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
- file://Source/JavaScriptCore/parser/Parser.h;endline=21;md5=bd69f72183a7af673863f057576e21ee \
-"
-
-DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-native bison-native flex-native"
-
-# Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.13
-# 5.13.meta-qt5.1
-SRC_URI += "\
- file://0001-Do-not-skip-build-for-cross-compile.patch \
- file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
- file://0003-Fix-build-bug-for-armv32-BE.patch \
- file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
-"
-
-inherit cmake_qt5 perlnative
-
-inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
-
-python() {
- if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
- raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
-}
-
-# qemuarm build fails with:
-# | {standard input}: Assembler messages:
-# | {standard input}:106: Error: invalid immediate: 983040 is out of range
-# | {standard input}:106: Error: value of 983040 too large for field of 2 bytes at 146
-ARM_INSTRUCTION_SET_armv4 = "arm"
-ARM_INSTRUCTION_SET_armv5 = "arm"
-
-# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
-# https://bugs.webkit.org/show_bug.cgi?id=159880
-# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
-# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
-ARM_INSTRUCTION_SET_armv7a = "thumb"
-ARM_INSTRUCTION_SET_armv7r = "thumb"
-ARM_INSTRUCTION_SET_armv7ve = "thumb"
-
-# http://errors.yoctoproject.org/Errors/Details/179245/
-# just use -fpermissive in this case like fedora did:
-# https://bugzilla.redhat.com/show_bug.cgi?id=1582954
-CXXFLAGS += "-fpermissive"
-
-EXTRA_OECMAKE += " \
- -DPORT=Qt \
- -DCROSS_COMPILE=ON \
- -DECM_MKSPECS_INSTALL_DIR=${libdir}${QT_DIR_NAME}/mkspecs/modules \
- -DQML_INSTALL_DIR=${OE_QMAKE_PATH_QML} \
-"
-
-EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}'"
-
-# JIT not supported on MIPS/PPC
-EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
-EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
-# Disable gold on mips64/clang
-# mips64-yoe-linux-musl-ld.gold: internal error in get_got_page_offset, at ../../gold/mips.cc:6260
-# mips-yoe-linux-musl-ld.gold: error: Can't find matching LO16 reloc
-EXTRA_OECMAKE_append_toolchain-clang_mipsarch = " -DUSE_LD_GOLD=OFF "
-
-PACKAGECONFIG ??= "qtlocation qtmultimedia qtsensors qtwebchannel \
- ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
- fontconfig \
-"
-
-# gstreamer conflicts with qtmultimedia!
-PACKAGECONFIG[gstreamer] = "-DUSE_GSTREAMER=ON,-DUSE_GSTREAMER=OFF,gstreamer1.0 gstreamer1.0-plugins-base"
-PACKAGECONFIG[qtlocation] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,qtlocation"
-PACKAGECONFIG[qtmultimedia] = "-DUSE_QT_MULTIMEDIA=ON,-DUSE_QT_MULTIMEDIA=OFF,qtmultimedia"
-PACKAGECONFIG[qtsensors] = "-DENABLE_DEVICE_ORIENTATION=ON,-DENABLE_DEVICE_ORIENTATION=OFF,qtsensors"
-PACKAGECONFIG[qtwebchannel] = "-DENABLE_QT_WEBCHANNEL=ON,-DENABLE_QT_WEBCHANNEL=OFF,qtwebchannel"
-PACKAGECONFIG[libwebp] = ",,libwebp"
-PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,libxcomposite libxrender"
-PACKAGECONFIG[fontconfig] = "-DENABLE_TEST_SUPPORT=ON,-DENABLE_TEST_SUPPORT=OFF,fontconfig"
-# hyphen is only in meta-office currently!
-PACKAGECONFIG[hyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,hyphen"
-
-# remove default ${PN}-examples* set in qt5.inc, because they conflicts with ${PN} from separate webkit-examples recipe
-PACKAGES_remove = "${PN}-examples"
-
-QT_MODULE_BRANCH = "dev"
-
-SRCREV = "ab1bd15209abaf7effc51dbc2f272c5681af7223"