aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-18 10:34:36 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 00:55:36 +0000
commitc483f15ee654f2b9d6eab0e34461299acadbdc49 (patch)
treed7b1de80124a3c17c00889eda2c123f9e06a49a4 /recipes-qt
parentb725e6de4549221b191174bcbfc78fd57c4638e8 (diff)
qtbase: Fix build with gcc9
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch34
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 760eb7ca..34f27f1e 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -44,6 +44,7 @@ SRC_URI += "\
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0022-Fix-compile-issue-with-gcc-9.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 31c10ff6..04deec67 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -39,6 +39,7 @@ SRC_URI += "\
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0022-Fix-compile-issue-with-gcc-9.patch \
"
# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch b/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch
new file mode 100644
index 00000000..6c72061d
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0022-Fix-compile-issue-with-gcc-9.patch
@@ -0,0 +1,34 @@
+From 0d89dead4396126606fb7954c0bb0a2734d2347b Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Date: Tue, 13 Nov 2018 16:00:23 +0100
+Subject: [PATCH] Fix compile issue with gcc 9
+
+It appears messenne_twisters in the latest libstdc++ has one more
+requirement before it is willing to construct with our
+SystemGenerator struct as an sseq provider.
+
+Upstream-Status: Backport
+
+Change-Id: If38151d1fa6f40a80274acc26d9ed6b4ac6049fe
+Reviewed-by: Giuseppe D'Angelo <giuseppe.dangelo@kdab.com>
+Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
+---
+
+ src/corelib/global/qrandom.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
+index ebf9864b15..577736a867 100644
+--- a/src/corelib/global/qrandom.cpp
++++ b/src/corelib/global/qrandom.cpp
+@@ -218,6 +218,7 @@ struct QRandomGenerator::SystemGenerator
+ #endif // Q_OS_WINRT
+
+ static SystemGenerator &self();
++ typedef quint32 result_type;
+ void generate(quint32 *begin, quint32 *end) Q_DECL_NOEXCEPT_EXPR(FillBufferNoexcept);
+
+ // For std::mersenne_twister_engine implementations that use something
+--
+2.20.1
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e50c90f5..6d4fd0c2 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -35,6 +35,7 @@ SRC_URI += "\
file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0020-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0021-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0022-Fix-compile-issue-with-gcc-9.patch \
"