aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorLorenzo Chianura <zuloch@gmail.com>2017-11-30 19:19:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-12-20 08:17:27 +0000
commit1421787254c26d3fd4269630786b1fb1f1d078e7 (patch)
tree2cb32e7696a54f03f624a684ef592e792d11f467 /recipes-qt
parent5ae76bbcf5b59b12a03d0f017aab9139609f16f6 (diff)
Fix missing OE_QMAKE_STRIP env variable
Using Qt based SDK for stripping ARM binaries results in errors. Generated Makefile contains: STRIP = \$(OE_QMAKE_STRIP) but due to the missing export of OE_QMAKE_STRIP variable STRIP will be unset and no strip will be perfomed: install -m 755 -p lib/libSigUdev.so.1.0.0 /opt/poky/2.2.1/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libSigUdev.so.1.0.0 strip-unneeded /opt/poky/2.2.1/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libSigUdev.so.1.0.0 make: strip-unneeded: Command not found Makefile:576: recipe for target 'install_target' failed make: [install_target] Error 127 (ignored) adding OE_QMAKE_STRIP=$STRIP to generated qt5.sh solve the issue. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 710d3a18..33be99e7 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -183,6 +183,7 @@ fakeroot do_generate_qt_environment_file() {
echo 'export OE_QMAKE_CXX=$CXX' >> $script
echo 'export OE_QMAKE_LINK=$CXX' >> $script
echo 'export OE_QMAKE_AR=$AR' >> $script
+ echo 'export OE_QMAKE_STRIP=$STRIP' >> $script
echo 'export QT_CONF_PATH=${OE_QMAKE_PATH_HOST_BINS}/qt.conf' >> $script
echo 'export OE_QMAKE_LIBDIR_QT=`qmake -query QT_INSTALL_LIBS`' >> $script
echo 'export OE_QMAKE_INCDIR_QT=`qmake -query QT_INSTALL_HEADERS`' >> $script