aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorJeroen Hofstee <jhofstee@victronenergy.com>2017-11-21 10:51:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-12-20 08:23:09 +0000
commit3cf0bbb8e1113376d5b5b26ecff362e180a180fd (patch)
tree34d11ac23af97ceec6be4461927db82f59d89bd9 /recipes-qt
parentaeeaa939c7f129a4be2220c86fcebca0fcc8b100 (diff)
qtbase_git: install qt.conf for the target
The build-in qmake settings point to the sysroots on the host machine. Running qmake on the target hence errors with: Could not find qmake configuration file linux-oe-g++. Error processing project file So add qt.conf to the target image with the correct locations. Signed-off-by: Jeroen Hofstee <jhofstee@victronenergy.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e5f0ab76..4e8dc4cd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -239,6 +239,8 @@ do_install_append() {
echo "isEmpty(QMAKE_LINK_C_SHLIB): QMAKE_LINK_C_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
echo "isEmpty(QMAKE_LFLAGS): QMAKE_LFLAGS = ${OE_QMAKE_LDFLAGS}" >> $conf
echo "isEmpty(QMAKE_STRIP): QMAKE_STRIP = ${TARGET_PREFIX}strip" >> $conf
+
+ generate_target_qt_config_file ${D}${OE_QMAKE_PATH_BINS}/qt.conf
}
# mkspecs have mac specific scripts that depend on perl and bash