aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-01-26 00:00:15 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2019-04-22 12:39:16 +0000
commit3d60f9a4047979587624ad97776530cc807ef21c (patch)
tree69b8e4a8dfe221212cb0b73c6162d7187ab08590 /recipes-qt
parenteb5d6daa354d51289e73e36b5c104806821e563b (diff)
qtwayland: workaround upstream bug: install missing headers manually
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 28dd2be8..f85fe356 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,3 +44,20 @@ BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+
+# Since version 5.11.2 some private headers are not installed. Work around
+# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
+# further details
+do_install_append() {
+ if [ -d "${B}/src/client" ]; then
+ upstream_pv=`echo "${PV}" | sed 's:+git.*::g'`
+ for header in `find ${B}/src/client -name '*wayland-*.h'`; do
+ header_base=`basename $header`
+ dest="${D}${includedir}/QtWaylandClient/$upstream_pv/QtWaylandClient/private/$header_base"
+ if [ ! -e "$dest" ]; then
+ echo "Manual install: $header_base to $dest"
+ install -m 644 "$header" "$dest"
+ fi
+ done
+ fi
+}