aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-04-22 20:09:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-04-22 20:09:04 +0000
commit7dc422d94a0028cd5b31aff4e1c5409fb3f66dc4 (patch)
tree64be2801693ba67764c6a0e070fa6b58cfc6b778 /recipes-qt
parent84d647afc8fd96f6ca9ff1600cbaad130df998e4 (diff)
qtwayland: check also that the destination for private headers exists before installing them
* it looks like with 5.12 the QtCompositor headers are actually in QtWaylandCompositor directory and ${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/ doesn't exist causing do_install to fail $ ls /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwayland/5.12.3+gitAUTOINC+bcdc00bcdc-r0/image/usr/include/QtWaylandCompositor/5.12.3/QtWaylandCompositor/private/ qtwaylandcompositor-config_p.h qwaylandpointer_p.h qwayland-server-wayland.h qwaylandxdgdecorationv1_p.h qwldatadevice_p.h wayland-hardware-integration-server-protocol.h qtwaylandcompositorglobal_p.h qwaylandqtwindowmanager_p.h qwayland-server-xdg-decoration-unstable-v1.h qwaylandxdgshellintegration_p.h qwldataoffer_p.h wayland-ivi-application-server-protocol.h qwaylandcompositorextension_p.h qwaylandquickhardwarelayer_p.h qwayland-server-xdg-shell.h qwaylandxdgshell_p.h qwldatasource_p.h wayland-qt-key-unstable-v1-server-protocol.h qwaylandcompositor_p.h qwaylandquickitem_p.h qwayland-server-xdg-shell-unstable-v5_p.h qwaylandxdgshellv5integration_p.h qwlhardwarelayerintegrationfactory_p.h wayland-qt-windowmanager-server-protocol.h qwaylanddestroylistener_p.h qwaylandquickshellsurfaceitem_p.h qwayland-server-xdg-shell-unstable-v6.h qwaylandxdgshellv5_p.h qwlhardwarelayerintegration_p.h wayland-server-buffer-extension-server-protocol.h qwaylandinputmethodcontrol_p.h qwaylandseat_p.h qwaylandshell_p.h qwaylandxdgshellv6integration_p.h qwlhardwarelayerintegrationplugin_p.h wayland-text-input-unstable-v2-server-protocol.h qwaylandiviapplication_p.h qwayland-server-hardware-integration.h qwaylandsurface_p.h qwaylandxdgshellv6_p.h qwlhwintegration_p.h wayland-touch-extension-server-protocol.h qwaylandivisurfaceintegration_p.h qwayland-server-ivi-application.h qwaylandtextinputmanager_p.h qwlbuffermanager_p.h qwlqtkey_p.h wayland-wayland-server-protocol.h qwaylandivisurface_p.h qwayland-server-qt-key-unstable-v1.h qwaylandtextinput_p.h qwlclientbufferintegrationfactory_p.h qwlqttouch_p.h wayland-xdg-decoration-unstable-v1-server-protocol.h qwaylandkeyboard_p.h qwayland-server-qt-windowmanager.h qwaylandtouch_p.h qwlclientbufferintegration_p.h qwlregion_p.h wayland-xdg-shell-server-protocol.h qwaylandkeymap_p.h qwayland-server-server-buffer-extension.h qwaylandview_p.h qwlclientbufferintegrationplugin_p.h qwlserverbufferintegrationfactory_p.h wayland-xdg-shell-unstable-v5-server-protocol_p.h qwaylandoutputmode_p.h qwayland-server-text-input-unstable-v2.h qwaylandwlshellintegration_p.h qwlclientbuffer_p.h qwlserverbufferintegration_p.h wayland-xdg-shell-unstable-v6-server-protocol.h qwaylandoutput_p.h qwayland-server-touch-extension.h qwaylandwlshell_p.h qwldatadevicemanager_p.h qwlserverbufferintegrationplugin_p.h Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 478ddc9a..58ffbe78 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -52,7 +52,7 @@ QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1"
# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2)
SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}"
do_install_append() {
- if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" ]; then
+ if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then
for header in `find ${B}/src/client -name '*wayland-*.h'`; do
header_base=`basename $header`
dest="${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/$header_base"
@@ -62,7 +62,7 @@ do_install_append() {
fi
done
fi
- if [ -d "${B}/src/compositor" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" ]; then
+ if [ -d "${B}/src/compositor" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/" ]; then
for header in `find ${B}/src/compositor -name '*wayland-*.h'`; do
header_base=`basename $header`
dest="${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/$header_base"