aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-26 21:33:57 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2021-10-03 12:27:28 +0200
commita72b27efd3fa8439608f427b81424f129b60dafd (patch)
tree8686679c95b628ba3cac4affb216e5ec194cc1fc /recipes-qt
parent78122af62179a5fecb7da9a42d697d65c78ae8fb (diff)
qtdeclarative: Ask for python3 explicitly
Python2 is going out in Jan 2020 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch60
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
2 files changed, 63 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch b/recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch
new file mode 100644
index 00000000..e1067016
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-Use-python3-explicitly.patch
@@ -0,0 +1,60 @@
+From dc94032e6132b41bd6927357e4a57c31436294eb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 26 Nov 2019 21:10:03 -0800
+Subject: [PATCH] Use python3 explicitly
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ qtdeclarative.pro | 2 +-
+ src/3rdparty/masm/masm.pri | 4 ++--
+ tests/auto/qml/ecmascripttests/test262.py | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/qtdeclarative.pro b/qtdeclarative.pro
+index 5b94da9b6..0e3496ce8 100644
+--- a/qtdeclarative.pro
++++ b/qtdeclarative.pro
+@@ -2,7 +2,7 @@ CONFIG += tests_need_tools examples_need_tools
+ load(qt_parts)
+
+ !python_available {
+- py_out = $$system('python -c "print(1)"')
++ py_out = $$system('python3 -c "print(1)"')
+ !equals(py_out, 1): error("Building QtQml requires Python.")
+ tmp = python_available
+ CONFIG += $$tmp
+diff --git a/src/3rdparty/masm/masm.pri b/src/3rdparty/masm/masm.pri
+index 0e63ac2ce..7a30ab64e 100644
+--- a/src/3rdparty/masm/masm.pri
++++ b/src/3rdparty/masm/masm.pri
+@@ -58,7 +58,7 @@ contains(DEFINES, WTF_USE_UDIS86=1) {
+ udis86.output = udis86_itab.h
+ udis86.input = ITAB
+ udis86.CONFIG += no_link
+- udis86.commands = python $$PWD/disassembler/udis86/itab.py ${QMAKE_FILE_IN}
++ udis86.commands = python3 $$PWD/disassembler/udis86/itab.py ${QMAKE_FILE_IN}
+ QMAKE_EXTRA_COMPILERS += udis86
+
+ udis86_tab_cfile.target = $$OUT_PWD/udis86_itab.c
+@@ -113,7 +113,7 @@ retgen.output = $$GENERATEDDIR/RegExpJitTables.h
+ retgen.script = $$PWD/yarr/create_regex_tables
+ retgen.input = retgen.script
+ retgen.CONFIG += no_link
+-retgen.commands = python $$retgen.script > ${QMAKE_FILE_OUT}
++retgen.commands = python3 $$retgen.script > ${QMAKE_FILE_OUT}
+ QMAKE_EXTRA_COMPILERS += retgen
+
+ # Taken from WebKit/Tools/qmake/mkspecs/features/unix/default_post.prf
+diff --git a/tests/auto/qml/ecmascripttests/test262.py b/tests/auto/qml/ecmascripttests/test262.py
+index 19551e3ba..bf3f79a45 100755
+--- a/tests/auto/qml/ecmascripttests/test262.py
++++ b/tests/auto/qml/ecmascripttests/test262.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #############################################################################
+ ##
+ ## Copyright (C) 2017 The Qt Company Ltd.
+--
+2.24.0
+
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index b79c3db0..ed1e3545 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -28,4 +28,6 @@ SRCREV = "ca5d6cccde1f977eedb46f3320fe8384ea41758e"
BBCLASSEXTEND =+ "native nativesdk"
-SRC_URI += "file://0001-Fix-build-with-gcc-11.patch"
+SRC_URI += "file://0001-Fix-build-with-gcc-11.patch \
+ file://0001-Use-python3-explicitly.patch \
+"