aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 18:20:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-25 12:14:11 +0200
commitebd60ffe7e34f653532e30bfe1fad611a2b31384 (patch)
tree65be4b1962d7bc3a65b1007ae56a3f6f55b9a1cd /recipes-qt
parent71cc38affe7b282fdea6f35c9876632056ef22ec (diff)
qtwayland: add native recipe
* qtwayland fails, because we'll need to add qtwayland-native to provide qtwaylandscanner in QT_EXTERNAL_HOST_BINS location (otherwise build will try to use /usr/bin/qt5/qtwaylandscanner) * native recipe is needed to build qtwayland-scanner which is required after this upstream commit commit 05d054ad7207764293525661876ebc689940a15c Author: Samuel R<C3><B8>dal <samuel.rodal@digia.com> Date: Tue Apr 9 16:52:59 2013 +0200 Introduced qtwaylandscanner. Signed-off-by: Simon Busch <morphis@gravedo.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwayland-native.inc22
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb7
-rw-r--r--recipes-qt/qt5/qtwayland/0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch32
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland-native.inc b/recipes-qt/qt5/qtwayland-native.inc
new file mode 100644
index 00000000..4aa82c36
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland-native.inc
@@ -0,0 +1,22 @@
+require qt5-native.inc
+
+LICENSE = "BSD & LGPL-2.1 | GPL-3.0"
+LIC_FILES_CHKSUM = "file://${S}/src/compositor/compositor_api/qwaylandsurfacenode.cpp;endline=40;md5=e38eccd7e9a6a149c9e31b6fb47daac1 \
+ file://${S}/src/compositor/compositor_api/qwaylandcompositor.cpp;endline=39;md5=8897abe415f27031e4237f09db7b9a36 \
+"
+
+QT_MODULE = "${BPN}"
+
+DEPENDS = "qtbase-native wayland-native"
+
+SRC_URI += " \
+ file://0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch \
+"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S}/src/qtwaylandscanner
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
new file mode 100644
index 00000000..090faafa
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -0,0 +1,7 @@
+require qt5-git.inc
+require ${PN}.inc
+
+# qtwayland wasn't released yet, last tag before this SRCREV is 5.0.0-beta1
+PV = "4.999+5.0.0-beta1+git${SRCPV}"
+
+SRCREV = "ede872db1cdfdc2810c2dd29edd5fb6e1cdac0f5"
diff --git a/recipes-qt/qt5/qtwayland/0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch b/recipes-qt/qt5/qtwayland/0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch
new file mode 100644
index 00000000..1fac95b7
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch
@@ -0,0 +1,32 @@
+From 761367755efa529c41ba414521eaed0b10873d99 Mon Sep 17 00:00:00 2001
+From: Simon Busch <morphis@gravedo.de>
+Date: Fri, 19 Jul 2013 13:35:14 +0000
+Subject: [PATCH] Install the qtwaylandscanner tool to the native side
+
+Upstream-Status: Inappropiate [configuration]
+
+Signed-off-by: Simon Busch <morphis@gravedo.de>
+---
+ src/qtwaylandscanner/qtwaylandscanner.pro | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/qtwaylandscanner/qtwaylandscanner.pro b/src/qtwaylandscanner/qtwaylandscanner.pro
+index ac2d07b..53b93f9 100644
+--- a/src/qtwaylandscanner/qtwaylandscanner.pro
++++ b/src/qtwaylandscanner/qtwaylandscanner.pro
+@@ -1,6 +1,10 @@
+ option(host_build)
+
+-SOURCES += qtwaylandscanner.cpp
++TARGET = qtwaylandscanner$$qtPlatformTargetSuffix()
++CONFIG += console warn_off
++QT = core
+
+-load(qt_tool)
++SOURCES += qtwaylandscanner.cpp
+
++target.path = $$[QT_HOST_BINS]
++INSTALLS += target
+--
+1.8.1.2
+