aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-09-20 10:28:20 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-09-24 15:07:34 +0300
commit61d0a61f4a19521b7b3d4379839210c0ad0bebb1 (patch)
tree8b61d218cabcd4f901213b914565ff7fb9f4c30f /recipes-qt
parent35fa091938fcffbc5efd0c79ae2221e67bd0ae97 (diff)
ogl-runtime: update to v2.5.0-beta1
Change-Id: I76cfb6cab1d0b997b05967398e0863bad08a4e0e Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/ogl-runtime/0002-Adapt-distance-field-cache-to-5.14.patch50
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb3
2 files changed, 1 insertions, 52 deletions
diff --git a/recipes-qt/qt5/ogl-runtime/0002-Adapt-distance-field-cache-to-5.14.patch b/recipes-qt/qt5/ogl-runtime/0002-Adapt-distance-field-cache-to-5.14.patch
deleted file mode 100644
index 619a49e0..00000000
--- a/recipes-qt/qt5/ogl-runtime/0002-Adapt-distance-field-cache-to-5.14.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From e177fb4a0fcf4068cef6a0e018cd98e00f248a13 Mon Sep 17 00:00:00 2001
-From: Laszlo Agocs <laszlo.agocs@qt.io>
-Date: Tue, 13 Aug 2019 10:13:47 +0200
-Subject: [PATCH] Adapt distance field cache to 5.14
-
-There is a new pure virtual in the base class in 5.14. It is not very
-relevant here since this glyph cache is not used in combination with
-the df text materials of Qt Quick. We can nonetheless implement the
-virtual and return the correct value.
-
-Task-number: QT3DS-3856
-Change-Id: I97b807ec73a664488b63c8888bc8cd90a9c53589
----
- src/runtimerender/Qt3DSDistanceFieldGlyphCache.cpp | 7 +++++++
- src/runtimerender/Qt3DSDistanceFieldGlyphCache_p.h | 4 ++++
- 2 files changed, 11 insertions(+)
-
-diff --git a/src/runtimerender/Qt3DSDistanceFieldGlyphCache.cpp b/src/runtimerender/Qt3DSDistanceFieldGlyphCache.cpp
-index e945335..52f01ea 100644
---- a/src/runtimerender/Qt3DSDistanceFieldGlyphCache.cpp
-+++ b/src/runtimerender/Qt3DSDistanceFieldGlyphCache.cpp
-@@ -513,6 +513,13 @@ bool Q3DSDistanceFieldGlyphCache::loadPregeneratedCache(const QRawFont &font)
- return true;
- }
-
-+#if QT_VERSION >= QT_VERSION_CHECK(5,14,0)
-+bool Q3DSDistanceFieldGlyphCache::eightBitFormatIsAlphaSwizzled() const
-+{
-+ return m_context.GetRenderContext().GetRenderContextType() == qt3ds::render::NVRenderContextValues::GLES2;
-+}
-+#endif // QT_VERSION >= QT_VERSION_CHECK(5,14,0)
-+
- QT_END_NAMESPACE
-
- #endif // QT_VERSION >= QT_VERSION_CHECK(5,12,2)
-diff --git a/src/runtimerender/Qt3DSDistanceFieldGlyphCache_p.h b/src/runtimerender/Qt3DSDistanceFieldGlyphCache_p.h
-index 679d3ad..fb4826e 100644
---- a/src/runtimerender/Qt3DSDistanceFieldGlyphCache_p.h
-+++ b/src/runtimerender/Qt3DSDistanceFieldGlyphCache_p.h
-@@ -76,6 +76,10 @@ public:
-
- qreal fontSize() const;
-
-+#if QT_VERSION >= QT_VERSION_CHECK(5,14,0)
-+ bool eightBitFormatIsAlphaSwizzled() const override;
-+#endif
-+
- private:
- bool loadPregeneratedCache(const QRawFont &font);
- TextureInfo *textureInfo(int index) const;
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
index 58d31e98..621d0e24 100644
--- a/recipes-qt/qt5/ogl-runtime_git.bb
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -17,10 +17,9 @@ PV = "2.5+git${SRCPV}"
SRC_URI += " \
${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
file://0001-Fix-examples-build-error.patch \
- file://0002-Adapt-distance-field-cache-to-5.14.patch \
"
-SRCREV_ogl-runtime = "bd488ea03ec4a969e86c55909c60deecdc9f9af2"
+SRCREV_ogl-runtime = "0ab6e1fb491cbc9aa821e11a1ee78915f61ee499"
SRCREV_EASTL = "31697c758f2ed19bd7c6bbe61f1b91f9e12035b5"
SRCREV = "${SRCREV_ogl-runtime}"