aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-29 09:15:43 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-29 11:26:05 +0200
commit60c8b35f13f0969a2244e5ab06333fc3994ed221 (patch)
tree9df5eef7ff4700a8d74a2a667d477ec458a63a48 /recipes-qt
parentddbe177dae46353f08f7326a11d3b3fd5a1f8435 (diff)
parent26637f766a40fd59df6e1edc65e4b14cd2f78014 (diff)
Merge remote-tracking branch 'meta-qt5/master' into master-mingw
* meta-qt5/master: qtbase: add runtime dependency to xkeyboard-config recipetool: add support for Qt5 to meta-qt5 libconnman-qt5: Blacklist because of connman-qt5.pc qt5: skip libdir for ${PN}-dbg and dev-elf for ${PN}-examples-dev qtbase: upgrade SRCREVs a bit more nativesdk-qtbase: use runtime linked dbus Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch recipes-qt/qt5/qtbase_git.bb Change-Id: I51f42699487c82a5f0e9c52f5fd5c5bf4bd51eff
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/libconnman-qt/libconnman-qt5_git.bb2
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb6
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qt5.inc3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0006-QOpenGLPaintDevice-sub-area-support.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0009-Always-build-uic.patch2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtenginio_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb5
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
36 files changed, 46 insertions, 42 deletions
diff --git a/recipes-qt/libconnman-qt/libconnman-qt5_git.bb b/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
index 0fc4bc03..71c04df8 100644
--- a/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
+++ b/recipes-qt/libconnman-qt/libconnman-qt5_git.bb
@@ -15,3 +15,5 @@ S = "${WORKDIR}/git"
inherit pkgconfig
RDEPENDS_${PN} += "connman"
+
+PNBLACKLIST[libconnman-qt5] ?= "BROKEN: QA Issue: connman-qt5.pc failed sanity test (tmpdir)"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index f70179b1..33413479 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -1,6 +1,5 @@
DESCRIPTION = "SDK version of Qt/[X11|Mac|Embedded]"
-DEPENDS = "nativesdk-zlib nativesdk-dbus qtbase-native"
-DEPENDS_remove_mingw32 = "nativesdk-dbus"
+DEPENDS = "nativesdk-zlib qtbase-native"
SECTION = "libs"
HOMEPAGE = "http://qt-project.org"
@@ -146,6 +145,7 @@ do_configure() {
-sysroot ${STAGING_DIR_TARGET} \
-no-gcc-sysroot \
-system-zlib \
+ -dbus-runtime \
-no-libjpeg \
-no-libpng \
-no-gif \
@@ -243,4 +243,4 @@ fakeroot do_generate_qt_environment_file_mingw32() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "8c2b4266002736da499d169a0da187e5cdc5381a"
+SRCREV = "41706400f605524a5a9953714aa0cfbf811dba7e"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 500ebfc1..a19422b6 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -27,6 +27,6 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/*/*/*.obj \
"
-SRCREV = "190795b1f884620ba8b31d3998ac97107d4f4eb7"
+SRCREV = "9b9f34701f47824e8201453d148152fb0855f98a"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 83c3a12b..8a6d93e8 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2014 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.6.0"
+QT_MODULE_BRANCH ?= "5.6"
# each module needs to define valid SRCREV
SRC_URI = " \
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index 70e4b308..85d7d892 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -42,9 +42,10 @@ do_configure_prepend() {
# Many examples come with libraries installed outside of standard libdir,
# suppress QA check complaining
+INSANE_SKIP_${PN}-dbg += "libdir"
INSANE_SKIP_${PN}-examples += "libdir"
INSANE_SKIP_${PN}-examples-dbg += "libdir"
-INSANE_SKIP_${PN}-examples-dev += "libdir"
+INSANE_SKIP_${PN}-examples-dev += "libdir dev-elf"
PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmldesigner ${PN}-qmlplugins ${PN}-tools ${PN}-plugins ${PN}-mkspecs ${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples "
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 75c29e33..e4702284 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -116,4 +116,4 @@ do_install() {
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
-SRCREV = "8c2b4266002736da499d169a0da187e5cdc5381a"
+SRCREV = "41706400f605524a5a9953714aa0cfbf811dba7e"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 77bfe31b..07e34f96 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From f35a940471022c31dfd72aa5d1c942ce64ca5a6a Mon Sep 17 00:00:00 2001
+From bf8e0e2292c8a9233d55714aab5eb780c62a132d Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH 01/10] Add linux-oe-g++ platform
@@ -52,7 +52,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index 1473a62..15207bf 100755
+index f247401..011cd70 100755
--- a/configure
+++ b/configure
@@ -342,6 +342,16 @@ getQMakeConf()
diff --git a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
index c93c6f5d..53ab37f5 100644
--- a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From 8bc8e96a6ad707c5f399c307e519444a1fafc4fe Mon Sep 17 00:00:00 2001
+From 561957e83aa0bc1404654506d1ae83251539d0eb Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH 05/10] configure: bump path length from 256 to 512 characters
@@ -14,7 +14,7 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure b/configure
-index 8fafeca..34c7b8b 100755
+index d30b6e5..aeb4ef2 100755
--- a/configure
+++ b/configure
@@ -3930,10 +3930,10 @@ static const char qt_configure_licensed_products_str [256 + 12] = "qt_lcnsprod=$
diff --git a/recipes-qt/qt5/qtbase/0006-QOpenGLPaintDevice-sub-area-support.patch b/recipes-qt/qt5/qtbase/0006-QOpenGLPaintDevice-sub-area-support.patch
index bd5cfacd..57a0dd11 100644
--- a/recipes-qt/qt5/qtbase/0006-QOpenGLPaintDevice-sub-area-support.patch
+++ b/recipes-qt/qt5/qtbase/0006-QOpenGLPaintDevice-sub-area-support.patch
@@ -1,4 +1,4 @@
-From a2a195bc2782ccf582afb00ffc25021abd2ba810 Mon Sep 17 00:00:00 2001
+From f6d59b0835e32f0575ec1671dff0348af1886da6 Mon Sep 17 00:00:00 2001
From: Jani Hautakangas <jani.hautakangas@ixonos.com>
Date: Thu, 16 May 2013 09:52:07 +0300
Subject: [PATCH 06/10] QOpenGLPaintDevice sub-area support
diff --git a/recipes-qt/qt5/qtbase/0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch b/recipes-qt/qt5/qtbase/0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch
index 525396f0..62e8a0d9 100644
--- a/recipes-qt/qt5/qtbase/0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch
+++ b/recipes-qt/qt5/qtbase/0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch
@@ -1,4 +1,4 @@
-From 4c68f97060427d3184589be4f25e1e366e26557c Mon Sep 17 00:00:00 2001
+From 0cac609e192c303e26d139b4a7d5b35897a020a8 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 8 Jun 2015 13:59:25 -0700
Subject: [PATCH 07/10] linux-oe-g++: Invert conditional for defining
diff --git a/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch b/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch
index 204b3bf6..2ea1954c 100644
--- a/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch
+++ b/recipes-qt/qt5/qtbase/0008-configure-paths-for-target-qmake-properly.patch
@@ -1,4 +1,4 @@
-From 3e343061f8f8cb71fbb4f52e6e825495880779a2 Mon Sep 17 00:00:00 2001
+From caa2e16f3efaede09abcc4cf263e82b4c1cfa6a0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
Date: Fri, 13 Nov 2015 12:36:11 +0100
Subject: [PATCH 08/10] configure paths for target qmake properly
@@ -19,7 +19,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 19 insertions(+), 4 deletions(-)
diff --git a/configure b/configure
-index 34c7b8b..f9869dd 100755
+index aeb4ef2..c696e7e 100755
--- a/configure
+++ b/configure
@@ -3875,8 +3875,13 @@ if [ "$CFG_COMPILE_EXAMPLES" = "yes" ]; then
diff --git a/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
index 4db32e7d..e2b57cef 100644
--- a/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
@@ -1,4 +1,4 @@
-From c9e825dd77c23dda786809ecb19ca1a88dccdf1b Mon Sep 17 00:00:00 2001
+From 376eba77c429a503b05256786f2996b397c2e36f Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH 09/10] Always build uic
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index f6c86c23..ee23ac28 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -108,7 +108,7 @@ PACKAGECONFIG[xvideo] = "-xvideo,-no-xvideo"
PACKAGECONFIG[openvg] = "-openvg,-no-openvg"
PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv"
PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon"
-PACKAGECONFIG[xkbcommon-evdev] = "-xkbcommon-evdev,-no-xkbcommon-evdev,libxkbcommon"
+PACKAGECONFIG[xkbcommon-evdev] = "-xkbcommon-evdev,-no-xkbcommon-evdev,libxkbcommon,xkeyboard-config"
PACKAGECONFIG[evdev] = "-evdev,-no-evdev"
PACKAGECONFIG[mtdev] = "-mtdev,-no-mtdev,mtdev"
# depends on glib
@@ -250,4 +250,4 @@ sysroot_stage_dirs_append() {
rm -rf $to${OE_QMAKE_PATH_QT_FONTS}
}
-SRCREV = "8c2b4266002736da499d169a0da187e5cdc5381a"
+SRCREV = "41706400f605524a5a9953714aa0cfbf811dba7e"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index a5940f25..4990f348 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "f669d1708c1009adc7d82d42bf550e0d971e827f"
+SRCREV = "b351fb164af327828c9bdbc414ffd8e47e387e8c"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index e3113847..cf6d3c51 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -25,4 +25,4 @@ do_configure_prepend() {
sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro
}
-SRCREV = "8b550f0a7508ed413cded71a20485e61010b0aa3"
+SRCREV = "dec32076b9153febc575a0418af702f8cb400258"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index c466a52a..24825ec2 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -38,6 +38,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "19dffeed2e677cf03b6e122c7a15f355ebe413c8"
+SRCREV = "0fab5761d5428aa708edd66e40fc3c449adc4b11"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtenginio_git.bb b/recipes-qt/qt5/qtenginio_git.bb
index 23b9417c..5590abdd 100644
--- a/recipes-qt/qt5/qtenginio_git.bb
+++ b/recipes-qt/qt5/qtenginio_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
-SRCREV = "2a19257a5eef7a25a05d5cf7ea69ecc4184226f3"
+SRCREV = "60a135102aaa37d0d817883e4d6aed456372709d"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index f80f6fad..c35cc809 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "2f0e5e726d76b8ad5a0e9b07aeb57006490e18b4"
+SRCREV = "24f3fd69a2e953619c48b4a632262ce8419fee40"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 0a97f121..b49940be 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -28,4 +28,4 @@ EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'jasper', 'CONFIG+=OE_
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'libtiff', 'CONFIG+=OE_LIBTIFF_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'libwebp', 'CONFIG+=OE_LIBWEBP_ENABLED', '', d)}"
-SRCREV = "0bd46d5861fa7b48c87cd3a734d00671df929869"
+SRCREV = "58f19cf8d51e06f1781f3142e6d872e5feb0690e"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index d6857edb..50729032 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -29,4 +29,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'geoclue', 'CONFIG+=OE_GEOCLUE_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'gypsy', 'CONFIG+=OE_GYPSY_ENABLED', '', d)}"
-SRCREV = "a2b6581e5a865ec1a3a7006b668e36c64d2f7ef5"
+SRCREV = "03163a3c9129b7f982b690e750056506c3d06b41"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 36d7f408..ce423021 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
file://0001-Initial-porting-effort-to-GStreamer-1.0.patch \
"
-SRCREV = "d633c02ce21b4b5aa9d9877c9424fcc0f363aa6b"
+SRCREV = "3b6de26fe585c586d055ac86c5911cc6df0e3887"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index 9d7ddbd6..e0a264d4 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -23,4 +23,4 @@ do_configure_prepend() {
sed -i 's#^qtHaveModule(webkitwidgets):#enable-webkit:qtHaveModule(webkitwidgets):#g' ${S}/src/imports/imports.pro
}
-SRCREV = "dcc5e5c01c28b227f0e5e5e4976a9d26e8a45295"
+SRCREV = "87f2415adf34da08e6cd58f5da6f6a7d0d9cf141"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 5894c533..1e25d6e0 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -13,4 +13,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "fc9c57cf8b66bafbcaa6957bb22293047aa3d9df"
+SRCREV = "93d06fb27d7eae9290db33b6684916a225939f0b"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index eea6911c..32f6ebf3 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -27,4 +27,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "a70f6a1b9599931fccd13b15a1700e61137f7e72"
+SRCREV = "a5e814fd8809dd6a8a3c3efd4b911b36e3325a2a"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index ca0ba4a8..4fbd15b1 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "ad52d307cbff44b77bf7d4fa923377b72bb04374"
+SRCREV = "fbaca62cd0a7309f04bf82101c8e20dbbf423192"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index db6a289c..f32a8e13 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "6dda140ada3d7c683537b069bf1512275a190884"
+SRCREV = "02e4a66a8bd9ce4d2f7f8c89cd1bddf4b6385b5f"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 83abbe6b..d2699f70 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,6 +13,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "38777ea7451d55e9c3d32d88d46063016013f60c"
+SRCREV = "a9ac71a443260de66f720f0184646847b03fcb46"
SRC_URI += "file://0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch"
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 0152e8a5..868e051d 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -33,4 +33,4 @@ QT_MODULE_BRANCH = "dev"
# qtsystems wasn't released yet, last tag before this SRCREV is 5.0.0-beta1
# qt5-git PV is only to indicate that this recipe is compatible with qt5 5.6
-SRCREV = "37b614abbfb35d06a57e5b0824249c3abd5640e3"
+SRCREV = "cc2077700bd5503d1fcf53aef83cbb76975e745a"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 23acf1e9..89916337 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -31,6 +31,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
-SRCREV = "eb59d8084af321d05b4ebdfb2c1e051dfdca0b62"
+SRCREV = "05206b44cf25ca6a895cc9a8716f2b7f2f14191f"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index cc847557..7908a3e5 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -114,4 +114,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "41d212290c3822b8eef151785d89ac5f5b246bde"
+SRCREV = "ce85e4ee4ee22e5dea3b44707a27dab44319708e"
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
index 390f4e66..c88cf696 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bb
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -25,4 +25,4 @@ do_install() {
oe_runmake install INSTALL_ROOT=${D}
}
-SRCREV = "baec8be7294a176620253dbbc1b2938cf96c8360"
+SRCREV = "bebe9beff3e9874498474cec32634cf281ddc453"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index fcf74270..78d8a3eb 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -36,4 +36,4 @@ SRC_URI += " \
file://0001-examples-wayland-include-server-buffer-only-when-bui.patch \
"
-SRCREV = "baec8be7294a176620253dbbc1b2938cf96c8360"
+SRCREV = "bebe9beff3e9874498474cec32634cf281ddc453"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 7d923d8d..eb4475b6 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "92d903d92b430222cd3f89eab08d61d947e5abea"
+SRCREV = "3fa1c9d2cf5e00e7431d042e7955a6dd75e6e2b1"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 0557ec7f..30168f43 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -111,14 +111,15 @@ SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \
file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
+ file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \
file://0004-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
file://0005-Include-dependency-to-QCoreApplication-translate.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "87cc80fd8182b24ff42f0f5458cb82f139730536"
-SRCREV_chromium = "3f655a31b4979b0862e5aec1c8f47b597464749f"
+SRCREV_qtwebengine = "3f02c25de46f5ff296b8189af3435ce5800b39a7"
+SRCREV_chromium = "779a2388fc123a7f3a178ce2ced921ee4a307e2c"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 5c143138..9044d4fb 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -71,4 +71,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-SRCREV = "be8e169ba38c84562194906047d0da04bf3ae91a"
+SRCREV = "d2ff5a085572b1ee24dcb42ae107063f3142d14e"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 2f24933b..c4245628 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -13,6 +13,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "de2dadb8af67f9d425c3a8d2353a7d5b07588915"
+SRCREV = "a8d103a05bc195dd045779f3aebdf67bd0140df1"
BBCLASSEXTEND =+ "native nativesdk"