aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-04-14 13:45:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-04-14 13:51:28 +0200
commit32c62abeb38a177e719de1471985a6aa897645e7 (patch)
tree70a51b72b0f07bc264745e67b6c72f5f83cddfde /recipes-qt
parent44fc90eecafed13d4700d30eb324e331c92eab2a (diff)
qwt-qt5: fix build with Qt 5.15
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch131
-rw-r--r--recipes-qt/qwt/qwt-qt5_6.1.4.bb1
2 files changed, 132 insertions, 0 deletions
diff --git a/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch b/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
new file mode 100644
index 00000000..5caf7930
--- /dev/null
+++ b/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
@@ -0,0 +1,131 @@
+From c44af9a6f0eff02b439ef770755da551f281e9ad Mon Sep 17 00:00:00 2001
+From: rathmann <rathmann@29e17f8d-cf37-471e-a288-72cc03a76eda>
+Date: Sun, 29 Mar 2020 09:11:29 +0000
+Subject: [PATCH] missing qpainterpath.h include added needed with Qt 5.15
+ Beta2
+
+Partial backport from
+https://sourceforge.net/p/qwt/code/3187/
+
+---
+diff -uNr qwt-6.1.4.orig/src/qwt_compass_rose.cpp qwt-6.1.4/src/qwt_compass_rose.cpp
+--- qwt-6.1.4.orig/src/qwt_compass_rose.cpp 2019-01-02 17:21:31.280460826 +0100
++++ qwt-6.1.4/src/qwt_compass_rose.cpp 2020-04-14 13:33:27.214932546 +0200
+@@ -11,6 +11,7 @@
+ #include "qwt_point_polar.h"
+ #include "qwt_painter.h"
+ #include <qpainter.h>
++#include <qpainterpath.h>
+
+ static QPointF qwtIntersection(
+ QPointF p11, QPointF p12, QPointF p21, QPointF p22 )
+diff -uNr qwt-6.1.4.orig/src/qwt_dial_needle.cpp qwt-6.1.4/src/qwt_dial_needle.cpp
+--- qwt-6.1.4.orig/src/qwt_dial_needle.cpp 2019-01-02 17:21:31.284460922 +0100
++++ qwt-6.1.4/src/qwt_dial_needle.cpp 2020-04-14 13:33:37.006864250 +0200
+@@ -13,6 +13,7 @@
+ #include "qwt_painter.h"
+ #include <qapplication.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+
+ #if QT_VERSION < 0x040601
+ #define qFastSin(x) qSin(x)
+diff -uNr qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp qwt-6.1.4/src/qwt_null_paintdevice.cpp
+--- qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp 2019-01-02 17:21:31.296461212 +0100
++++ qwt-6.1.4/src/qwt_null_paintdevice.cpp 2020-04-14 13:31:21.983807348 +0200
+@@ -9,6 +9,7 @@
+
+ #include "qwt_null_paintdevice.h"
+ #include <qpaintengine.h>
++#include <qpainterpath.h>
+ #include <qpixmap.h>
+
+ class QwtNullPaintDevice::PrivateData
+diff -uNr qwt-6.1.4.orig/src/qwt_painter_command.h qwt-6.1.4/src/qwt_painter_command.h
+--- qwt-6.1.4.orig/src/qwt_painter_command.h 2020-04-14 13:29:35.128556140 +0200
++++ qwt-6.1.4/src/qwt_painter_command.h 2020-04-14 13:28:23.957056341 +0200
+@@ -15,6 +15,7 @@
+ #include <qpixmap.h>
+ #include <qimage.h>
+ #include <qpolygon.h>
++#include <qpainterpath.h>
+
+ class QPainterPath;
+
+diff -uNr qwt-6.1.4.orig/src/qwt_painter.cpp qwt-6.1.4/src/qwt_painter.cpp
+--- qwt-6.1.4.orig/src/qwt_painter.cpp 2019-01-02 17:21:31.452464985 +0100
++++ qwt-6.1.4/src/qwt_painter.cpp 2020-04-14 13:30:22.356224890 +0200
+@@ -19,6 +19,7 @@
+ #include <qpainter.h>
+ #include <qpalette.h>
+ #include <qpaintdevice.h>
++#include <qpainterpath.h>
+ #include <qpixmap.h>
+ #include <qstyle.h>
+ #include <qtextdocument.h>
+diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp qwt-6.1.4/src/qwt_plot_glcanvas.cpp
+--- qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp 2019-01-02 17:21:31.300461309 +0100
++++ qwt-6.1.4/src/qwt_plot_glcanvas.cpp 2020-04-14 13:33:14.947018129 +0200
+@@ -12,6 +12,7 @@
+ #include "qwt_painter.h"
+ #include <qevent.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qdrawutil.h>
+ #include <qstyle.h>
+ #include <qstyleoption.h>
+diff -uNr qwt-6.1.4.orig/src/qwt_plot_panner.cpp qwt-6.1.4/src/qwt_plot_panner.cpp
+--- qwt-6.1.4.orig/src/qwt_plot_panner.cpp 2019-01-02 17:21:31.468465371 +0100
++++ qwt-6.1.4/src/qwt_plot_panner.cpp 2020-04-14 13:32:33.259309129 +0200
+@@ -14,6 +14,7 @@
+ #include <qbitmap.h>
+ #include <qstyle.h>
+ #include <qstyleoption.h>
++#include <qpainterpath.h>
+
+ #if QT_VERSION >= 0x050000
+ #if QT_VERSION < 0x050100
+diff -uNr qwt-6.1.4.orig/src/qwt_plot_renderer.cpp qwt-6.1.4/src/qwt_plot_renderer.cpp
+--- qwt-6.1.4.orig/src/qwt_plot_renderer.cpp 2019-01-02 17:21:31.352462567 +0100
++++ qwt-6.1.4/src/qwt_plot_renderer.cpp 2020-04-14 13:31:51.019604276 +0200
+@@ -20,6 +20,7 @@
+ #include "qwt_math.h"
+
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qtransform.h>
+ #include <qprinter.h>
+ #include <qfiledialog.h>
+diff -uNr qwt-6.1.4.orig/src/qwt_widget_overlay.cpp qwt-6.1.4/src/qwt_widget_overlay.cpp
+--- qwt-6.1.4.orig/src/qwt_widget_overlay.cpp 2019-01-02 17:21:31.388463437 +0100
++++ qwt-6.1.4/src/qwt_widget_overlay.cpp 2020-04-14 13:31:07.091911561 +0200
+@@ -11,6 +11,7 @@
+ #include "qwt_painter.h"
+ #include <qpainter.h>
+ #include <qpaintengine.h>
++#include <qpainterpath.h>
+ #include <qimage.h>
+ #include <qevent.h>
+
+diff -uNr qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp qwt-6.1.4/examples/dials/attitude_indicator.cpp
+--- qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp 2019-01-02 17:21:31.164458020 +0100
++++ qwt-6.1.4/examples/dials/attitude_indicator.cpp 2020-04-14 13:44:46.354218570 +0200
+@@ -3,6 +3,7 @@
+ #include <qwt_round_scale_draw.h>
+ #include <qevent.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qpolygon.h>
+
+ AttitudeIndicatorNeedle::AttitudeIndicatorNeedle( const QColor &color )
+diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.h qwt-6.1.4/src/qwt_plot_glcanvas.h
+--- qwt-6.1.4.orig/src/qwt_plot_glcanvas.h 2020-04-14 13:44:26.642354964 +0200
++++ qwt-6.1.4/src/qwt_plot_glcanvas.h 2020-04-14 13:42:38.555103164 +0200
+@@ -12,6 +12,7 @@
+
+ #include "qwt_global.h"
+ #include <qframe.h>
++#include <qpainterpath.h>
+ #include <qgl.h>
+
+ class QwtPlot;
diff --git a/recipes-qt/qwt/qwt-qt5_6.1.4.bb b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
index 623b45e5..18eebbf1 100644
--- a/recipes-qt/qwt/qwt-qt5_6.1.4.bb
+++ b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
@@ -16,6 +16,7 @@ inherit qmake5
SRC_URI = " \
${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \
file://0001-Remove-rpath-from-binaries-they-point-to-buuild-area.patch \
+ file://0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch \
"
SRC_URI[qwt.md5sum] = "4fb1852f694420e3ab9c583526edecc5"
SRC_URI[qwt.sha256sum] = "1529215329e51fc562e0009505a838f427919a18b362afff441f035b2d9b5bd9"