aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb3
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc4
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch8
-rw-r--r--recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch16
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch31
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-Include-dependency-to-QCoreApplication-translate.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb6
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
45 files changed, 89 insertions, 103 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1da5753d..5c7afea8 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -61,6 +61,7 @@ PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
FILES_${PN}-dev += " \
${OE_QMAKE_PATH_ARCHDATA}/mkspecs \
${OE_QMAKE_PATH_LIBS}/*.prl \
+ ${datadir}/cmake \
"
FILES_${PN} += " \
@@ -195,4 +196,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "49efea26a5fae8c2275999c36c7c8d24cf4125de"
+SRCREV = "c69f43594fc921fea82377e7b31a7f55f718051d"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 6cf4ab79..86d2d31d 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "03253babc2077795eca2decfd8b9d6310f49ce93"
+SRCREV = "d4835713b808503ab6d3039f3893355804a8a21d"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 87c7aea1..ca5e6b9a 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -3,7 +3,7 @@
QT_MODULE ?= "${BPN}"
QT_MODULE_BRANCH ?= "5.11"
-QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
+QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
SRC_URI = " \
@@ -14,4 +14,4 @@ CVE_PRODUCT = "qt"
S = "${WORKDIR}/git"
-PV = "5.11.2+git${SRCPV}"
+PV = "5.11.3+git${SRCPV}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 660c27ae..9b37864a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -139,4 +139,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "49efea26a5fae8c2275999c36c7c8d24cf4125de"
+SRCREV = "c69f43594fc921fea82377e7b31a7f55f718051d"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index acb0a7d4..c22eb2e1 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -31,7 +31,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index 2830a1b189..6445dc2d5a 100755
+index 2830a1b1897..6445dc2d5a0 100755
--- a/configure
+++ b/configure
@@ -712,7 +712,7 @@ fi
@@ -44,7 +44,7 @@ index 2830a1b189..6445dc2d5a 100755
# build qmake
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index 934a18a924..0f5b1b6333 100644
+index 934a18a9249..0f5b1b63334 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
@@ -89,7 +89,7 @@ index b57afcf72d..afa1c39b3e 100644
# run qmlimportscanner
qtPrepareTool(QMLIMPORTSCANNER, qmlimportscanner, , system)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 1903e509c8..c093dd4592 100644
+index 1903e509c8e..c093dd4592d 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
@@ -149,7 +149,7 @@ index 0000000000..f34a66599a
+load(qt_config)
diff --git a/mkspecs/linux-oe-g++/qplatformdefs.h b/mkspecs/linux-oe-g++/qplatformdefs.h
new file mode 100644
-index 0000000000..5d22fb4101
+index 00000000000..5d22fb41013
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qplatformdefs.h
@@ -0,0 +1 @@
diff --git a/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch b/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
index 0f1e1b30..b1684e3c 100644
--- a/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
+++ b/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
@@ -1,4 +1,4 @@
-From f63242fbcac990839eff2ce9f970377d6350fd8a Mon Sep 17 00:00:00 2001
+From cd9a12017597d9233b529be24434225da6db614e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Tue, 21 Aug 2018 00:29:06 +0200
Subject: [PATCH] Check glibc version for renameat2/statx on non bootstrapped
@@ -15,13 +15,14 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
1 file changed, 11 insertions(+)
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
-index deb4a9f220..ecf23168e7 100644
+index 964dceb..c09eb01 100644
--- a/src/corelib/io/qfilesystemengine_unix.cpp
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
-@@ -97,6 +97,17 @@ extern "C" NSString *NSTemporaryDirectory();
+@@ -95,6 +95,17 @@ extern "C" NSString *NSTemporaryDirectory();
+ #ifndef FICLONE
# define FICLONE _IOW(0x94, 9, int)
#endif
-
++
+// renameat2/statx features for non bootstrapped build
+#ifndef QT_BOOTSTRAPPED
+#ifdef __GLIBC_PREREQ
@@ -32,7 +33,6 @@ index deb4a9f220..ecf23168e7 100644
+# define QT_FEATURE_statx -1
+#endif
+#endif
-+
- # if defined(Q_OS_ANDROID)
- // renameat2() and statx() are disabled on Android because quite a few systems
- // come with sandboxes that kill applications that make system calls outside a
+ #endif
+
+ #if defined(Q_OS_ANDROID)
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index f4c10a62..76f776f5 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -110,7 +110,7 @@ PACKAGECONFIG[glib] = "-glib,-no-glib,glib-2.0"
# fontdatabases/basic/qbasicfontdatabase.cpp will fail to build and system freetype
# works only together with fontconfig
PACKAGECONFIG[freetype] = "-system-freetype,-qt-freetype,freetype"
-PACKAGECONFIG[harfbuzz] = "-system-harfbuzz,-no-harfbuzz,harfbuzz"
+PACKAGECONFIG[harfbuzz] = "-system-harfbuzz,-qt-harfbuzz,harfbuzz"
PACKAGECONFIG[jpeg] = "-system-libjpeg,-no-libjpeg,jpeg"
PACKAGECONFIG[libpng] = "-system-libpng,-no-libpng,libpng"
PACKAGECONFIG[gif] = "-gif,-no-gif"
@@ -259,4 +259,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "49efea26a5fae8c2275999c36c7c8d24cf4125de"
+SRCREV = "c69f43594fc921fea82377e7b31a7f55f718051d"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 32cf713c..229fcbbf 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "96a47ce9de9e61ca92561160bc6d586c156094d2"
+SRCREV = "6f0a1143a55a4e19d14bf999c4e3a2ad5c7fa313"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index ed7d2d97..ab0fe39d 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "28f8372233b5a4bbc740959d4a7d0d4823727798"
+SRCREV = "1bf73796a92ccd1599e5c762b73a76e545e48262"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 4cdb1729..da0b9259 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "5f30c77484a9af223d32067f579d440010520eb2"
+SRCREV = "d1cf8dad0e6d8d08b5c6f2f08d85a0e75b0bcf8a"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index c36ef27c..02b9ff6b 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "f305948c23f631ddce3e49c4bd90149997c0903c"
+SRCREV = "7b091d13ed5509a73da921a7ed30034a7eb55131"
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch b/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch
new file mode 100644
index 00000000..a734f8a2
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch
@@ -0,0 +1,31 @@
+From 260e165993fe15a1668cfd36caee18a95b2d2f59 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Mon, 2 Jul 2018 13:32:44 +0300
+Subject: [PATCH] Always use commit sha1 for QML_COMPILE_HASH
+
+git describe can produce different strings for the same sha1, depending
+on the version of git (length of short hash) and whether release tag was
+in place when build was done (v5.11.1-0- vs. v5.11.0-66-).
+
+Instead use rev-parse to get the unambiguous commit sha1 which is also
+what is used from the .tag file.
+
+Change-Id: If378f03eb764e2d858bda5b662106aa4402d6559
+Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
+---
+ src/qml/qml.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qml/qml.pro b/src/qml/qml.pro
+index 940ebb325..a76a87b15 100644
+--- a/src/qml/qml.pro
++++ b/src/qml/qml.pro
+@@ -31,7 +31,7 @@ DEFINES += QT_NO_FOREACH
+ !equals(tag, "$${LITERAL_DOLLAR}Format:%H$${LITERAL_DOLLAR}") {
+ QML_COMPILE_HASH = $$tag
+ } else:exists($$PWD/../../.git) {
+- commit = $$system(git describe --tags --always --long --dirty)
++ commit = $$system(git rev-parse HEAD)
+ QML_COMPILE_HASH = $$commit
+ }
+ compile_hash_contents = \
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 520c7ad8..9ecadb92 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+SRC_URI += "file://0001-Always-use-commit-sha1-for-QML_COMPILE_HASH.patch"
+
DEPENDS += "qtbase"
PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}"
@@ -33,6 +35,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "c2494382432d66cc08c14877378354f1b6cd6bfd"
+SRCREV = "7eaa93680ce583354f23f3b29bd6db59169dfece"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index 7abef3be..21b26858 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "e3b436f6718e666f4c5baa3b768993382809e1ed"
+SRCREV = "e542b1b6c46e49baec66d427a2664cc2c6aefa01"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index f2d29fb6..e6c1c953 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "965da52a583a27fc41a489a4141f78c3acb0d143"
+SRCREV = "7e2544e28cac2fbf7176b6692dacc57096774249"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index cc0ade5c..fda15241 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "855106d17258638cf50099b47d2db801c747ebb6"
+SRCREV = "2f61f401187d55bb0304591f27792a63a38db00e"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 77ed848c..ed821c01 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "b415d1fc2231261a641ada2ffe8332a259ad6b88"
+SRCREV = "c378516c007f15f439dfb167bbe78a6b275667dc"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index eae9c433..ca9a75b5 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "67a93bb3684b5146505cf570da6c714d0bfe4b1d"
+SRCREV_qtlocation = "25c6840ff6585ca9f7ab1c168cdcdd18a68c7885"
SRCREV_qtlocation-mapboxgl = "b59b0450c60b3df9e0852f62f6c8a6024889cd9e"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index 99332811..e691e48d 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "d733d6f950bc05ab195e9936bc69236eecfb6382"
+SRCREV = "fd396f82b34f11afafc63f33a15e87b89fd1bd88"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index e057030e..d86903e7 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "2c5efb49495e31afa399a1c1ea003a9b630ba113"
+SRCREV = "d9bf568551c9e101374ba842e831650d34d0d41e"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index f1ce02ca..c2968305 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "f76f07ee7328b8d402bf0b12aa99023b8955d4ed"
+SRCREV = "ffb63277ac2ac90b4a99a710660d5e66920a8c5a"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 921687cb..20bf4e96 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "13925e560cfcf80dd6c10c8936af8bcc67cf97e3"
+SRCREV = "e8561dd48762cbaf92bdb1b191ca8647415e19b1"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index fd621ebe..0fc53360 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "e5ae8515422fd0cc7cf9aa91c8b0c38fa53fd9a9"
+SRCREV = "d7257f75e1e9f89a2934c50784d76d90f919605f"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 6668f3b0..1f72fda4 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "e7213c0460788f49ec6c2204bfd5c0517699aa51"
+SRCREV = "d56c193eb4ceb640611d66f22e1f26aae91cd7d1"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 72cd865f..591f3979 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "e02910386a4c0c3fd4f813a58b211d21622f750f"
+SRCREV = "cf957e407030fc260bd86882cf2f79724126abdd"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index f8e38795..8675b9d4 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "d292f1d93ffef611a0a6e9f393251785e1e9b779"
+SRCREV = "9fcf2a90db6d6dce1fe03a2f7af4c4a148c35087"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 5b12dad0..496a7792 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -37,4 +37,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "eb28710655e4cf1059ec450527061d777fcb867e"
+SRCREV = "ebe11c8e867bb65ad7cb1424fe4c096935741089"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 8c10dd33..9cb028f3 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "4f6797ac018f931f3655a53ca5d4ca0114f321e0"
+SRCREV = "a5effbcb0372020f5ce3134a4f38eb865fd6cdd6"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.11
# 5.11.meta-qt5.5
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 1b6113d1..b489c35e 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "58854bdb19cfff1c66788a3035f2aa12b34cce00"
+SRCREV = "a4c3631b0bb895b854305ecf2a4632dc949ef2d3"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index f3ce57b1..343f2684 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "71966594c3ed75f5a863fc99956aca90d3b08655"
+SRCREV = "200822ca61732693cc97802b953cd846654eb319"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 7d9d6685..eed68e87 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "3f0285847230151026890e668b2ff13944b902ee"
+SRCREV = "74222a0e38687068970c8492d794cf92b898c6b6"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 24773839..30a6b79f 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "32c93cbca8b2f337e0801537d52e416289b3f464"
+SRCREV = "a844c1c36551665f19be8a69c0e5e608d24f3a8e"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 291987f2..822ceae7 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "ff440191de244307c968b251faee4122267d3094"
+SRCREV = "ab73d888c4f41a0d0993abca18680cdcbd79b444"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 08008a09..6689ab14 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -103,4 +103,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "60de15a0e0121096239cf6031250d2862e77971d"
+SRCREV = "ed5110171ca294207f341f46610c716170c06282"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 4e6738ba..a17ee4e1 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "631b2089bc1cc73aa78a4ede1a731c8bdfbe8503"
+SRCREV = "eb9e095722e1d953d3bf17bad73f528ac9061488"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index f40681a1..dd616c06 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "297bcd005c4205f69e1bf9e9dc565ab757cf0bac"
+SRCREV = "dccec9b282ae15fa65fd61698dd1cb47325e5c8e"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index e64993ae..cb19a421 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "daecad4cc7552cff68aa6c87cd78cb3b7a0d73f6"
+SRCREV = "faab35b4f88c634510e56adcfa6f12f0fef548bb"
diff --git a/recipes-qt/qt5/qtwebengine/0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch b/recipes-qt/qt5/qtwebengine/0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch
deleted file mode 100644
index d0e9679f..00000000
--- a/recipes-qt/qt5/qtwebengine/0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 50a92a60b04d0e6253a903a53f5b01da2d00072d Mon Sep 17 00:00:00 2001
-From: Cleiton Bueno <cleitonrbueno@gmail.com>
-Date: Fri, 25 Dec 2015 18:16:05 -0200
-Subject: [PATCH] WebEngine qquickwebengineview_p_p.h add include QColor
-
-Signed-off-by: Cleiton Bueno <cleitonrbueno@gmail.com>
----
- src/webengine/api/qquickwebengineview_p_p.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/webengine/api/qquickwebengineview_p_p.h b/src/webengine/api/qquickwebengineview_p_p.h
-index 1723da7e..4d9e5981 100644
---- a/src/webengine/api/qquickwebengineview_p_p.h
-+++ b/src/webengine/api/qquickwebengineview_p_p.h
-@@ -61,6 +61,8 @@
- #include <QString>
- #include <QtCore/qcompilerdetection.h>
- #include <QtGui/qaccessibleobject.h>
-+#include <QColor>
-+
-
- namespace QtWebEngineCore {
- class WebContentsAdapter;
diff --git a/recipes-qt/qt5/qtwebengine/0002-Include-dependency-to-QCoreApplication-translate.patch b/recipes-qt/qt5/qtwebengine/0002-Include-dependency-to-QCoreApplication-translate.patch
deleted file mode 100644
index 0467d97a..00000000
--- a/recipes-qt/qt5/qtwebengine/0002-Include-dependency-to-QCoreApplication-translate.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From d61b28affb7d895e12dfa0e0390c488ec3b2a1f8 Mon Sep 17 00:00:00 2001
-From: Cleiton Bueno <cleitonrbueno@gmail.com>
-Date: Thu, 24 Dec 2015 15:59:51 -0200
-Subject: [PATCH] Include dependency to QCoreApplication::translate()
-
-Signed-off-by: Cleiton Bueno <cleitonrbueno@gmail.com>
----
- src/core/media_capture_devices_dispatcher.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/core/media_capture_devices_dispatcher.h b/src/core/media_capture_devices_dispatcher.h
-index 579d159a..0904c468 100644
---- a/src/core/media_capture_devices_dispatcher.h
-+++ b/src/core/media_capture_devices_dispatcher.h
-@@ -45,6 +45,8 @@
- #include <list>
- #include <map>
-
-+#include <QCoreApplication>
-+
- #include "web_contents_adapter_client.h"
-
- #include "base/callback.h"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a4469183..0822e858 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -139,8 +139,6 @@ QT_MODULE_BRANCH_CHROMIUM = "65-based"
# 5.11.meta-qt5.7
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
- file://0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
- file://0002-Include-dependency-to-QCoreApplication-translate.patch \
file://0003-Force-host-toolchain-configuration.patch \
file://0004-chromium_overrides.cpp-Fix-build-with-plugins-and-oz.patch \
"
@@ -174,8 +172,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "89afebb830f616a6e8c43dd37bf34551f243b264"
-SRCREV_chromium = "7085115f51ce9d02cfff216a3f74b1fb6715f38d"
+SRCREV_qtwebengine = "97687f9bdf9eba7ce06f0813f6df3e9ed65e95d5"
+SRCREV_chromium = "33fd7a21ed794e4d89062b9153ff714e642773ff"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index ca07e79f..749b95a2 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "9a19f14013519f3c00a53b4204c7a7d1b2d0acc5"
+SRCREV = "4519f09577e76c6c0f6cc7ca4c0a5a78174bc4a9"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 7e1155c1..61855612 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "e71467cb569c8d1453e023701b17c9ce9e3fdb86"
+SRCREV = "bac5a37663249edb9a9746687a7128c013af0309"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index c172e00e..d4ff9f6d 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "b9fef247821416de6532a5ed375a01039c6336dd"
+SRCREV = "8970865f64bc4f02ad110c0ad1d9bbd8e949a4d9"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index 06bace51..2102b898 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "295c13f5779795c5ec49c7a1ada70287707a8fd6"
+SRCREV = "25abe51f8455fbdaab9d6c4bcb6c8ce7b45f5e13"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 39217597..b27d2ec5 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "15e22118d01ae39722d1836715fe9cf8b6d3ee88"
+SRCREV = "af06f4fbf76ef6168529f5de4480d4afd2cf204b"
BBCLASSEXTEND =+ "native nativesdk"