aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rw-r--r--coin/module_config.yaml180
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch75
-rw-r--r--recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch26
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb8
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch24
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb5
-rw-r--r--recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb20
-rw-r--r--recipes-qt/qt5/qttools/run-ptest1
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
14 files changed, 235 insertions, 137 deletions
diff --git a/.gitattributes b/.gitattributes
index cb2381c0..f6a86105 100644
--- a/.gitattributes
+++ b/.gitattributes
@@ -1,2 +1,3 @@
+/coin export-ignore
# linguist overrides
recipes-*/**/*.inc linguist-language=BitBake
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
new file mode 100644
index 00000000..1da8e1ba
--- /dev/null
+++ b/coin/module_config.yaml
@@ -0,0 +1,180 @@
+version: 1
+accept_configuration:
+ condition: and
+ conditions:
+ - condition: property
+ property: host.osVersion
+ equals_value: Ubuntu_18_04
+ - condition: property
+ property: target.osVersion
+ equals_value: QEMU
+ - condition: property
+ property: target.arch
+ in_values: [ARMv7, ARM64]
+
+environment: &environment
+ type: Group
+ instructions:
+ - type: EnvironmentVariable
+ variableName: POKY_SHA1
+ variableValue: 835f7eac0610325e906591cd81890bebe8627580
+ - type: EnvironmentVariable
+ variableName: OE_SHA1
+ variableValue: 4e0538516b1e0ef42dc79bd08f7895f0052063ac
+ - type: EnvironmentVariable
+ variableName: MACHINE
+ variableValue: qemuarm64
+ enable_if:
+ condition: property
+ property: target.arch
+ equals_value: ARM64
+ - type: EnvironmentVariable
+ variableName: MACHINE
+ variableValue: qemux86
+ enable_if:
+ condition: property
+ property: target.arch
+ equals_value: ARMv7
+
+build_instructions:
+ - *environment
+ - type: SetBuildDirectory
+ directory: "{{.AgentWorkingDir}}/build"
+ - type: MakeDirectory
+ directory: "{{.BuildDir}}"
+ - type: ChangeDirectory
+ directory: "{{.BuildDir}}"
+ - type: ExecuteCommand
+ command: ["sudo", "mkdir", "-p", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Could not create '/mnt/yocto-cache' directory"
+ - type: ExecuteCommand
+ command: ["sudo", "mount", "yocto-cache.intra.qt.io:/srv/yocto-cache", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Could not mount yocto cache."
+ - type: WriteFile
+ fileContents: |
+ # https://github.com/shr-project/jenkins-jobs/blob/master/jenkins-job.sh
+ INHERIT += "reproducible_build_simple"
+ # We want musl and glibc to share the same tmpfs, so instead of appending default "-${TCLIBC}" we append "fs"
+ TCLIBCAPPEND = "fs"
+ PREFERRED_PROVIDER_udev = "systemd"
+ PREFERRED_PROVIDER_virtual/fftw = "fftw"
+ # use gold
+ DISTRO_FEATURES_append = " ld-is-gold"
+ # use ptest
+ DISTRO_FEATURES_append = " ptest"
+ # use systemd
+ DISTRO_FEATURES_append = " systemd"
+ DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
+ VIRTUAL-RUNTIME_init_manager = "systemd"
+ VIRTUAL-RUNTIME_initscripts = ""
+ # use opengl
+ DISTRO_FEATURES_append = " opengl"
+ # use wayland to fix building weston and qtwayland
+ DISTRO_FEATURES_append = " wayland"
+ PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
+ PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"
+ PREFERRED_PROVIDER_gpsd = "gpsd"
+ PREFERRED_PROVIDER_e-wm-sysactions = "e-wm"
+ ESYSACTIONS = "e-wm-sysactions"
+ # don't pull libhybris unless explicitly asked for
+ PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+ PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+ PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+ PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+ # to fix fsoaudiod, alsa-state conflict in shr-image-all
+ VIRTUAL-RUNTIME_alsa-state = ""
+ # to prevent alsa-state being pulled into -dev or -dbg images
+ RDEPENDS_${PN}-dev_pn-alsa-state = ""
+ RDEPENDS_${PN}-dbg_pn-alsa-state = ""
+ # to fix dependency on conflicting x11-common from packagegroup-core-x11
+ VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
+ RDEPENDS_${PN}-dev_pn-x11-common = ""
+ RDEPENDS_${PN}-dbg_pn-x11-common = ""
+ # to fix apm, fso-apm conflict in shr-image-all
+ VIRTUAL-RUNTIME_apm = "fso-apm"
+ # require conf/distro/include/qt5-versions.inc
+ # QT5_VERSION = "5.4.0+git%"
+ # for qtwebkit etc
+ # see https://bugzilla.yoctoproject.org/show_bug.cgi?id=5013
+ # DEPENDS_append_pn-qtbase = " mesa"
+ PACKAGECONFIG_append_pn-qtbase = " icu gl accessibility freetype fontconfig"
+ # qtwayland doesn't like egl and xcomposite-glx enabled at the same time
+ # http://lists.openembedded.org/pipermail/openembedded-devel/2016-December/110444.html
+ PACKAGECONFIG_remove_pn-qtwayland = "xcomposite-egl xcomposite-glx"
+ # for webkit-efl
+ PACKAGECONFIG_append_pn-harfbuzz = " icu"
+ inherit blacklist
+ # PNBLACKLIST[samsung-rfs-mgr] = "needs newer libsamsung-ipc with negative D_P: Requested 'samsung-ipc-1.0 >= 0.2' but version of libsamsung-ipc is 0.1.0"
+ PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds"
+ PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/"
+ # enable reporting
+ # needs http://patchwork.openembedded.org/patch/68735/
+ #ERR_REPORT_SERVER = "errors.yoctoproject.org"
+ #ERR_REPORT_PORT = "80"
+ #ERR_REPORT_USERNAME = "Martin Jansa"
+ #ERR_REPORT_EMAIL = "Martin.Jansa@gmail.com"
+ #ERR_REPORT_UPLOAD_FAILURES = "1"
+ #INHERIT += "report-error"
+ # needs patch with buildstats-summary.bbclass
+ INHERIT += "buildstats buildstats-summary"
+ # be more strict with QA warnings, turn them all to errors:
+ ERROR_QA_append = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+ WARN_QA_remove = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+ # enable thumb for broader test coverage (oe-core autobuilder doesn't have thumb enabled)
+ PREFERRED_ARM_INSTRUCTION_SET ?= "thumb"
+ ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
+ # use musl for qemux86 and qemux86copy
+ TCLIBC_qemux86 = "musl"
+ TCLIBC_qemux86copy = "musl"
+ # limit parallel make to avoid OOM
+ PARALLEL_MAKE_pn-qtwebkit = "-j 8"
+ filename: "{{.BuildDir}}/world_fixes.inc"
+ fileMode: 420
+ - type: WriteFile
+ fileContents: |
+ #!/bin/bash -xe
+ git clone git://git.yoctoproject.org/poky --reference /mnt/yocto-cache/mirror/poky.git
+ (cd poky; git checkout ${POKY_SHA1})
+ git clone git://github.com/openembedded/meta-openembedded --reference /mnt/yocto-cache/mirror/meta-openembedded.git
+ (cd meta-openembedded; git checkout ${OE_SHA1})
+
+ source ./poky/oe-init-build-env
+ export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE SSTATE_DIR DL_DIR"
+ export DL_DIR=/mnt/yocto-cache/downloads
+ export BB_GENERATE_MIRROR_TARBALLS=1
+ export SSTATE_DIR=/mnt/yocto-cache/sstate-caches/$(sed -n -e "s/DISTRO_CODENAME.*\"\(.*\)\"/\1/p" ../poky/meta-*/conf/distro/poky.conf)
+ bitbake-layers add-layer ../meta-openembedded/meta-oe
+ bitbake-layers add-layer ${SOURCE_DIR}
+
+ echo 'require ../world_fixes.inc' >> conf/local.conf
+
+ # EXCLUDE_FROM_WORLD
+ rm -f ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
+
+ bitbake $(find ${SOURCE_DIR} -name *.bb | xargs -n1 basename | sed -e 's/\([^._]*\).*/\1/')
+ filename: "{{.BuildDir}}/start-build"
+ fileMode: 420
+ - type: ExecuteCommand
+ command: ["chmod", "+x", "{{.BuildDir}}/start-build"]
+ userMessageOnFailure: "Could not add execution right to the start-build."
+ - type: EnvironmentVariable
+ variableName: DL_DIR
+ variableValue: "/mnt/yocto-cache/downloads"
+ - type: EnvironmentVariable
+ variableName: SOURCE_DIR
+ variableValue: "{{.SourceDir}}"
+ - type: ExecuteCommand
+ command: ["{{.BuildDir}}/start-build"]
+ maxTimeInSeconds: 28800
+ maxTimeBetweenOutput: 28800
+ userMessageOnFailure: "Build failed."
+ - type: ExecuteCommand
+ command: ["sudo", "umount", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Unmounting cache failed."
+
+test_instructions: []
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 8a4b471b..2a26e776 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -76,8 +76,9 @@ FILES_${PN} += " \
DEBIAN_NOAUTONAME_${PN} = "1"
PACKAGECONFIG ?= ""
-PACKAGECONFIG[gui] = "-gui -qpa minimal,-no-gui,"
+PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
QT_CONFIG_FLAGS += " \
-shared \
@@ -112,7 +113,6 @@ do_configure() {
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
- -no-openssl \
-no-xcb \
-no-feature-bearermanagement \
-no-icu \
diff --git a/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch b/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch
deleted file mode 100644
index fcf6915d..00000000
--- a/recipes-qt/qt5/ogl-runtime/0002-Fix-format-security-issues.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From c80b588cc3e11a80ffedd778fab3f19c686552f7 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Mon, 5 Aug 2019 14:24:44 +0300
-Subject: [PATCH] Fix format-security issues
-
-format not a string literal and no format arguments [-Wformat-security]
-
-Change-Id: I04c1d1598948b664b9d85036030c6f89fcf3c8b7
----
- src/render/backends/gl/Q3DSRenderBackendGLES2.cpp | 4 ++--
- src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp | 8 ++++----
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp b/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
-index ac5b992..02046ac 100644
---- a/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
-+++ b/src/render/backends/gl/Q3DSRenderBackendGLES2.cpp
-@@ -663,7 +663,7 @@ NVRenderBackendGLES2Impl::CreateRenderbuffer(NVRenderRenderBufferFormats::Enum s
- // check for error
- GLenum error = m_glFunctions->glGetError();
- if (error != GL_NO_ERROR) {
-- qCCritical(GL_ERROR, GLConversion::processGLError(error));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
- QT3DS_ASSERT(false);
- GL_CALL_EXTRA_FUNCTION(glDeleteRenderbuffers(1, &bufID));
- bufID = 0;
-@@ -699,7 +699,7 @@ bool NVRenderBackendGLES2Impl::ResizeRenderbuffer(NVRenderBackendRenderbufferObj
- // check for error
- GLenum error = m_glFunctions->glGetError();
- if (error != GL_NO_ERROR) {
-- qCCritical(GL_ERROR, GLConversion::processGLError(error));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
- QT3DS_ASSERT(false);
- success = false;
- }
-diff --git a/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp b/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
-index 0fe6e0f..5dfe9d1 100644
---- a/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
-+++ b/src/render/backends/gl/Qt3DSRenderBackendGLBase.cpp
-@@ -604,7 +604,7 @@ NVRenderBackendGLBase::CreateBuffer(size_t size, NVRenderBufferBindFlags bindFla
- } else {
- GL_CALL_FUNCTION(glDeleteBuffers(1, &bufID));
- bufID = 0;
-- qCCritical(GL_ERROR, GLConversion::processGLError(target));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(target);
- }
- }
-
-@@ -832,7 +832,7 @@ NVRenderBackendGLBase::CreateRenderbuffer(NVRenderRenderBufferFormats::Enum stor
- // check for error
- GLenum error = m_glFunctions->glGetError();
- if (error != GL_NO_ERROR) {
-- qCCritical(GL_ERROR, GLConversion::processGLError(error));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
- QT3DS_ASSERT(false);
- GL_CALL_FUNCTION(glDeleteRenderbuffers(1, &bufID));
- bufID = 0;
-@@ -869,7 +869,7 @@ bool NVRenderBackendGLBase::ResizeRenderbuffer(NVRenderBackendRenderbufferObject
- // check for error
- GLenum error = m_glFunctions->glGetError();
- if (error != GL_NO_ERROR) {
-- qCCritical(GL_ERROR, GLConversion::processGLError(error));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(error);
- QT3DS_ASSERT(false);
- success = false;
- }
-@@ -1306,7 +1306,7 @@ bool NVRenderBackendGLBase::compileSource(GLuint shaderID, NVConstDataRef<QT3DSI
- GLenum binaryError = m_glFunctions->glGetError();
- if (binaryError != GL_NO_ERROR) {
- shaderStatus = GL_FALSE;
-- qCCritical(GL_ERROR, GLConversion::processGLError(binaryError));
-+ qCCritical(GL_ERROR) << GLConversion::processGLError(binaryError);
- }
- }
-
diff --git a/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch b/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch
deleted file mode 100644
index 5fe840a0..00000000
--- a/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From f654a25f9df6583532798f30181d149d51b23808 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Thu, 8 Aug 2019 08:34:47 +0300
-Subject: [PATCH] Fix build on musl libc
-
-Use bits/local_lim.h only with glibc as it's not available
-on musl libc.
-
-Change-Id: Ibffa4ab5649b544664f99b16e94d6865148eeeb5
----
- src/foundation/linux/Qt3DSLinuxThread.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/foundation/linux/Qt3DSLinuxThread.cpp b/src/foundation/linux/Qt3DSLinuxThread.cpp
-index fa6e069..99c4c3a 100644
---- a/src/foundation/linux/Qt3DSLinuxThread.cpp
-+++ b/src/foundation/linux/Qt3DSLinuxThread.cpp
-@@ -35,7 +35,7 @@
- #include "foundation/Qt3DSAssert.h"
- #include "foundation/Qt3DSIntrinsics.h"
- #include "foundation/Qt3DSBroadcastingAllocator.h"
--#if !defined(QT3DS_APPLE) && !defined(ANDROID) && !defined(__CYGWIN__) && !defined(__QNX__) && !defined(__INTEGRITY)
-+#if !defined(QT3DS_APPLE) && !defined(ANDROID) && !defined(__CYGWIN__) && !defined(__QNX__) && !defined(__INTEGRITY) && defined(__GLIBC__)
- #include <bits/local_lim.h> // PTHREAD_STACK_MIN
- #endif
- #include <stdio.h>
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
index 97e25bc1..912f5dc1 100644
--- a/recipes-qt/qt5/ogl-runtime_git.bb
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -9,20 +9,18 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtquickcontrols2"
-QT_MODULE_BRANCH = "2.4"
+QT_MODULE_BRANCH = "2.5"
QT_MODULE_BRANCH_EASTL = "master"
QT_GIT_PROJECT = "qt3dstudio"
-PV = "2.4+git${SRCPV}"
+PV = "2.5.0+git${SRCPV}"
SRC_URI += " \
${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
file://0001-Fix-examples-build-error.patch \
- file://0002-Fix-format-security-issues.patch \
- file://0003-Fix-build-on-musl-libc.patch \
file://0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch \
"
-SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f"
+SRCREV_ogl-runtime = "25236c672d81a73ee8754dbd764eb8a2a26d866e"
SRCREV_EASTL = "31697c758f2ed19bd7c6bbe61f1b91f9e12035b5"
SRCREV = "${SRCREV_ogl-runtime}"
diff --git a/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch
index 214a4034..d17f60b4 100644
--- a/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch
+++ b/recipes-qt/qt5/qt5-creator/0001-Link-with-libexecinfo-on-musl.patch
@@ -1,4 +1,4 @@
-From 33299724b8719d53b26c9055a76a61c358270110 Mon Sep 17 00:00:00 2001
+From ec7aec2f6c56889c96dc12af46059a7f3d4c3a37 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 16 Jan 2018 13:26:57 +0000
Subject: [PATCH] Link with libexecinfo on musl
@@ -6,15 +6,29 @@ Subject: [PATCH] Link with libexecinfo on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- src/plugins/debugger/debugger.pro | 1 +
- 1 file changed, 1 insertion(+)
+ src/plugins/debugger/debugger.pro | 1 +
+ src/plugins/qmldesigner/designercore/designercore-lib.pri | 2 ++
+ 2 files changed, 3 insertions(+)
diff --git a/src/plugins/debugger/debugger.pro b/src/plugins/debugger/debugger.pro
-index acbf5136b9..159139eb2b 100644
+index f5a34aa0d5..4a1359dd5c 100644
--- a/src/plugins/debugger/debugger.pro
+++ b/src/plugins/debugger/debugger.pro
-@@ -139,3 +139,4 @@ include(console/console.pri)
+@@ -141,3 +141,4 @@ include(console/console.pri)
include(analyzer/analyzer.pri)
include(shared/shared.pri)
+LIBS *= -lexecinfo
+diff --git a/src/plugins/qmldesigner/designercore/designercore-lib.pri b/src/plugins/qmldesigner/designercore/designercore-lib.pri
+index 935b29728e..31527267fd 100644
+--- a/src/plugins/qmldesigner/designercore/designercore-lib.pri
++++ b/src/plugins/qmldesigner/designercore/designercore-lib.pri
+@@ -2,6 +2,8 @@ include($$PWD/filemanager/filemanager.pri)
+
+ QT += network
+
++LIBS *= -lexecinfo
++
+ DEFINES += TEST_EXPORTS
+ DEFINES += DESIGNER_CORE_LIBRARY
+ INCLUDEPATH += $$PWD \
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 09d00f31..a9152255 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -3,7 +3,7 @@
QT_MODULE ?= "${BPN}"
QT_MODULE_BRANCH ?= "5.13"
-QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
+QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
SRC_URI = " \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 4af7f8c0..b88b83e2 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -58,8 +58,9 @@ XPLATFORM_toolchain-clang = "linux-oe-clang"
XPLATFORM ?= "linux-oe-g++"
PACKAGECONFIG ?= ""
-PACKAGECONFIG[gui] = "-gui -qpa minimal,-no-gui,"
+PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl"
QT_CONFIG_FLAGS = " \
-sysroot ${STAGING_DIR_NATIVE} \
@@ -74,7 +75,7 @@ QT_CONFIG_FLAGS = " \
-no-sql-sqlite \
-no-sql-psql \
-no-opengl \
- -no-openssl \
+ -no-vulkan \
-no-xcb \
-no-icu \
-verbose \
diff --git a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
index b56224b9..7c77805d 100644
--- a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
@@ -22,7 +22,7 @@ index a94f6d0eeb..ccab725843 100644
static:no-static-ltcg {
# Static library but no-static-ltcg enabled: skip LTCG
-} else: CONFIG(release, debug|release) {
-+} else: CONFIG(release, debug|release)!host_build {
++} else: CONFIG(release, debug|release):!host_build {
# We need fat object files when creating static libraries on some platforms
# so the linker will know to load a particular object from the library
# in the first place. On others, we have special ar and nm to create the symbol
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 05bc716d..eaca3666 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -50,7 +50,7 @@ PACKAGECONFIG_DISTRO ?= ""
PACKAGECONFIG_RELEASE ?= "release"
# This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency
# PACKAGECONFIG_OPENSSL ?= "openssl"
-PACKAGECONFIG_DEFAULT ?= "accessibility dbus udev evdev widgets tools libs freetype tests \
+PACKAGECONFIG_DEFAULT ?= "accessibility dbus udev evdev widgets tools libs freetype tests pcre \
${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)} \
"
@@ -277,22 +277,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-TARGET_MKSPEC ?= "linux-g++"
-
-# use clean mkspecs on target
-pkg_postinst_${PN}-tools () {
-sed -i \
- -e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
- -e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
- $D${OE_QMAKE_PATH_BINS}/qt.conf
-}
-
-pkg_postinst_${PN}-mkspecs () {
-sed -i 's: cross_compile : :g' $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qconfig.pri
-sed -i \
- -e 's: cross_compile : :g' \
- -e 's:HOST_QT_TOOLS =.*::g' \
- $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
-}
-
SRCREV = "a7a24784eeba6747d319eb911583bdd99ef38cdb"
diff --git a/recipes-qt/qt5/qttools/run-ptest b/recipes-qt/qt5/qttools/run-ptest
index 5cd5e27e..ae671a72 100644
--- a/recipes-qt/qt5/qttools/run-ptest
+++ b/recipes-qt/qt5/qttools/run-ptest
@@ -1,4 +1,3 @@
#!/bin/sh
./tst_qtdiag
-./tst_qtattributionsscanner
diff --git a/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
new file mode 100644
index 00000000..3047230c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
@@ -0,0 +1,23 @@
+From a1c248259f3d8561d6e2c75a56edf4a72c393843 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 15 Aug 2019 07:52:53 +0300
+Subject: [PATCH] musl: allow build without glibc
+
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ mkspecs/features/configure.prf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
+index cc84182b..f1310f75 100644
+--- a/mkspecs/features/configure.prf
++++ b/mkspecs/features/configure.prf
+@@ -75,7 +75,7 @@ defineTest(runConfigure) {
+ return(false)
+ }
+
+- !qtConfig(webengine-system-glibc) {
++ false:!qtConfig(webengine-system-glibc) {
+ skipBuild("A suitable version >= 2.27 of libc could not be found.")
+ return(false)
+ }
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index dc41c517..66b159a9 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -146,6 +146,7 @@ SRC_URI += " \
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0003-musl-link-against-libexecinfo.patch \
+ file://0004-musl-allow-build-without-glibc.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/73-based