aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 00000000..b1866778
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,15 @@
+inherit qmake5_paths
+
+PACKAGECONFIG[qt5] = '--enable-qt \
+ --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \
+ --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \
+ --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \
+ ,--disable-qt,qtbase qtdeclarative qtbase-native'
+
+# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
+python() {
+ cur_packageconfig = d.getVar('PACKAGECONFIG').split()
+ if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
+ gl_packageconfig = d.getVar('PACKAGECONFIG_GL')
+ d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
+}