aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc4
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0011-Always-build-uic.patch10
-rw-r--r--recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch49
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit-examples_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
38 files changed, 64 insertions, 71 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 5040a1a4..5a6b7070 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "31374105940bb15a68683a0ae691e7fe1f9b049a"
+SRCREV = "4480f47f7b0f81483b0cf3c8327eff12938ca018"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index f0f960af..794ce1c5 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -34,6 +34,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "f39d0a0c32cc489849a0cd5c2880f6e824223485"
+SRCREV = "11a7585b75def904f7450eea50455ca6e8e9396f"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index b7fee9c9..78c754ce 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2016 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.9"
+QT_MODULE_BRANCH ?= "dev"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
@@ -12,4 +12,4 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-PV = "5.9.0+git${SRCPV}"
+PV = "5.10.0+git${SRCPV}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index a786f33a..de8a1e75 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -109,4 +109,4 @@ do_install() {
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
}
-SRCREV = "31374105940bb15a68683a0ae691e7fe1f9b049a"
+SRCREV = "4480f47f7b0f81483b0cf3c8327eff12938ca018"
diff --git a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch
index fb3d316f..8ca2c8c4 100644
--- a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch
@@ -1,7 +1,7 @@
-From 1b94b0f2579edcf870bc953f820af8fb2ec4376f Mon Sep 17 00:00:00 2001
+From b63b2819b88ef252a078e7ef595f7f370ec0c050 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
-Subject: [PATCH] Always build uic
+Subject: [PATCH] Always build uic and qvkgen
Even if we are not building gui or widgets. This tool is needed later
as a native tool when compiling the target.
@@ -14,15 +14,15 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/src.pro b/src/src.pro
-index 3d18540..d128b3a 100644
+index a2064b1..9fae335 100644
--- a/src/src.pro
+++ b/src/src.pro
-@@ -195,7 +195,7 @@ contains(QT_CONFIG, concurrent):SUBDIRS += src_concurrent
+@@ -211,7 +211,7 @@ qtConfig(gui) {
}
}
}
-SUBDIRS += src_plugins
-+SUBDIRS += src_plugins src_tools_uic
++SUBDIRS += src_plugins src_tools_uic src_tools_qvkgen
nacl: SUBDIRS -= src_network src_testlib
diff --git a/recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch b/recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch
index e72601ca..9c5f8fef 100644
--- a/recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch
+++ b/recipes-qt/qt5/qtbase/0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch
@@ -1,4 +1,4 @@
-From 86ae0ce931edbe0ac30cfe5f94f681f1d055fdb0 Mon Sep 17 00:00:00 2001
+From 9bd7ad277698be81db2af1a86d5b4efad5818203 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
Date: Mon, 6 Mar 2017 11:50:38 +0100
Subject: [PATCH] qdbuscpp2xml.pro: do not build with bootstrapped
@@ -9,15 +9,16 @@ Content-Transfer-Encoding: 8bit
Upstream-Status: Pending
+Change-Id: I14e9b9a2bb4aca08d408c8aa76a2c58b54e74e7d
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
---
src/src.pro | 9 ++-------
- src/tools/qdbuscpp2xml/qdbuscpp2xml.pro | 3 +--
- src/tools/qdbusxml2cpp/qdbusxml2cpp.pro | 5 +----
- 3 files changed, 4 insertions(+), 13 deletions(-)
+ src/tools/qdbuscpp2xml/qdbuscpp2xml.pro | 1 +
+ src/tools/qdbusxml2cpp/qdbusxml2cpp.pro | 1 +
+ 3 files changed, 4 insertions(+), 7 deletions(-)
diff --git a/src/src.pro b/src/src.pro
-index 90d7e2b..0aaf604 100644
+index a2064b1..d6f05e0 100644
--- a/src/src.pro
+++ b/src/src.pro
@@ -4,9 +4,6 @@ QT_FOR_CONFIG += gui-private
@@ -30,7 +31,7 @@ index 90d7e2b..0aaf604 100644
src_qtzlib.file = $$PWD/corelib/qtzlib.pro
src_qtzlib.target = sub-zlib
-@@ -37,13 +34,11 @@ src_tools_bootstrap_dbus.depends = src_tools_bootstrap
+@@ -41,13 +38,11 @@ src_tools_bootstrap_dbus.depends = src_tools_bootstrap
src_tools_qdbusxml2cpp.subdir = tools/qdbusxml2cpp
src_tools_qdbusxml2cpp.target = sub-qdbusxml2cpp
@@ -44,36 +45,28 @@ index 90d7e2b..0aaf604 100644
-else: src_tools_qdbuscpp2xml.depends = src_dbus
+src_tools_qdbuscpp2xml.depends = src_dbus
- src_winmain.subdir = $$PWD/winmain
- src_winmain.target = sub-winmain
+ src_tools_qvkgen.subdir = tools/qvkgen
+ src_tools_qvkgen.target = sub-qvkgen
diff --git a/src/tools/qdbuscpp2xml/qdbuscpp2xml.pro b/src/tools/qdbuscpp2xml/qdbuscpp2xml.pro
-index 5ac3159..74c507c 100644
+index 5ac3159..65de97e 100644
--- a/src/tools/qdbuscpp2xml/qdbuscpp2xml.pro
+++ b/src/tools/qdbuscpp2xml/qdbuscpp2xml.pro
-@@ -1,7 +1,6 @@
+@@ -1,5 +1,6 @@
option(host_build)
QT = core-private
--force_bootstrap: QT += bootstrap_dbus-private
--else: QT += dbus-private
-+QT += dbus-private
++CONFIG -= force_bootstrap
+ force_bootstrap: QT += bootstrap_dbus-private
+ else: QT += dbus-private
DEFINES += QT_NO_CAST_FROM_ASCII QT_NO_FOREACH
- QMAKE_CXXFLAGS += $$QT_HOST_CFLAGS_DBUS
-
diff --git a/src/tools/qdbusxml2cpp/qdbusxml2cpp.pro b/src/tools/qdbusxml2cpp/qdbusxml2cpp.pro
-index d9ee5de..e891103 100644
+index 95fcbcb..d1ebdde 100644
--- a/src/tools/qdbusxml2cpp/qdbusxml2cpp.pro
+++ b/src/tools/qdbusxml2cpp/qdbusxml2cpp.pro
-@@ -1,9 +1,6 @@
- option(host_build)
--!force_bootstrap:!qtConfig(commandlineparser): \
-- CONFIG += force_bootstrap
+@@ -5,6 +5,7 @@ option(host_build)
+ CONFIG += force_bootstrap
+ }
QT = core-private
--force_bootstrap: QT += bootstrap_dbus-private
--else: QT += dbus-private
-+QT += dbus-private
++CONFIG -= force_bootstrap
+ force_bootstrap: QT += bootstrap_dbus-private
+ else: QT += dbus-private
DEFINES += QT_NO_CAST_FROM_ASCII QT_NO_FOREACH
- QMAKE_CXXFLAGS += $$QT_HOST_CFLAGS_DBUS
-
---
-2.9.3
-
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 96cdc36d..f130a0ac 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "31374105940bb15a68683a0ae691e7fe1f9b049a"
+SRCREV = "4480f47f7b0f81483b0cf3c8327eff12938ca018"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index b2a07247..9dc7155d 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "116737dc8fa244282dda95a8f13624b66fdb5521"
+SRCREV = "88573c72949b4540ee1456375c64f6262c94a472"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 6b895aaa..236d82e5 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "de7f741c428febfe3c81a28f955996d2314953fc"
+SRCREV = "826aa4dbfb31353d41fa7a6cdba28961c413b214"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 0d13dc40..4a4b975d 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "8dcbf68e4579e03ea6d2808ac0c670169b59d0df"
+SRCREV = "d5063285a8e6c01c4e4fc16fe76ed162b8e21e1d"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 0cbd04e6..ee565d94 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "84490ff75be5acdaeb3fd93900e4ebf7ba8f539b"
+SRCREV = "e7b022ec334ce6768c30402c1e17fe0a1e3a0bb0"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index a578a065..edff48dc 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "96f6ba5f562073f508cd8569ac354592fdd48f4a"
+SRCREV = "7ab6f0dda1cbe4ffd154226996482bc6b092690b"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index 94f04a49..a6bf4470 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "ef8850fee38e2552d535379a8477c9abebdf8bb4"
+SRCREV = "e5f9fbd342574bada201b5a96d8a2a68f2f37cf1"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index d98d77e9..9196173f 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -19,4 +19,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "db93af5b2bb49af74fbad6c9cd80bd7010434e78"
+SRCREV = "d424a1d208f09431d62e1de391dfaa037742456c"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 4dd64df2..3b6a6e1b 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "71ccf0dff82835ce7b5aed74c37829afdef44cde"
+SRCREV = "175dcf6e565bd638601697bfa6becd3a3321a0de"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index af295769..56e7fac0 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -24,7 +24,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "888d351cb0c7fe6d05ab1efe8d4dbb4b6f06cd5f"
-SRCREV_qtlocation-mapboxgl = "d45c177e8a23eefcc94930af9fa085e61136bb94"
+SRCREV_qtlocation = "22d980c8124026eb712f563326d5a5c1b180c671"
+SRCREV_qtlocation-mapboxgl = "edd127ee7658ceb7f5f2f740bce75db1cbf25c0e"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index c1ae7862..8cd7aac0 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -29,4 +29,4 @@ SRC_URI += "\
file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
"
-SRCREV = "559c305ded730e23505e8b29536a98dc59e2acfa"
+SRCREV = "badecdbc46df6ada383f1dfd006fa3dfff1706c6"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index eb5e4f61..28b92667 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "86c5036848ad004208803d9d497cfcd08c9623d6"
+SRCREV = "c071b588ce2b4d474845d553aa83120747dc46da"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index a84cfb32..e54adc8b 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "ef6b8d3081f0bf93d6d59e67c8e3f82c63c511c3"
+SRCREV = "9bae6189fe8ad5d11bbec0b204b42cd71f4a375a"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 83ed908d..c06da0c8 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -26,4 +26,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "dacb91916b202208681471ba764504c7c7d086f0"
+SRCREV = "9f085b889524a80d4064d6ac01dbdc817bb31060"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 550e0305..1ed086fd 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -11,4 +11,4 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "ae0b101884b05355e3a7bc06dbca722ad3d08d0f"
+SRCREV = "0f80a0ad9f80f9f78dc9e9efe8b601dea2487322"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index ae5e0da4..8aa5750c 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "e00ca9b6bec2adf78fd14e02376ecf1b55a93b0c"
+SRCREV = "88bea4e52f6bd4570b0424a93b1d2e5ca96e6c11"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index c2c00e1b..0c58cede 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "eff82ac957e051f16f64c287f2dfaec9049bdfc1"
+SRCREV = "b490e1b782ac28a82d7902f926f6e041ede179ca"
SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 17d06394..1405428d 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "0c3c4d01ea34ed98a0d2928662f07b673f00535d"
+SRCREV = "9a1b163e1fdd99a838c082805c687205b766da25"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 93a826bd..5e3c3cfd 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "20811e3b004af817e3f02982c755e8b1560b8c3d"
+SRCREV = "6ba3a215494a829e73e62f5bd73f5b769874267d"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 957000c4..9ec6d8d2 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "687f5a9bd44a45a29d24925f29470c43d6729dee"
+SRCREV = "65dba188d51d6dc67a15483f26c6b94a21abf5bc"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index fb8d44e1..6fe88e51 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "4fd787e90c70afbaa168abb3efdb8757ba77f3a4"
+SRCREV = "1ef3d38562f686cf06b7a62be13cf9d3a23d0e41"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 9ca90a2c..1b811eaf 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -27,7 +27,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "88e02bb0a9b97d68a4b270e4ddfb6d0847c702a9"
+SRCREV = "36defe5725bbed8e03d4f0ef676bc6afa99e6b04"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 822517f6..02ec4bbb 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -114,4 +114,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "3e727a890f7856978469ee38ef0619b1b59a8ca7"
+SRCREV = "e51b921f6fa0fb64a8a7f4159024d1a2f1872772"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 6d45a508..fa92f2f5 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "bdf61afe76e94ef03da1332c4540646f18f5852f"
+SRCREV = "95c3d5e602c2053a3e0629ecadf1f99ffaa08eea"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 26ef8532..4271a783 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "f1cf62fa8e9ffa2548c9968906848596f50dbc0b"
+SRCREV = "dbf418dce41fe08368d38a098a771348a5b3d0fd"
# From https://bugreports.qt.io/browse/QTBUG-57767
SRC_URI += " \
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index f1167a9e..f353c547 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -17,4 +17,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "6383f0fc5eec4935697a6d2d2f87b511bbeb678e"
+SRCREV = "ed4be1f75314ddc004ea7c0d7c6af715252e4e5c"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 26d2e28d..a2647b5c 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -113,7 +113,7 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "73f7be5b2a95eab3dce11caede538eeb7beb71f2"
+SRCREV_qtwebengine = "d4cb1d15ae8cf57b931b021490b0776cc70f0b32"
SRCREV_chromium = "aa2fdd6be3d465280d2a0c3aacdc738bb4ffec05"
SRCREV = "${SRCREV_qtwebengine}"
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb
index 286aecae..b8b6ee71 100644
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ b/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtwebkit qtxmlpatterns"
RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
-SRCREV = "822426abc77a74752b0ee0da4d0a1c106c4dac22"
+SRCREV = "7efef7478b60f6aeb7babb0663234cf8dcb8a265"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 722af85e..6472ab92 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -85,4 +85,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-SRCREV = "f27089657a207ef8c5c9d27d661d3d12c3af8df2"
+SRCREV = "0a3506ebe5d7f431f0dd4dffa24ac32063b90ff1"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 41ec27f6..f39fb46f 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "1421c3e4ae4213ca18f2f51d5ddb38e223450222"
+SRCREV = "e5133f4f0bb7c01d7bd7fc499d8c148c03a5b500"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index bf03e9bb..fe0f57e0 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "9e83ff8713c1a3f69ce514bf3e31335194668da7"
+SRCREV = "de4c1f09a00884a959bf7f53d38c204d14064c21"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 85563862..e60f3997 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -16,6 +16,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "c1c3af0ae456247c9bcd30161d51a94c9b38dc52"
+SRCREV = "a5984f0a63233e0e9608ce8ab66e6d2d0e6948e3"
BBCLASSEXTEND =+ "native nativesdk"