aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch26
-rw-r--r--recipes-qt/qt5/qt3d_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb5
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch29
-rw-r--r--recipes-qt/qt5/qttools_git.bb3
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit-examples_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit/0002-Remove-TEXTREL-tag-in-x86.patch76
-rw-r--r--recipes-qt/qt5/qtwebkit/0004-Remove-unused-check-for-private_tests.patch41
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
36 files changed, 61 insertions, 182 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 98fa67f4..d45431c8 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -190,4 +190,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "1d9270ee42c257e6df104053177653cffa76336e"
+SRCREV = "df40b1115db600e8de1c4774476fa30956a34fd9"
diff --git a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch b/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
new file mode 100644
index 00000000..0d8d0837
--- /dev/null
+++ b/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
@@ -0,0 +1,26 @@
+From 6a1c600bcb6288c021eafdef516b8313c60505a3 Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Fri, 17 Mar 2017 14:42:12 +0200
+Subject: [PATCH] qt3d: include qcoreapplication.h header in
+ qtquickscene2dplugin.cpp
+
+Fix build break in qt3d:
+Add #include <QtCore/qcoreapplication.h> to qtquickscene2dplugin.cpp
+to prevent build break due unknown Q_COREAPP_STARTUP_FUNCTION macro.
+---
+ src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
+index c67271a..224b24f 100644
+--- a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
++++ b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
+@@ -40,6 +40,8 @@
+ #include <private/qrenderaspect_p.h>
+ #include <Qt3DQuickScene2D/private/qt3dquick3dscene2d_p.h>
+
++#include <QtCore/qcoreapplication.h>
++
+ QT_BEGIN_NAMESPACE
+
+ static void initScene2dPlugin()
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index ce7fc506..3403d8ce 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -13,6 +13,7 @@ DEPENDS_class-target += "qtdeclarative qt3d-native"
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
+ file://0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch \
"
PACKAGECONFIG ??= ""
@@ -34,6 +35,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "0bb720013d93c34d589c352a53405d8110fa57fe"
+SRCREV = "9675579a6d7955b0b278a54050f6f503e2b10b1a"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 8a4415a6..6534ca06 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -105,4 +105,4 @@ do_install() {
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
}
-SRCREV = "1d9270ee42c257e6df104053177653cffa76336e"
+SRCREV = "df40b1115db600e8de1c4774476fa30956a34fd9"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 9c87e211..834e5f9c 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -179,4 +179,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "1d9270ee42c257e6df104053177653cffa76336e"
+SRCREV = "df40b1115db600e8de1c4774476fa30956a34fd9"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 92305950..24f46265 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "3ac87eeb59dd7ec0351d76a05dd7cfa22a274e5e"
+SRCREV = "ca69fc961724d3a31c90e29ce3a7618b94b7c21c"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 92a301a5..ea91fa1e 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "e0ba5ac91dbb1fe3611118239c00ea8d748e5678"
+SRCREV = "54c920f3735d5302e1f6af7768c6a06f1dcd333f"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 027e5d14..2dc5be49 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -23,4 +23,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "89cf6da818279b16708d320ae3f5ed434310a347"
+SRCREV = "a983457e2280af1a1d7f5d5b94540d5648daca18"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 3f8ef3b0..75cfaa3e 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "743f32ee776220b52e0c37cbbbff5b4c52c475b6"
+SRCREV = "a29f9af154aca4a88be3df46641762a289556693"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index fe24da46..64f781f2 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "60708ee6227df017269146d2c0cfd4238ec25b9f"
+SRCREV = "77e0dc0485953427320ed0b442ba24eef4f9d73b"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index b5647edb..2332c924 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "fdce0bd433f4a219a371db4091b18cc48209b04f"
+SRCREV = "951b5fb5e39df3caa09b5e52292b1ac22c4dfe03"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 6d5e3f4f..1fc80e0d 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -19,4 +19,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "a3a229bd2ace8fc4f874304e60cf1cb74f294d71"
+SRCREV = "b934d46c2255391ea2b301974542bc0190bf5f72"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index feab7561..8e84d145 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "d2306d74850986692c02b70df0d7a6a6e933d0dc"
+SRCREV = "f2dbc67c2b032a5f27d0224e020fb6dfcd3fd142"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index c46f9677..2c4dc0d2 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -23,7 +23,8 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "11e6a62957433843816b41ad11fada7ca8eab85c"
-SRCREV_qtlocation-mapboxgl = "eec42f36aed7e446c03807ec6acc477d654548d7"
+
+SRCREV_qtlocation = "dca175454aefdd019952d941c6369c314e8c3b11"
+SRCREV_qtlocation-mapboxgl = "58b3bfbd0001f47fd88288e250d2028173dc0b23"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 19ddfe74..aff3f173 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -33,4 +33,4 @@ SRC_URI += "\
file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
"
-SRCREV = "b6299347cc5cf4a9e4f79e2a4a8bb389260264df"
+SRCREV = "e964e89331f2cfef99a3f63172a127b6c02a9727"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 983f0a17..d7dca2fd 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -10,4 +10,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "279adce9bb578749161899bfe82cfb6c8b9b6f0a"
+SRCREV = "8847f1e54d27c43ef744c39d28033e48764a254a"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 355c24ce..9f8510ce 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "e7409625f24ed8a32bb303b948bfdf077b74ea77"
+SRCREV = "5461df158c6076d3c3ed037e3051778018da7762"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 22c2b5e2..8f7087a3 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -21,4 +21,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "0e92d0ae2e21f01769f6768223a411c06b953989"
+SRCREV = "fb5e28850a1cdf86cecea1151ee68da35f759184"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 37ab92fd..089ee4f8 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "61d135d1c0ae52a756cf62144210fa73c9ea5526"
+SRCREV = "5cde7e8668c0d8729674e4fdd96ee6de52e6c2c3"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index fc8d71c9..df07ce7f 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "5d851f27a3c72e46df0dfdd234fc3a300a2870fb"
+SRCREV = "8ce3ea59e86f349d2505c97de28f817bccc11480"
SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 844b4be5..890e4276 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "d7f1d23c1dd954d20e8358ca6b7c3f6720310f50"
+SRCREV = "5863c695ee8eef2976026dea876e37b8978d0c7a"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 64a5df03..2ef9bdea 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "ed1942128078a30ea0436c3f2eb6cd9d60a82a4d"
+SRCREV = "f5338617ed81a740493d4006b185572a37ccb45d"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 0a9404b8..d438cb47 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "1340fedecd841765485beffa7c93320c96f21cdc"
+SRCREV = "d99b4cf607827bebd62475ed419bd6765a3b1d0b"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 36325adc..a001ceae 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "7cc50e972b7fa546f7cedff2ef19db20af9e36ab"
+SRCREV = "be428b21b777a04a1766adb880cb44e7b0b68e5a"
diff --git a/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch b/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch
deleted file mode 100644
index 17d5d514..00000000
--- a/recipes-qt/qt5/qttools/0002-assistant-help-fix-linking-of-dependent-libraries.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 95a418157ce5f49052ec1c349581d1811a79c9eb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Fri, 17 Jan 2014 14:33:19 +0100
-Subject: [PATCH] assistant/help: fix linking of dependent libraries
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-else we get:
-| ...ld: warning: libQt5CLucene.so.5, needed by ...libQt5Help.so, not found (try using -rpath or -rpath-link)
-| ...undefined reference to `QCLucenePhraseQuery::getTerms() const'
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- src/assistant/help/help.pro | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/assistant/help/help.pro b/src/assistant/help/help.pro
-index 37d5ba4..8de8763 100644
---- a/src/assistant/help/help.pro
-+++ b/src/assistant/help/help.pro
-@@ -60,3 +60,5 @@ HEADERS += qhelpsearchindexwriter_clucene_p.h \
- qhelpsearchindexreader_clucene_p.h
-
- load(qt_module)
-+
-+LIBS += -lQt5CLucene
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 775bc08c..17ec65a0 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -17,7 +17,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
SRC_URI += " \
- file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
file://0003-add-noqtwebkit-configuration.patch \
file://0004-linguist-tools-cmake-allow-overriding-the-location-f.patch \
"
@@ -30,6 +29,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "0285e3ad511882b3cfb87fc06ffbf5775c01437b"
+SRCREV = "451adafbc52c8f7a13854821c9d69efd37dfcc6a"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index f9f1e5d9..9425bd09 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -41,7 +41,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "e9fb11653a504b86478ef8f4513a6c23045a4fa2"
+SRCREV = "60a3ae6559c3d53ef936c5f90182d53b1a7fea24"
# From https://bugreports.qt.io/browse/QTBUG-57767
SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index a38387c7..724a6a61 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -17,4 +17,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "196097bfc84d297199ea591fc19e714c88796e8e"
+SRCREV = "4a95a4e603e1bfd8e365274a5888dcdbb6bb42e7"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index dffb9d3f..9187a331 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -115,7 +115,7 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "6ec0428db1d1dda0a74ead838aa799298e7a1306"
+SRCREV_qtwebengine = "cd475d5727becd6ec4e7605d335721355e049354"
SRCREV_chromium = "cd3417bc8b5bae4cdc04a9dd714adadacc03b28d"
SRCREV = "${SRCREV_qtwebengine}"
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb
index 3d6f5003..286aecae 100644
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ b/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtwebkit qtxmlpatterns"
RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
-SRCREV = "c858361fb202c201f8c45e2072d913dc7f31ec8e"
+SRCREV = "822426abc77a74752b0ee0da4d0a1c106c4dac22"
diff --git a/recipes-qt/qt5/qtwebkit/0002-Remove-TEXTREL-tag-in-x86.patch b/recipes-qt/qt5/qtwebkit/0002-Remove-TEXTREL-tag-in-x86.patch
deleted file mode 100644
index d7627ec2..00000000
--- a/recipes-qt/qt5/qtwebkit/0002-Remove-TEXTREL-tag-in-x86.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From f6989fec34f0bafdeda549d71751f236ef1f3b96 Mon Sep 17 00:00:00 2001
-From: Magnus Granberg <zorry@gentoo.org>
-Date: Fri, 27 Feb 2015 11:55:09 +0100
-Subject: [PATCH] Remove TEXTREL tag in x86
-
-Fix textrel QA warnings when building qtwebkit for x86:
-
- WARNING: QA Issue: ELF binary '/home/andre/rdk/rdk-master/build-vbox32/tmp/work/core2-32-rdk-linux/qtwebkit/5.4.0-r0/packages-split/qtwebkit/usr/lib/libQt5WebKit.so.5.4.0' has relocations in .text [textrel]
-
-Patch from upstream webkit:
-
- https://bugs.webkit.org/show_bug.cgi?id=70610
-
-Minor refresh required to apply cleanly to the older webkit sources used
-by qtwebkit. Specifically, the patch needed to be modified to account
-for PLATFORM(MAC) -> OS(DARWIN) renaming in recent webkit which is not
-part of qtwebkit yet ( https://bugs.webkit.org/show_bug.cgi?id=99683 ).
-
-Upstream status [webkit] : backport
-Upstream status [qtwebkit] : unclear
-
-Bug: https://bugs.webkit.org/show_bug.cgi?id=70610
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- Source/JavaScriptCore/jit/ThunkGenerators.cpp | 24 ++++++++++++++++++++++++
- Source/WTF/wtf/InlineASM.h | 2 ++
- 2 files changed, 26 insertions(+)
-
-diff --git a/Source/JavaScriptCore/jit/ThunkGenerators.cpp b/Source/JavaScriptCore/jit/ThunkGenerators.cpp
-index 9684df2..8af82d8 100644
---- a/Source/JavaScriptCore/jit/ThunkGenerators.cpp
-+++ b/Source/JavaScriptCore/jit/ThunkGenerators.cpp
-@@ -524,6 +524,30 @@ double jsRound(double d)
- } \
- static MathThunk UnaryDoubleOpWrapper(function) = &function##Thunk;
-
-+#elif CPU(X86) && COMPILER(GCC) && OS(LINUX) && defined(__PIC__)
-+#define defineUnaryDoubleOpWrapper(function) \
-+ asm( \
-+ ".text\n" \
-+ ".globl " SYMBOL_STRING(function##Thunk) "\n" \
-+ HIDE_SYMBOL(function##Thunk) "\n" \
-+ SYMBOL_STRING(function##Thunk) ":" "\n" \
-+ "pushl %ebx\n" \
-+ "subl $20, %esp\n" \
-+ "movsd %xmm0, (%esp) \n" \
-+ "call __x86.get_pc_thunk.bx\n" \
-+ "addl $_GLOBAL_OFFSET_TABLE_, %ebx\n" \
-+ "call " GLOBAL_REFERENCE(function) "\n" \
-+ "fstpl (%esp) \n" \
-+ "movsd (%esp), %xmm0 \n" \
-+ "addl $20, %esp\n" \
-+ "popl %ebx\n" \
-+ "ret\n" \
-+ );\
-+ extern "C" { \
-+ MathThunkCallingConvention function##Thunk(MathThunkCallingConvention); \
-+ } \
-+ static MathThunk UnaryDoubleOpWrapper(function) = &function##Thunk;
-+
- #elif CPU(X86) && COMPILER(GCC) && (PLATFORM(MAC) || OS(LINUX))
- #define defineUnaryDoubleOpWrapper(function) \
- asm( \
-diff --git a/Source/WTF/wtf/InlineASM.h b/Source/WTF/wtf/InlineASM.h
-index 0a2fe78..2dc40ef 100644
---- a/Source/WTF/wtf/InlineASM.h
-+++ b/Source/WTF/wtf/InlineASM.h
-@@ -46,6 +46,8 @@
- #define GLOBAL_REFERENCE(name) #name "@plt"
- #elif CPU(X86) && COMPILER(MINGW)
- #define GLOBAL_REFERENCE(name) "@" #name "@4"
-+#elif OS(LINUX) && CPU(X86) && defined(__PIC__)
-+#define GLOBAL_REFERENCE(name) SYMBOL_STRING(name) "@plt"
- #else
- #define GLOBAL_REFERENCE(name) SYMBOL_STRING(name)
- #endif
diff --git a/recipes-qt/qt5/qtwebkit/0004-Remove-unused-check-for-private_tests.patch b/recipes-qt/qt5/qtwebkit/0004-Remove-unused-check-for-private_tests.patch
deleted file mode 100644
index 694b983a..00000000
--- a/recipes-qt/qt5/qtwebkit/0004-Remove-unused-check-for-private_tests.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From fbbbd9f3bc669790ab95569ebd6052ec68bd408f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jan=20Kundr=C3=A1t?= <jkt@kde.org>
-Date: Wed, 14 Sep 2016 23:51:14 +0200
-Subject: [PATCH] Remove unused check for private_tests
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-It turns out that qt_developer_build is never used anyway.
-
-I did some git archeology and it looks like it was nuked when doing the
-5.2 merge from upstream. The original purpose was apparently to control
--Werror, which is nowadays controlled by CONFIG -= production_build.
-
-This actually fixes the build, as the QT_FOR_CONFIG += core-private which
-would have been required for qtConfig(private_tests) is missing.
-
-Task-number: QTBUG-55950
-Change-Id: Iaaaad184b29b523ce4a4ed8afec2ac527d8f93e3
-Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
-Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
-Reviewed-by: Jan Kundrát <jkt@kde.org>
----
- Tools/qmake/mkspecs/features/default_pre.prf | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/Tools/qmake/mkspecs/features/default_pre.prf b/Tools/qmake/mkspecs/features/default_pre.prf
-index 6bb52d0..8aa806d 100644
---- a/Tools/qmake/mkspecs/features/default_pre.prf
-+++ b/Tools/qmake/mkspecs/features/default_pre.prf
-@@ -62,10 +62,6 @@ win32-msvc*: MAKEFILE_NOOP_COMMAND = @echo >NUL
- scratchbox: PYTHON = python2.6
- else: PYTHON = python
-
--# We use private_tests to detect developer build, since the destdir will
--# always be our webkit build dir. This might change as configure changes.
--qtConfig(private_tests): CONFIG += qt_developer_build
--
- # By default we enable "production build", and build-webkit, which is
- # used by bots and developers, will disable it, to enable warnings etc.
- CONFIG += production_build
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 1ceaffd2..8b2468d2 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -20,9 +20,7 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
SRC_URI += "\
file://0001-qtwebkit-fix-QA-issue-bad-RPATH.patch \
- file://0002-Remove-TEXTREL-tag-in-x86.patch \
file://0003-Exclude-backtrace-API-for-non-glibc-libraries.patch \
- file://0004-Remove-unused-check-for-private_tests.patch \
"
PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel \
@@ -87,4 +85,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-SRCREV = "0b30e4490f7500ade1868fb33cea8705418c90bb"
+SRCREV = "5a249af4e4ba392904bc7b0f3e103bb87ad540f6"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index a567f15f..42c0e4a1 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "1af97a5f04d4d7d0dbf9954397e2374a791d717b"
+SRCREV = "91582c53c5c3b404169ce2a44d75ac8102043513"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index ac8d1350..3682aca2 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "5ecce026f65b2fb320379e49e70f772ad2bbba69"
+SRCREV = "8c44529ed5269bc2130c27ba9733d262143424ed"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index b1018720..7704535b 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -16,6 +16,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "8f340ee4baddd6f9a43ecb1754c563372b561ce3"
+SRCREV = "15c0b967295b4be41c881335fe602c1afec65aec"
BBCLASSEXTEND =+ "native nativesdk"