aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-missing-forward-declarations.patch31
-rw-r--r--recipes-qt/qt5/qtbase/0001-Disable-unnamed-tmp-files.patch29
-rw-r--r--recipes-qt/qt5/qtbase_git.bb5
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch6
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2/0001-Add-missing-includes-for-QColor.patch35
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb4
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch40
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb6
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch22
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb4
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
40 files changed, 105 insertions, 140 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 29a8438d..602ba50e 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "678ff94ff29db1b0faa4aa8d486d4df544ce3247"
+SRCREV = "f537dc0da288949c4df903c1f2b21156e62fbae5"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 2800def1..46610372 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -34,6 +34,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "43c7f0bbdcc465d80aeb51328f9154ef1631c769"
+SRCREV = "5c99313eedada4e502b57798122ab20d71eca0fe"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 78c754ce..c17b2bbb 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2016 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "dev"
+QT_MODULE_BRANCH ?= "5.10"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index e3ef6d92..50e894b5 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -33,6 +33,7 @@ SRC_URI += "\
SRC_URI += " \
file://0011-Always-build-uic.patch \
file://0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch \
+ file://0001-Disable-unnamed-tmp-files.patch \
"
CLEANBROKEN = "1"
@@ -109,4 +110,4 @@ do_install() {
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
}
-SRCREV = "678ff94ff29db1b0faa4aa8d486d4df544ce3247"
+SRCREV = "f537dc0da288949c4df903c1f2b21156e62fbae5"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-missing-forward-declarations.patch b/recipes-qt/qt5/qtbase/0001-Add-missing-forward-declarations.patch
deleted file mode 100644
index 8f0f392c..00000000
--- a/recipes-qt/qt5/qtbase/0001-Add-missing-forward-declarations.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From a3ad110da2320174057671ec3b0df2447f0f728b Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Tue, 20 Jun 2017 13:45:20 +0300
-Subject: [PATCH] Add missing forward declarations
-
-fix build with -no-accessibility
-
-Change-Id: Ia58c11b22f08a51d5978e4a002480d265aa10fbd
----
- src/widgets/styles/qstylehelper_p.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/widgets/styles/qstylehelper_p.h b/src/widgets/styles/qstylehelper_p.h
-index 8ca2139..777ad95 100644
---- a/src/widgets/styles/qstylehelper_p.h
-+++ b/src/widgets/styles/qstylehelper_p.h
-@@ -62,10 +62,14 @@
-
- QT_BEGIN_NAMESPACE
-
-+class QColor;
-+class QObject;
- class QPainter;
-+class QPalette;
- class QPixmap;
- class QStyleOptionSlider;
- class QStyleOption;
-+class QWidget;
- class QWindow;
-
- namespace QStyleHelper
diff --git a/recipes-qt/qt5/qtbase/0001-Disable-unnamed-tmp-files.patch b/recipes-qt/qt5/qtbase/0001-Disable-unnamed-tmp-files.patch
new file mode 100644
index 00000000..098e2fa7
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0001-Disable-unnamed-tmp-files.patch
@@ -0,0 +1,29 @@
+From 853fc888f38d6ad0e189ba54ef648abe0ff5bb60 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Mon, 28 Aug 2017 15:36:17 +0300
+Subject: [PATCH] Disable unnamed tmp files
+
+qmake does not work together with pseudo when unnamed temporary files
+(O_TMPFILE) are used.
+
+Upstream-Status: Inappropriate [OE specific]
+[YOCTO #11996]
+Change-Id: I9be92312c3e9a80438c1dc01344cb1ad721ad466
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ src/corelib/io/qtemporaryfile_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/corelib/io/qtemporaryfile_p.h b/src/corelib/io/qtemporaryfile_p.h
+index 46a0d7a..3b418c9 100644
+--- a/src/corelib/io/qtemporaryfile_p.h
++++ b/src/corelib/io/qtemporaryfile_p.h
+@@ -58,7 +58,7 @@
+ #include "private/qfile_p.h"
+ #include "qtemporaryfile.h"
+
+-#ifdef Q_OS_LINUX
++#if 0
+ # include <fcntl.h>
+ # ifdef O_TMPFILE
+ // some early libc support had the wrong values for O_TMPFILE
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 62e62ad5..d0e98675 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -22,8 +22,7 @@ SRC_URI += "\
file://0005-configure-bump-path-length-from-256-to-512-character.patch \
file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \
file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
- file://0001-Add-missing-forward-declarations.patch \
-"
+ "
DEPENDS += "qtbase-native"
@@ -183,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "678ff94ff29db1b0faa4aa8d486d4df544ce3247"
+SRCREV = "f537dc0da288949c4df903c1f2b21156e62fbae5"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 137f0348..77bfcb47 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "eb28146d3f2984a29a8917a36c1327e1d0becec7"
+SRCREV = "3241a817e0c25da7ee682c8274d859757eeb5839"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 671ea5d0..77b00542 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "81d0c42c7e4b781365556e1e8d1c8de1e592ae47"
+SRCREV = "0168fe1f95d56850734447b118cdcf1847da1c51"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index b4e88e99..8936699b 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "c961434d37eefa83e824ab3917480247a43045b8"
+SRCREV = "c3c3837b02919a26031d917003898e72585e300b"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 7501f9b4..1cb25bc4 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "53fcf914e278ed4395a4873af2b64272c5d7882c"
+SRCREV = "c54adde27f5aa723882ffc5f77fae86b3793b6e2"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 902ef91a..c6733f70 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "55490690f81eba168b06a90e4a66cefc20b38252"
+SRCREV = "780e11cf38a98cd32b6a5aa44dbb4cbf0f5d5ff8"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index d1568922..e6d75c93 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "d4c6ba6afe1d7a3165f1ac108fef6eb2b994175a"
+SRCREV = "ffa5a03da503c3cd00f960debf3f43b85958c874"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index b44821f7..d48e1134 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -14,4 +14,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "8ffe4cc5244f9d2dfa0f9444f2aa86c74dc593c8"
+SRCREV = "045174c411f89863165610c1f6135ef4bd3d0889"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 6b9ebd38..f02e57b8 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "2b7fadfd9c0fc084588af2074f9731041632ec22"
+SRCREV = "36fdeb50941e3e2b0c4cd1b3343c3e337534357d"
diff --git a/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
index 5e452c03..ea8b8827 100644
--- a/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
+++ b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
@@ -1,4 +1,4 @@
-From 632cfa131a890d42275873a7ca8cdf95ada61360 Mon Sep 17 00:00:00 2001
+From 3f88a23ead8da8bd3e3ef354f0afe8ddedcccc41 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 7 Jun 2017 13:29:29 +0300
Subject: [PATCH] Make mapbox-gl build configurable
@@ -13,7 +13,7 @@ Change-Id: I5f26200f2735b363c3c322f9035b331b9159c47b
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/plugins/geoservices/geoservices.pro b/src/plugins/geoservices/geoservices.pro
-index 459897a..d97e05d 100644
+index 07c3479..55d0040 100644
--- a/src/plugins/geoservices/geoservices.pro
+++ b/src/plugins/geoservices/geoservices.pro
@@ -6,7 +6,7 @@ qtConfig(concurrent) {
@@ -22,6 +22,6 @@ index 459897a..d97e05d 100644
-qtConfig(opengl):qtConfig(c++14):!win32|mingw:!qnx {
+mapboxgl:qtConfig(opengl):qtConfig(c++14):!win32|mingw:!qnx {
- !exists(../../3rdparty/mapbox-gl-native/CMakeLists.txt) {
+ !exists(../../3rdparty/mapbox-gl-native/mapbox-gl-native.pro) {
warning("Submodule mapbox-gl-native does not exist. Run 'git submodule update --init' on qtlocation.")
} else {
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index ac8b5f35..22131b63 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -28,7 +28,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "7bd7815f613c6f1ae0215d0b6a0ab5b7a6e72a59"
-SRCREV_qtlocation-mapboxgl = "9ecbe3642fb4a53b558598239b59bf1d0224c25b"
+SRCREV_qtlocation = "b68b88373beb884c77ec9813cac1e9a79854b957"
+SRCREV_qtlocation-mapboxgl = "1c633072fcea7ad153ab6f8ec40dd72d83541ead"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index ad0a7e11..1a523cb7 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -29,4 +29,4 @@ SRC_URI += "\
file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
"
-SRCREV = "7fdb88a86b0782e7170eefe3dfe7ab3e9c81f847"
+SRCREV = "c341b2b25697f937280fe3620629ac3d32c19613"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 6f334bf9..df060c13 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "aa52bdacbff744c2bf20845f8c0a78aeb21d9878"
+SRCREV = "461a29be564271ef3a6ca1728f5e48ec2d25c08d"
diff --git a/recipes-qt/qt5/qtquickcontrols2/0001-Add-missing-includes-for-QColor.patch b/recipes-qt/qt5/qtquickcontrols2/0001-Add-missing-includes-for-QColor.patch
deleted file mode 100644
index b1b28f7e..00000000
--- a/recipes-qt/qt5/qtquickcontrols2/0001-Add-missing-includes-for-QColor.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From df04226fe0bc6d372e1c237527d0d0c9ea39bca4 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Tue, 20 Jun 2017 13:43:41 +0300
-Subject: [PATCH] Add missing includes for QColor
-
-Change-Id: I1bb5b4653bdc9d7b4fab61df99035715fa280fcd
----
- src/imports/controls/qquickdefaultbusyindicator_p.h | 1 +
- src/imports/controls/qquickdefaultprogressbar_p.h | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/src/imports/controls/qquickdefaultbusyindicator_p.h b/src/imports/controls/qquickdefaultbusyindicator_p.h
-index e214020..f327c8d 100644
---- a/src/imports/controls/qquickdefaultbusyindicator_p.h
-+++ b/src/imports/controls/qquickdefaultbusyindicator_p.h
-@@ -49,6 +49,7 @@
- //
-
- #include <QtQuick/qquickitem.h>
-+#include <QtGui/qcolor.h>
-
- QT_BEGIN_NAMESPACE
-
-diff --git a/src/imports/controls/qquickdefaultprogressbar_p.h b/src/imports/controls/qquickdefaultprogressbar_p.h
-index dbdf5ad..91f8056 100644
---- a/src/imports/controls/qquickdefaultprogressbar_p.h
-+++ b/src/imports/controls/qquickdefaultprogressbar_p.h
-@@ -49,6 +49,7 @@
- //
-
- #include <QtQuick/qquickitem.h>
-+#include <QtGui/qcolor.h>
-
- QT_BEGIN_NAMESPACE
-
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index aff91025..d3f3a08e 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,6 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRC_URI += "file://0001-Add-missing-includes-for-QColor.patch"
-
-SRCREV = "20d141034b48ae73eee70743dc410d35491cd00f"
+SRCREV = "4200f7117973969392be48b0c82f1b4bc214e546"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 1c23fed5..d176d1b5 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -24,4 +24,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "9f085b889524a80d4064d6ac01dbdc817bb31060"
+SRCREV = "caa38d217ecbcaaa5617255290598012477c4492"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 4622e17f..e4e32b76 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -22,6 +22,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "0f80a0ad9f80f9f78dc9e9efe8b601dea2487322"
+SRCREV = "d2269c4e68f283f704547a0a96a662b5feeea732"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 8e127a6d..668a2f30 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "0ac21330b6cf5f95d733f16ff16614879000b588"
+SRCREV = "3d44bf7ce2a45d461f1d74a3f1dbdff313845898"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 452e6ccd..301ed0ab 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "5b89e61c39fb253dae46a8aa48d341a3fd37b4b4"
+SRCREV = "3ba4176568867cb146c2b758cd39461367ad22d1"
SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index d6c3ac26..fb4c496f 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "c0fe554f498025067edd78e75e3efb46868f8fe6"
+SRCREV = "b2e6b77c0862aba5d9f9fc979db8f2d84e47a78a"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index c42be4b8..2166d82d 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "e257664ae65ce5c51c7edac0a1a9ffaba4baea70"
+SRCREV = "bec0f13fa456d3b52deb6dbb7add5e81b7734fa4"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 9eabd1b7..37a99d32 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "55aa81e9acc736d162d3e4f775814ac91dbf1a80"
+SRCREV = "004289a1b7e5ff5c4f19fab3c3d41c009429b352"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index beab9315..bf632bb0 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "0781b64b56ea1116bf5bf214df782772c09f27ca"
+SRCREV = "dc9e39eb679946e82bf3b1a82f5c49737f9994b2"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 1b811eaf..de2da9c5 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -27,7 +27,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "36defe5725bbed8e03d4f0ef676bc6afa99e6b04"
+SRCREV = "8492e448666931a33d53a52df31ac2fd796239a5"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 38c710f8..37cd0083 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "7c770c6e510d6c2274fd10a10e6f812672e3a6d1"
+SRCREV = "d80646f8f11283ad4bd9996d5a59a1154e7f651d"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 4271a783..03e2eb6c 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "dbf418dce41fe08368d38a098a771348a5b3d0fd"
+SRCREV = "e99dae74353e5652794d7bcbcd3d79b1478debbc"
# From https://bugreports.qt.io/browse/QTBUG-57767
SRC_URI += " \
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index ecd7f0d8..37a0c403 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "2dd6a5e7ff769e54065ae8b9b532b2e56f2e3116"
+SRCREV = "749951c19cbb7d301bed20f24d16dd4e713485c2"
diff --git a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
index e10d3b82..148b0629 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
-From 5c879db32cde9bee9c9073842ecc281172f19453 Mon Sep 17 00:00:00 2001
+From e7d1e5dfdece59f247a1d71ad0ca1b0c8cadda21 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 15 Mar 2017 13:53:28 +0200
Subject: [PATCH] Force host toolchain configuration
@@ -6,17 +6,32 @@ Subject: [PATCH] Force host toolchain configuration
Force gcc/g++ to be used for parts using host toolchain, since
the option(host_build) does not work in yocto builds.
+Don't use QT_ARCH for the host architecture, since that's always
+the target architecture in bitbake builds, instead ask specifically
+for the qmakes's host architecture.
+
+Change-Id: I38329d545e527dbc5892547b6951822171ab761f
Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
- src/buildtools/configure_host.pro | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
+ src/buildtools/configure_host.pro | 14 +++++++-------
+ src/core/config/linux.pri | 2 +-
+ 2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/src/buildtools/configure_host.pro b/src/buildtools/configure_host.pro
-index d8d731d..89dade4 100644
+index f1b3d47..1212372 100644
--- a/src/buildtools/configure_host.pro
+++ b/src/buildtools/configure_host.pro
-@@ -16,9 +16,9 @@ GN_CONTENTS = \
+@@ -4,7 +4,7 @@ TEMPLATE = aux
+ # Pick up the host toolchain
+ option(host_build)
+
+-GN_HOST_CPU = $$gnArch($$QT_ARCH)
++GN_HOST_CPU = $$gnArch($$QMAKE_HOST.arch)
+ !isEmpty(QT_TARGET_ARCH): GN_TARGET_CPU = $$gnArch($$QT_TARGET_ARCH)
+ else: GN_TARGET_CPU = $$GN_HOST_CPU
+ GN_OS = $$gnOS()
+@@ -29,9 +29,9 @@ GN_CONTENTS = \
"import(\"//build/config/sysroot.gni\")" \
"import(\"//build/toolchain/gcc_toolchain.gni\")" \
"gcc_toolchain(\"host\") {" \
@@ -29,7 +44,7 @@ index d8d731d..89dade4 100644
" ar = \"$$which(ar)\" " \
" nm = \"$$which(nm)\" " \
" toolchain_args = { " \
-@@ -27,9 +27,9 @@ GN_CONTENTS = \
+@@ -42,9 +42,9 @@ GN_CONTENTS = \
" } " \
"}" \
"gcc_toolchain(\"v8_snapshot\") {" \
@@ -42,6 +57,19 @@ index d8d731d..89dade4 100644
" ar = \"$$which(ar)\" " \
" nm = \"$$which(nm)\" " \
" toolchain_args = { " \
+diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
+index 714c864..f66ca55 100644
+--- a/src/core/config/linux.pri
++++ b/src/core/config/linux.pri
+@@ -98,7 +98,7 @@ contains(QT_ARCH, "mips"):!host_build {
+
+ host_build {
+ gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\"
+- GN_HOST_CPU = $$gnArch($$QT_ARCH)
++ GN_HOST_CPU = $$gnArch($$QMAKE_HOST.arch)
+ gn_args += host_cpu=\"$$GN_HOST_CPU\"
+ # Don't bother trying to use system libraries in this case
+ gn_args += use_glib=false
diff --git a/src/3rdparty/chromium/tools/gn/bootstrap/bootstrap.py b/src/3rdparty/chromium/tools/gn/bootstrap/bootstrap.py
index 75b9690..601f688 100755
--- a/src/3rdparty/chromium/tools/gn/bootstrap/bootstrap.py
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 74e003b6..0c5fbf90 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -104,7 +104,7 @@ RDEPENDS_${PN}-examples += " \
qtdeclarative-qmlplugins \
"
-QT_MODULE_BRANCH_CHROMIUM = "56-based"
+QT_MODULE_BRANCH_CHROMIUM = "58-based"
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
@@ -113,8 +113,8 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "fa19227c3ac7df7c0d2f8a548a9a36ac9a7b803c"
-SRCREV_chromium = "aa2fdd6be3d465280d2a0c3aacdc738bb4ffec05"
+SRCREV_qtwebengine = "647307f534d45758832f23912ed281af819f0174"
+SRCREV_chromium = "582c5493439ba9ac57c6c14c706f530741f5bfc8"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index fa775946..dd618b10 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "26e56e18eb234df4a782737cd3c8d8d11daead2c"
+SRCREV = "fdb6d8370f9ae8fa148124289317c108399853c3"
diff --git a/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch b/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch
deleted file mode 100644
index 82087b9a..00000000
--- a/recipes-qt/qt5/qtwebview/0001-Add-missing-include-for-qWarning.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From b946b6ea4a2a30bd12ecd036e40c9ef671681ba8 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Fri, 2 Jun 2017 13:12:18 +0300
-Subject: [PATCH] Add missing include for qWarning
-
-Change-Id: I7c7699e7a2b7ce59e4f659d460ec835f59bba439
----
- src/webview/qquickwebview.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/webview/qquickwebview.cpp b/src/webview/qquickwebview.cpp
-index d760564..fbbbfd6 100644
---- a/src/webview/qquickwebview.cpp
-+++ b/src/webview/qquickwebview.cpp
-@@ -39,6 +39,7 @@
- #include <QtWebView/private/qwebviewloadrequest_p.h>
- #include <QtQml/qqmlengine.h>
- #include <QtCore/qmutex.h>
-+#include <QtCore/QDebug>
-
- namespace {
-
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index cdf465d6..4b9e0be8 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -9,8 +9,6 @@ LIC_FILES_CHKSUM = " \
require qt5.inc
require qt5-git.inc
-SRC_URI += "file://0001-Add-missing-include-for-qWarning.patch"
-
DEPENDS += "qtbase qtwebengine"
-SRCREV = "22e7f1941fbbb7aa7212faabf5939b6d2ca7bd49"
+SRCREV = "7e71daf48c2ee3c3518cbfe6103d212772ccf414"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index 620e0430..bc2557c4 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "915ee2598030b799aeb67908bae49a70b4079e37"
+SRCREV = "9749c5085dc21d2064177aa748f3a9395592a7cf"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index af70b9f4..7a363175 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -16,6 +16,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "c9a4897aa09d723d22b842b1fabcc296bf3c7f91"
+SRCREV = "fee0795ca96079a8f37473d3aec18757d1e52d24"
BBCLASSEXTEND =+ "native nativesdk"