aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch29
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch b/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
new file mode 100644
index 00000000..73ef469f
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
@@ -0,0 +1,29 @@
+From a5c8d833ffb8b54626b7b670b2782a6cf9a45075 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 12 Nov 2019 19:53:59 -0800
+Subject: [PATCH] mkspecs: Allow builds with libc != glibc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/features/configure.prf | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
+index cc84182b..c278ffae 100644
+--- a/mkspecs/features/configure.prf
++++ b/mkspecs/features/configure.prf
+@@ -75,11 +75,6 @@ defineTest(runConfigure) {
+ return(false)
+ }
+
+- !qtConfig(webengine-system-glibc) {
+- skipBuild("A suitable version >= 2.27 of libc could not be found.")
+- return(false)
+- }
+-
+ QT_FOR_CONFIG += gui-private
+
+ !qtConfig(webengine-system-khr) {
+--
+2.24.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index dc41c517..eab8225e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -146,6 +146,7 @@ SRC_URI += " \
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0003-musl-link-against-libexecinfo.patch \
+ file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/73-based