aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/files/module_qmake.conf1
-rw-r--r--recipes-qt/qt5/qtdeclarative.inc39
-rw-r--r--recipes-qt/qt5/qtdeclarative_4.999+git.bb7
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qt/qt5/files/module_qmake.conf b/recipes-qt/qt5/files/module_qmake.conf
new file mode 100644
index 00000000..4285ae84
--- /dev/null
+++ b/recipes-qt/qt5/files/module_qmake.conf
@@ -0,0 +1 @@
+load(qt_build_config) \ No newline at end of file
diff --git a/recipes-qt/qt5/qtdeclarative.inc b/recipes-qt/qt5/qtdeclarative.inc
new file mode 100644
index 00000000..aaada23e
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative.inc
@@ -0,0 +1,39 @@
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
+
+DEPENDS = "qtbase qtjsbackend"
+
+INC_PR = "r0"
+
+inherit qmake5
+
+SRC_URI += " \
+ file://module_qmake.conf \
+ "
+
+# Bitbake will not respect the make order set by qmake and at times it will try to compile
+# parts of the source tree with out the 'mkv8snapshot' tool if it is enabled and that will fail
+#PARALLEL_MAKE = ""
+
+export QT_CONF_PATH="${WORKDIR}/qt.conf"
+
+do_configure () {
+ # Avoid setting QMAKE_LINK from LD (since we want the linker to be g++)
+ unset LD
+
+ # This should not be needed. Perhaps the lack of this file is an indication
+ # of an error on the native recipe...
+ cp ${WORKDIR}/module_qmake.conf ${S}/.qmake.conf
+
+ ${OE_QMAKE_QMAKE} -d
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
+
+FILES_${PN}-dev += "\
+ ${STAGING_INCDIR}/qt5 \
+ ${STAGING_DATADIR}/qt5 \
+ ${libdir}/*.prl \
+"
diff --git a/recipes-qt/qt5/qtdeclarative_4.999+git.bb b/recipes-qt/qt5/qtdeclarative_4.999+git.bb
new file mode 100644
index 00000000..456c2dab
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative_4.999+git.bb
@@ -0,0 +1,7 @@
+SRCREV = "90ac5018823ab1109d084cbe0e9e63a4cd531faa"
+SRC_URI += "git://gitorious.org/qt/qtdeclarative.git;protocol=git"
+S = "${WORKDIR}/git"
+
+require qtdeclarative.inc
+
+PR = "${INC_PR}.0"