aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtdeclarative/run-ptest5
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb1
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/run-ptest b/recipes-qt/qt5/qtdeclarative/run-ptest
new file mode 100644
index 00000000..6c3f522b
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/run-ptest
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+for x in ` awk '{print $1}' tst_list `;do
+ ./${x};
+done
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index c19bbd56..34a8897d 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \