aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb3
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch49
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
16 files changed, 16 insertions, 68 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 3faf3416..cec0d0cc 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -36,7 +36,6 @@ SRC_URI += "\
file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
- file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0013-Disable-ltcg-for-host_build.patch \
file://0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
@@ -195,4 +194,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "de6e92e26a49de4942f006c2e70f11d1dbf600d6"
+SRCREV = "81ce2d1d6fa741de4d27b939a378147a02019ec1"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 9dc4a601..e8e981e4 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "5f83aa911364925d93c552c4bbea885a4e2807ee"
+SRCREV = "85c21500c52fe4cbfa1aa9d556296f85abc062b9"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 9957f0da..12436a73 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -31,7 +31,6 @@ SRC_URI += "\
file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
- file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0013-Disable-ltcg-for-host_build.patch \
file://0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
@@ -142,4 +141,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "de6e92e26a49de4942f006c2e70f11d1dbf600d6"
+SRCREV = "81ce2d1d6fa741de4d27b939a378147a02019ec1"
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
deleted file mode 100644
index a35746c6..00000000
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 3184d1f75e0312826efd1227519b46b5cb464299 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 14 Feb 2018 17:08:43 -0800
-Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
-
--isystem fails to build when code uses include_next on certain files e.g.
-
-qtbase/5.10.0+gitAUTOINC+50117d738a-r0/recipe-sysroot/usr/include/c++/7.3.0/cstdlib:75:15: fatal error: stdlib.h: No such file or directory
- #include_next <stdlib.h>
- ^~~~~~~~~~
-compilation terminated.
-make[2]: *** [Makefile:11592: .obj/qgenericpluginfactory.o] Error 1
-
-Upstream-Status: Pending
-
-Change-Id: Ia47832a6339a6ee59c0a6301fc5e552cd28b1029
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- mkspecs/common/clang.conf | 2 +-
- mkspecs/common/gcc-base.conf | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/mkspecs/common/clang.conf b/mkspecs/common/clang.conf
-index 2499c8b6d8..2e79e083cd 100644
---- a/mkspecs/common/clang.conf
-+++ b/mkspecs/common/clang.conf
-@@ -18,7 +18,7 @@ QMAKE_PCH_OUTPUT_EXT = .pch
-
- QMAKE_CFLAGS_OPTIMIZE_SIZE = -Oz
-
--QMAKE_CFLAGS_ISYSTEM = -isystem
-+QMAKE_CFLAGS_ISYSTEM =
- QMAKE_CFLAGS_PRECOMPILE = -x c-header -c ${QMAKE_PCH_INPUT} -o ${QMAKE_PCH_OUTPUT}
- QMAKE_CFLAGS_USE_PRECOMPILE = -Xclang -include-pch -Xclang ${QMAKE_PCH_OUTPUT}
- QMAKE_CFLAGS_LTCG = -flto=thin
-diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
-index 1f919d270a..adf3fead32 100644
---- a/mkspecs/common/gcc-base.conf
-+++ b/mkspecs/common/gcc-base.conf
-@@ -46,7 +46,7 @@ QMAKE_CFLAGS_DEBUG += -g
- QMAKE_CFLAGS_SHLIB += $$QMAKE_CFLAGS_PIC
- QMAKE_CFLAGS_STATIC_LIB += $$QMAKE_CFLAGS_PIC
- QMAKE_CFLAGS_APP += $$QMAKE_CFLAGS_PIC
--QMAKE_CFLAGS_ISYSTEM = -isystem
-+QMAKE_CFLAGS_ISYSTEM =
- QMAKE_CFLAGS_YACC += -Wno-unused -Wno-parentheses
- QMAKE_CFLAGS_HIDESYMS += -fvisibility=hidden
- QMAKE_CFLAGS_EXCEPTIONS_OFF += -fno-exceptions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3d6dfd13..41f26211 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -27,7 +27,6 @@ SRC_URI += "\
file://0009-Add-OE-specific-specs-for-clang-compiler.patch \
file://0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
file://0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
- file://0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch \
file://0013-Disable-ltcg-for-host_build.patch \
file://0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
@@ -295,4 +294,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "de6e92e26a49de4942f006c2e70f11d1dbf600d6"
+SRCREV = "81ce2d1d6fa741de4d27b939a378147a02019ec1"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 5f319e26..ef534d48 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -30,6 +30,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "ad47d70e2289d59625cd405fa54c5de2db68ad82"
+SRCREV = "749ca5d0272eec49c2986eecebe897d311cbf372"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 8c3d5ce6..78453327 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -38,7 +38,7 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "8337692ea357da48e8914e6ab87d6cb6baf17dc7"
+SRCREV = "99db82a99363a8819b7c1600c565d37b48409fbf"
# Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory
do_install_append() {
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 49e519c9..14f74043 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "8e3774cf88ba086c12df4ac14da6b7c91bfa333c"
+SRCREV = "2b8a0b6423f70bbccdf214d12896d4755b384c67"
diff --git a/recipes-qt/qt5/qtquick3d_git.bb b/recipes-qt/qt5/qtquick3d_git.bb
index bb06cecf..28c0c4ea 100644
--- a/recipes-qt/qt5/qtquick3d_git.bb
+++ b/recipes-qt/qt5/qtquick3d_git.bb
@@ -21,7 +21,7 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick3D/Helpers/meshes/*.mesh \
"
-SRCREV_qtquick3d = "e133dec4278ce34b68617e4ec7bbbdb841e60904"
+SRCREV_qtquick3d = "45b3b76a9529e31fc1b0d7423400d9a76cfef67d"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
SRCREV_FORMAT = "qtquick3d_assimp"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 6e3b8d7d..6f40cea6 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "d439739e15c100f257a1a1842770c4282dc9666e"
+SRCREV = "6de62741019a1686e0af5d4e78b5d0f50fa18853"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 00fb5021..eac549b6 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -49,7 +49,7 @@ EXTRA_QMAKEVARS_PRE_append_class-target = "\
${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=config_clang', 'CONFIG+=config_clang_done CONFIG-=config_clang', d)} \
"
-SRCREV = "d4342ab7e827960c417f9aa60340e8a56ff5a1c9"
+SRCREV = "c9e9fd967b38f975e7c5743b7f5c4316df99121e"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index f9aecee9..a2cb9105 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -98,4 +98,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "ae7c48d0547391b6a247e3365f084292e8af6ec9"
+SRCREV = "d350bec8d135f7080291c89b32266fc1e7873244"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 9a758fb4..fa7a4c95 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -43,7 +43,7 @@ PACKAGECONFIG[wayland-vulkan-server-buffer] = "-feature-wayland-vulkan-server-bu
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "eaeb21284ab7a3714c735ee8d7c348aa3bc3a07a"
+SRCREV = "ef0eeff3783ff81ed4146a58597beaa9199ea323"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f3b8ff25..4b5ffb4f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -190,8 +190,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0026-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "64e7fec600cf49a66d418b656bef2622529003e9"
-SRCREV_chromium = "3670a2bf53ddf847b499a777161e697e08ecc26b"
+SRCREV_qtwebengine = "f41dbaad0f0b554b3168df5456e57c3016bd5e43"
+SRCREV_chromium = "87e5a52b8860fc35e59e308a3468b015ba4c19ed"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index a6abb723..2e8e719f 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "34010e649734fe7a41d1a0280c606b15de5c2799"
+SRCREV = "57e447f19afb9fa58add302547c966e6f5c3b16f"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 29367e38..05f8f346 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -23,4 +23,4 @@ python() {
if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
}
-SRCREV = "1b514c3b7d1b5d6ddfbfd818cf878a425d2b5f8b"
+SRCREV = "48f2622cde5923d07d8b11e254079309a20e7f41"