aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb4
-rw-r--r--recipes-qt/maliit/maliit-plugins-qt5_git.bb3
2 files changed, 7 insertions, 0 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index fabb43ee..232e8252 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -57,6 +57,10 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=enable-dbus-activation \
CONFIG+=qt5-inputcontext \
"
+
+# tests fail to build with clang
+EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
do_install_append() {
diff --git a/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index 54bc7432..8225cb54 100644
--- a/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -23,6 +23,9 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=nodoc \
"
+# tests fail to build with clang
+EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+
FILES_${PN} += "\
${libdir}/maliit \
${datadir} \