aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-devtools/cmake/cmake_2.8.11.2.bbappend7
2 files changed, 8 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2aee9a55..3b47b7f7 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -12,7 +12,7 @@
BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/*/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "qt5-layer"
BBFILE_PATTERN_qt5-layer := "^${LAYERDIR}/"
diff --git a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
new file mode 100644
index 00000000..0ad2d2fb
--- /dev/null
+++ b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
@@ -0,0 +1,7 @@
+# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
+# and possibly missing qmake binary (qtbase-native can be removed from sysroot
+# e.g. in order to upgrade it, even when there is target qtbase)
+
+do_configure_prepend() {
+ sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt
+}