aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-python/pyqt5/python-pyqt5.inc4
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5.inc b/recipes-python/pyqt5/python-pyqt5.inc
index b830c9a9..47bf5b9d 100644
--- a/recipes-python/pyqt5/python-pyqt5.inc
+++ b/recipes-python/pyqt5/python-pyqt5.inc
@@ -24,11 +24,11 @@ export STAGING_LIBDIR
PARALLEL_MAKEINST = ""
-DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
+DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '', 'PyQt_OpenGL', d)}"
DISABLED_FEATURES_append_arm = " PyQt_qreal_double"
-PYQT_MODULES = "QtCore QtGui QtNetwork QtWidgets QtXml QtNetwork QtQml QtQuick QtQuickWidgets"
+PYQT_MODULES = "QtCore QtGui QtNetwork QtXml QtNetwork QtQml ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'QtQuick QtWidgets QtQuickWidgets', '', d)}"
do_configure_prepend() {
cd ${S}
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index e051b156..389686c9 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -10,5 +10,3 @@ python() {
DEPENDS += "sip sip-native python"
RDEPENDS_${PN} += "python-core python-sip"
-
-PNBLACKLIST[python-pyqt5] = "Sip fails in do_configure sip: QOpenGLFramebufferObject is undefined"