aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/examples/qt5-opengles2-test_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-qt/examples/qt5-opengles2-test_git.bb b/recipes-qt/examples/qt5-opengles2-test_git.bb
new file mode 100644
index 00000000..5da25dc9
--- /dev/null
+++ b/recipes-qt/examples/qt5-opengles2-test_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Qt5 OpenGL ES 2.0 Test Application"
+DESCRIPTION = "This application is used to test OpenGL ES 2.0 rendering \
+in a simple QWindow, plus multi-touch input, window orientation, window \
+focus handling and some other game-related features."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/main.cpp;beginline=1;endline=26;md5=93b83ece006c9e76b9fca80c3aecb169"
+
+PV = "1.0.4+gitr${SRCPV}"
+
+DEPENDS = "qtbase qtsensors"
+
+# Depends on gles2 enabled and that's not default configuration
+EXCLUDE_FROM_WORLD = "1"
+
+SRC_URI = "git://github.com/smk-embedded/qt5-opengles2-test.git"
+SRCREV = "938390507054ed1258345f70ed55770d2fe56176"
+S = "${WORKDIR}/git"
+
+inherit qmake5