aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qt5-lts.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
8 files changed, 9 insertions, 9 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 4bc90e74..17b799ab 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -195,4 +195,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "db2ed3fdc8f3a1e70cb5ac962f469217e9df4190"
+SRCREV = "f16edaecbf36a3090e10a1a290dbb8f1649c1e5b"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 2e4240a2..4ff6af27 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2020 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.15"
+QT_MODULE_BRANCH ?= "5.15.3"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
QT_MODULE_REPO ?= "${QT_MODULE}.git"
diff --git a/recipes-qt/qt5/qt5-lts.inc b/recipes-qt/qt5/qt5-lts.inc
index 0a5a3abe..c01e7526 100644
--- a/recipes-qt/qt5/qt5-lts.inc
+++ b/recipes-qt/qt5/qt5-lts.inc
@@ -4,7 +4,7 @@ QT_LTS_GIT ?= "git://codereview.qt-project.org/${QT_GIT_PROJECT}"
QT_GIT = "${QT_LTS_GIT}"
QT_LTS_GIT_PROTOCOL ?= "ssh"
QT_GIT_PROTOCOL = "${QT_LTS_GIT_PROTOCOL}"
-QT_MODULE_BRANCH = "tqtc/lts-5.15"
+QT_MODULE_BRANCH = "tqtc/lts-5.15.3"
QT_LTS_MODULE_REPO ?= "tqtc-${QT_MODULE}.git"
QT_MODULE_REPO = "${QT_LTS_MODULE_REPO}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 4e54cf65..17933e4a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -142,4 +142,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "db2ed3fdc8f3a1e70cb5ac962f469217e9df4190"
+SRCREV = "f16edaecbf36a3090e10a1a290dbb8f1649c1e5b"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e97b4d7c..357d28fd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -302,4 +302,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "db2ed3fdc8f3a1e70cb5ac962f469217e9df4190"
+SRCREV = "f16edaecbf36a3090e10a1a290dbb8f1649c1e5b"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 3f290ba3..d4630c7b 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -38,7 +38,7 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "5524add94f7a5fb43c572adcff9469230b5f1c61"
+SRCREV = "54f60b0fcc61ff036c1ab69d98180c9c154e3977"
# Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory
do_install_append() {
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 83015580..7213afb5 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -43,7 +43,7 @@ PACKAGECONFIG[wayland-vulkan-server-buffer] = "-feature-wayland-vulkan-server-bu
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "6bb05fed8fdb564f3ff0136bbdaf4efd6088797d"
+SRCREV = "991c8e9b9b4075a9b484af30ee275a2a7f72501c"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 371bac57..e0621f48 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -194,8 +194,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0025-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "4c94370394ccf1e00233669df01599cb6141a5dc"
-SRCREV_chromium = "a38752bff0fd3ae3e98ce973a437413e074403a0"
+SRCREV_qtwebengine = "a00fb61776425ed0f32d4d4052ffb1567f62e6d7"
+SRCREV_chromium = "4cb5565114c77a22dee9c337a5be1f7d8f3e463c"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"