aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/qmake5.bbclass2
-rw-r--r--recipes-qt/qt5/qt5.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native.inc (renamed from recipes-qt/qt5/qt5-native.inc)3
-rw-r--r--recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch (renamed from recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch)0
-rw-r--r--recipes-qt/qt5/qtbase-native_5.0.0+git.bb (renamed from recipes-qt/qt5/qt5-native_5.0.0+git.bb)2
-rw-r--r--recipes-qt/qt5/qtbase-native_5.0.1.bb (renamed from recipes-qt/qt5/qt5-native_5.0.1.bb)2
-rw-r--r--recipes-qt/qt5/qtbase.inc2
-rw-r--r--recipes-qt/qt5/qtbase/0001-Always-build-uic.patch (renamed from recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch)0
-rw-r--r--recipes-qt/qt5/qtjsbackend-native.inc2
9 files changed, 7 insertions, 8 deletions
diff --git a/classes/qmake5.bbclass b/classes/qmake5.bbclass
index 180cedcf..00d6c0ea 100644
--- a/classes/qmake5.bbclass
+++ b/classes/qmake5.bbclass
@@ -3,7 +3,7 @@
#
inherit qmake5_base
-QT5TOOLSDEPENDS ?= "qt5-native "
+QT5TOOLSDEPENDS ?= "qtbase-native "
DEPENDS_prepend = "${QT5TOOLSDEPENDS}"
export QMAKESPEC = "${STAGING_DATADIR}/qt5/mkspecs/${TARGET_OS}-oe-g++"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index e9b87a0b..97f3ee17 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -6,7 +6,7 @@ inherit qmake5_base
ICU = "icu "
ICU_powerpc = "pango"
-DEPENDS += "qt5-tools-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}"
+DEPENDS += "virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}"
require qt5_arch.inc
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qtbase-native.inc
index 1aa5c0ce..db1292cd 100644
--- a/recipes-qt/qt5/qt5-native.inc
+++ b/recipes-qt/qt5/qtbase-native.inc
@@ -2,7 +2,6 @@ DESCRIPTION = "Native version of Qt/[X11|Mac|Embedded]"
DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://qt-project.org"
-PROVIDES = "qt5-tools-native"
INC_PR = "r0"
@@ -10,8 +9,6 @@ inherit native
QT_MODULE = "qtbase"
-FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/qtbase:"
-
SRC_URI += " \
file://0001-qlibraryinfo-Allow-the-specification-of-where-to-loa.patch \
file://0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch \
diff --git a/recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch b/recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch
index 1b294fd2..1b294fd2 100644
--- a/recipes-qt/qt5/qt5-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch
+++ b/recipes-qt/qt5/qtbase-native/0003-qtbase-Allow-qt.conf-override-when-bootstrapping.patch
diff --git a/recipes-qt/qt5/qt5-native_5.0.0+git.bb b/recipes-qt/qt5/qtbase-native_5.0.0+git.bb
index e99971fb..80d80565 100644
--- a/recipes-qt/qt5/qt5-native_5.0.0+git.bb
+++ b/recipes-qt/qt5/qtbase-native_5.0.0+git.bb
@@ -1,4 +1,4 @@
-require qt5-native.inc
+require ${PN}.inc
require qt5-5.0.0+git.inc
PR = "${INC_PR}.0"
diff --git a/recipes-qt/qt5/qt5-native_5.0.1.bb b/recipes-qt/qt5/qtbase-native_5.0.1.bb
index f822a3e3..f5d96130 100644
--- a/recipes-qt/qt5/qt5-native_5.0.1.bb
+++ b/recipes-qt/qt5/qtbase-native_5.0.1.bb
@@ -3,5 +3,7 @@ require qt5-${PV}.inc
PR = "${INC_PR}.0"
+SRC_URI += "file://0001-Always-build-uic.patch"
+
SRC_URI[md5sum] = "720e5061d75913dfa97bf8bef4a443df"
SRC_URI[sha256sum] = "6f8a0489eb057f6cba5e77cabaec13dcd010da562b3b88f91fe960022d7c37c8"
diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc
index 2b14de1e..f420d37a 100644
--- a/recipes-qt/qt5/qtbase.inc
+++ b/recipes-qt/qt5/qtbase.inc
@@ -8,7 +8,7 @@ SRC_URI += " \
file://qplatformdefs.h \
"
-DEPENDS += "qt5-tools-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}"
+DEPENDS += "qtbase-native virtual/libgl freetype jpeg libpng zlib openssl glib-2.0 ${ICU}"
# to provide xcb/xcb_icccm.h, xcb/xcb_image.h, xcb/xcb_keysyms.h and dbus/dbus.h
# DEPENDS += "xcb-util-wm xcb-util-image xcb-util-keysyms dbus"
diff --git a/recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0001-Always-build-uic.patch
index 3f2e3fd9..3f2e3fd9 100644
--- a/recipes-qt/qt5/qt5-native/0001-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0001-Always-build-uic.patch
diff --git a/recipes-qt/qt5/qtjsbackend-native.inc b/recipes-qt/qt5/qtjsbackend-native.inc
index 8a66229a..37e2b80d 100644
--- a/recipes-qt/qt5/qtjsbackend-native.inc
+++ b/recipes-qt/qt5/qtjsbackend-native.inc
@@ -1,7 +1,7 @@
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
-DEPENDS = "qt5-native"
+DEPENDS = "qtbase-native"
QT_MODULE = "qtjsbackend"