aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb7
-rw-r--r--recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb9
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb9
4 files changed, 26 insertions, 3 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index b8b1d086..e051b156 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -1,6 +1,11 @@
require python-pyqt5.inc
-inherit pythonnative python-dir
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative python-dir", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
DEPENDS += "sip sip-native python"
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
index 44bdf18c..8ae0e9ef 100644
--- a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
+++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb
@@ -4,6 +4,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
LICENSE = "GPLv3"
DEPENDS = "qtwebengine"
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('qtwebengine dependency requires meta-python2 to be present.')
+}
SRC_URI = " \
git://github.com/OSSystems/qt-kiosk-browser;protocol=https \
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index e42cf491..c00120b3 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -79,10 +79,17 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)"
inherit qmake5
inherit gettext
-inherit pythonnative
inherit perlnative
inherit features_check
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
+
+
# Static builds of QtWebEngine aren't supported.
CONFLICT_DISTRO_FEATURES = "qt5-static"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 6cc789f0..942e733a 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,7 +18,14 @@ SRC_URI += "\
file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
"
-inherit cmake_qt5 perlnative pythonnative
+inherit cmake_qt5 perlnative
+
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
# qemuarm build fails with:
# | {standard input}: Assembler messages: