aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb9
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb9
2 files changed, 12 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index b1e155e2..f677f710 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -13,11 +13,14 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[bluez4] = "OE_BLUEZ_ENABLED,,bluez4"
+inherit bluetooth
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
+
+EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
do_configure_prepend() {
- export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}"
# disable bluez test if it isn't enabled by PACKAGECONFIG
sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro
}
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 27d2bff3..9d9d245d 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -11,11 +11,14 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative udev gconf"
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[bluez4] = "OE_BLUEZ_ENABLED,,bluez4"
+inherit bluetooth
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
+
+EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
do_configure_prepend() {
- export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}"
# disable bluez test if it isn't enabled by PACKAGECONFIG
sed -i 's/^ qtCompileTest(bluez)/ OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtsystems.pro
}